These are chat archives for DrupalRu/chat

7th
Sep 2017
Alexey
@alexsco74
Sep 07 2017 04:34
С добрым утром, други :)
Tahtabaev Ildar
@Tahtabaev
Sep 07 2017 05:51
привет всем
Alexey
@alexsco74
Sep 07 2017 05:51
Hi
Tahtabaev Ildar
@Tahtabaev
Sep 07 2017 05:52
@alexsco74 а /admin/content это модуль же отдельны?
не на вьюхе
Maksim Baev
@mbaev
Sep 07 2017 05:59
Привет, это стандартная страница материала, но может перекрываться вьюхой. Например, модуль admin_views создаёт вьюху и помещает не туда.
Tahtabaev Ildar
@Tahtabaev
Sep 07 2017 06:08
@mbaev а нельзя сделать, чтоб для определенной роли, только поределенный тип материала там был?
Tahtabaev Ildar
@Tahtabaev
Sep 07 2017 06:14
о, в теории раз вьюха, можно хоть что сделать
Maksim Baev
@mbaev
Sep 07 2017 06:38
Определенной роли можно либо дать доступ к странице, либо к просмотру типа материала.
Либо можно дать смотреть все, а редактировать определенные
Alexey
@alexsco74
Sep 07 2017 06:38

@Tahtabaev

@alexsco74 а /admin/content это модуль же отдельны?

не на views
Maksim Baev
@mbaev
Sep 07 2017 06:39
Ну это в пермишенов рулится
Tahtabaev Ildar
@Tahtabaev
Sep 07 2017 06:41
@mbaev вот чет я настривал права, а толку нету, править может, а на той странице не видит, сейчас админ вьюсом пропробую
@mbaev а на simplecloud, обязательно сразу паспортные данные заполнять?
Maksim Baev
@mbaev
Sep 07 2017 08:21
@Tahtabaev не, не обязательно
только там пароль нельзя будет на свой поменять
но есть хак
можно сбросить пароль)
Tahtabaev Ildar
@Tahtabaev
Sep 07 2017 09:36
@mbaev пароль рута?)
Maksim Baev
@mbaev
Sep 07 2017 09:53
пароль аккаунта)
bardachev
@bardachev
Sep 07 2017 10:01
Привет всем!
Alexey
@alexsco74
Sep 07 2017 10:02
@bardachev Хай
bardachev
@bardachev
Sep 07 2017 10:02
Пишу клиенту про то что нужно перейти д6 -> д8. Подскажите, как правильно - Д6 не поддерживается сообществом, или д6 не поддерживается Аквией?
@alexsco74 хай!
Alexey
@alexsco74
Sep 07 2017 10:03
@bardachev Как это не поддерживается - очень даже поддерживается :)
Они за деньги, только плати
bardachev
@bardachev
Sep 07 2017 10:03
мм. Кем?
Alexey
@alexsco74
Sep 07 2017 10:03
org
там полно предложений
О всяких бэкдроп я уже молчу
bardachev
@bardachev
Sep 07 2017 10:05
не, постой. д6 поддерживается не сообществом. д6 может поддерживаться отдельными компаниями.
бэкдроп вроде про 7ку
Alexey
@alexsco74
Sep 07 2017 10:05
@bardachev А зачем клиенту сообщество ? Оно его поддерживает?
:)
Наверно его компания/человек поддерживает!?
Пугай короче - отсутствием поддержки бесплатной безопасности - заплатки не выходят :)
Maksim Baev
@mbaev
Sep 07 2017 10:07

@bardachev acquia не поддерживает d6.
Drupal прекратил оффициальную поддержку d6
backdrop - форк от d7

--
За деньги можно перевести что угодно, куда угодно.

bardachev
@bardachev
Sep 07 2017 10:07
Клиенту нужна дешевизна. Мы, компания, пользуясь наработками сообщества, поддерживаем клиента. Если сообщество прекращает поддерживать д6, нам становится сложнее, цена возрастает.
Maksim Baev
@mbaev
Sep 07 2017 10:07
Ушёл
Alexey
@alexsco74
Sep 07 2017 10:07
@bardachev Много компаний и людей поддерживают D6
А вот ег=сли его 6 сайт хакнут , он может понести финансовые потери
bardachev
@bardachev
Sep 07 2017 10:08
@alexsco74 та ну зачем эта философия. Это и так понятно.
Alexey
@alexsco74
Sep 07 2017 10:08
@bardachev Вообще это целесообразность финансовая и мотивация для клиента
@bardachev Но ты конечно можешь задовить сообщестовм попробовать
bardachev
@bardachev
Sep 07 2017 10:09
у меня был простой вопрос. Кто ответственный за поддержку Д7 например сейчас - Аквия или сообщество, или оба?
Alexey
@alexsco74
Sep 07 2017 10:09
@bardachev Вроде ты про 6 спрашивал?
Или про 7 все таки?
bardachev
@bardachev
Sep 07 2017 10:11
@alexsco74 да. Я пытался перефразировать вопрос - кто был ответственный за поддержку д6 пока он был официально на поддержке и получал обновления? Сообщество или Аквия?
да, вопрос про д6. Но он также и про д7 и про д8.
Alexey
@alexsco74
Sep 07 2017 10:12
@bardachev core не знаю кто штопает , контрибы - сами авторы
bardachev
@bardachev
Sep 07 2017 10:13

@bardachev Но ты конечно можешь задовить сообщестовм попробовать

у меня нет цели кого-то "давить". Нужно написать обоснование перехода d6-d8

Alexey
@alexsco74
Sep 07 2017 10:14
@bardachev Сначала выясни приритеты клиента в отношении сайта, от них зависит обоснование
Практика показывает что до сих пор используется 6 7 8 :)
bardachev
@bardachev
Sep 07 2017 10:17
с контрибами понятно. Но и даже с контрибами, вот к примеру Drupal Security Team - она от сообщества или от Аквии?
Alexey
@alexsco74
Sep 07 2017 10:18
маинтейнер же делает, а есть разница где он работает?
bardachev
@bardachev
Sep 07 2017 10:18
что делает?
Alexey
@alexsco74
Sep 07 2017 10:18
Обновления
bardachev
@bardachev
Sep 07 2017 10:19
да. Но команда безопасности делает аудит безопасности контрибов и заставляет майнтейнеров закрывать дырки
Alexey
@alexsco74
Sep 07 2017 10:19
Обновления проверяются автоматически, зачем тебе ещё какие то страницы?
bardachev
@bardachev
Sep 07 2017 10:20
Лёш, ты философ. Не в обиду.
Alexey
@alexsco74
Sep 07 2017 10:20
Есть требования к контрибам, чтобы скрафтить контриб тебя будут проверять и код
@bardachev Есть жестки регламент
Его испольняют волонтеры, они могут быть фриланс могу работать в конторах
Это же Open Source или что-то поменялось в лицензии?
Лёш, ты философ. Не в обиду.
Наоборот - комплимент :red_circle:
Drupal Security Team - кто то её ведет - ссыль дай ?!
вот и у меня вопрос - кто её ведёт.
Alexey
@alexsco74
Sep 07 2017 10:23
на ней нет упоминания автора и компании типа аквии
Значит сообщество
bardachev
@bardachev
Sep 07 2017 10:23
Ну вот по идее да, я уже прочитал.
Alexey
@alexsco74
Sep 07 2017 10:24
А вот снизу Drupal is a registered trademark of Dries Buytaert.
:)
Drupal’s online documentation is © 2000-2017 by the individual contributors and can be used in accordance with the Creative Commons License, Attribution-ShareAlike 2.0. PHP code is distributed under the GNU General Public License.
Всё конкретно, даже не пофилосовствуешь :)
bardachev
@bardachev
Sep 07 2017 10:25
The security team is an all-volunteer group of individuals who work to improve the security of the Drupal project. These members were part of the team previously (and may potentially re-join in the future) but they are not current members.
Alexey
@alexsco74
Sep 07 2017 10:25
34 члена - это хорошо
Но они не делают обновление безопасностей контриб модулей
bardachev
@bardachev
Sep 07 2017 10:26
да, но они важная часть экосистемы безопасности Друпала
Alexey
@alexsco74
Sep 07 2017 10:27
Да важная
The security team is an all-volunteer group of individuals who work to improve the security of the Drupal project. These members were part of the team previously (and may potentially re-join in the future) but they are not current members.
12 13 свободны :)
3-х даже расстреляли
а нет 4-х
т.е. 30 членов
bardachev
@bardachev
Sep 07 2017 10:29
а говоришь совбодное сообщество. В застенках Аквии замучены.
те 4
Здесь больше
bardachev
@bardachev
Sep 07 2017 10:30
да, то список был основателей, не действующитх членов
Alexey
@alexsco74
Sep 07 2017 10:30
Эх
редеют члены
Отйы так сказать - основатели
bardachev
@bardachev
Sep 07 2017 10:31
кароч ответ на мой вопрос - д6 не поддерживается официальным Д сообществом.
Alexey
@alexsco74
Sep 07 2017 10:31
А ссыль можно?
bardachev
@bardachev
Sep 07 2017 10:31
Кажется Аквия напрямую никак с этим не связана.
Alexey
@alexsco74
Sep 07 2017 10:32
На официальный документ в инете?
bardachev
@bardachev
Sep 07 2017 10:32
ссыль на ответ? я его придумал, ссыли нет :)
Alexey
@alexsco74
Sep 07 2017 10:32
Гы , молодца
bardachev
@bardachev
Sep 07 2017 10:32
не, ну а ты как считаешь?
Alexey
@alexsco74
Sep 07 2017 10:32
@bardachev не связана, не поддерживается - подерживаю тебя!
bardachev
@bardachev
Sep 07 2017 10:33

https://www.drupal.org/drupal-security-team/general-information

Which versions are supported?
Only the current and one previous version of Drupal are actively supported, currently 8.x and 7.x. Upgrade if you are using an unsupported version of Drupal.

Alexey
@alexsco74
Sep 07 2017 10:34
Ну да безопасность - не поддерживается
bardachev
@bardachev
Sep 07 2017 10:34
ну а что тогда поддерживается?
Alexey
@alexsco74
Sep 07 2017 10:35
Клиенты :)
За деньги
bardachev
@bardachev
Sep 07 2017 10:35
кем?
Alexey
@alexsco74
Sep 07 2017 10:35
Всеми желающими где то они даже писали об этом
надо поискать
bardachev
@bardachev
Sep 07 2017 10:35
клиенты и так за деньги обычно поддерживаются :) И которые на д7 и на д8
Alexander Dubovskoy
@adubovskoy
Sep 07 2017 10:37
да с 6й другой вопрос. там контриб не держит php >5.2, ядро 5.3
Alexey
@alexsco74
Sep 07 2017 10:38
да с 6й другой вопрос. там контриб не держит php >5.2, ядро 5.3
bardachev
@bardachev
Sep 07 2017 10:38
@adubovskoy ну это правда другой вопрос :)
Alexander Dubovskoy
@adubovskoy
Sep 07 2017 10:38
а secyrity fix поддержка php 5.4 кончилась еще в 2014.
Alexey
@alexsco74
Sep 07 2017 10:38
Его можно сделать совместимым с пыхом 5.6 точно
bardachev
@bardachev
Sep 07 2017 10:38
@adubovskoy но тоже не маловажный
Alexander Dubovskoy
@adubovskoy
Sep 07 2017 10:39

Его можно сделать совместимым с пыхом 5.6 точно

ага, но проще миграции написать на d8, чем переписать весь контриб)

Alexey
@alexsco74
Sep 07 2017 10:39
Насчет 7 пыха не совру

Его можно сделать совместимым с пыхом 5.6 точно

ага, но проще миграции написать на d8, чем переписать весь контриб)

Позвольте не согласится так как делал :)
Извини Саша, но я это делал
Alexander Dubovskoy
@adubovskoy
Sep 07 2017 10:40
drush pml в студию
Alexey
@alexsco74
Sep 07 2017 10:40
Мне не за чем , д аи есть правила клиентской этики
Но меня убеждать в том что это долго ии не возможно - не получится :)
Alexander Dubovskoy
@adubovskoy
Sep 07 2017 10:42
я не говорю что невозможно. уберкарт там был? или какойнть другой емкий контриб типа OG?
bardachev
@bardachev
Sep 07 2017 10:42
@adubovskoy а ты как считаешь, какое отношение Аквия имеет к тому, что д6 сейчас не поддерживается официальным сообществом?
или никакого?
Alexey
@alexsco74
Sep 07 2017 10:43
@adubovskoy Ubercart и это 2-3 дня максимум
работы
магазин
Alexander Dubovskoy
@adubovskoy
Sep 07 2017 10:43

@adubovskoy а ты как считаешь, какое отношение Аквия имеет к тому, что д6 сейчас не поддерживается официальным сообществом?

переформулирую вопрос: как аквия относится к тому что друпал-сообщество соблюдает цикл поддержки, который сами же выбрали. )

bardachev
@bardachev
Sep 07 2017 10:43
ну или так
Alexander Dubovskoy
@adubovskoy
Sep 07 2017 10:44

@adubovskoy Ubercart и это 2-3 дня максимум

оптимизм и отвага)

в смысле я не спорю, может и 2-3 дня. но это сложно прогнозировать. я бы не рискнул клиенту такое предложить - могу легко ошибиться в оценке
Alexey
@alexsco74
Sep 07 2017 10:44
@adubovskoy я сразу после экспоресса убеждал клиента перейти, потом сказал, что всё равно надо пых обновить, он кстати сказал что его уверяли про то что невозможно :)
Alexey Kuznetsov
@alexey-kuznetsov
Sep 07 2017 10:45
о чём шум? 6 vs 8? )))
Alexey
@alexsco74
Sep 07 2017 10:45
Вообщем я обеими руками за 8-ку , поэтому и торговлю пищшу свою, но поддерживать можно реально и 6 7 8
@alexey-kuznetsov Да не @bardachev нужны аргументы для клиента чтобы убедить его перейти на 9 -ку :)
Alexey Kuznetsov
@alexey-kuznetsov
Sep 07 2017 10:47
ясно понятно))
Alexander Dubovskoy
@adubovskoy
Sep 07 2017 10:48
у нас кстати на хостинге кстати есть bacport/community secutiry fixes старых версий php, с 4.4.9, https://www.cloudlinux.com/hardenedphp
bardachev
@bardachev
Sep 07 2017 10:48
не то чтобы нужны аргументы, меня самого заинтересовал вопрос места Аквии в деле поддержки. Аргументы у меня есть.
ну и захотелось написать правильно.
bardachev
@bardachev
Sep 07 2017 11:06

@alexsco74

поэтому и торговлю пищшу свою

это очень интересно! А есть где посмотреть?

Alexey Kuznetsov
@alexey-kuznetsov
Sep 07 2017 14:49
drush: command not found
пащиму!
не тот путь
Alexey Kuznetsov
@alexey-kuznetsov
Sep 07 2017 15:38
может есть у кого ссыль на настройку phpmyadmin + php7.1 + nginx?
onlyextart
@onlyextart
Sep 07 2017 16:00
привет всем
как можно через альтер достать поле из другой формы?