by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Punit
    @punit-creolestudios
    Hello , i have just created Dwolla sandbox account. and trying to implement this examples,
    but i am getting following error.
    Can you please help me ?

    Fatal error: Class 'GuzzleHttp\Client' not found in C:\xampp\htdocs\punit\dwolla\lib\client.php on line 348

    David Stancu
    @mach-kernel
    hey @punit-creolestudios, I saw your messages
    what error are you getting specifically from composer?
    Punit
    @punit-creolestudios

    c:\xampp\htdocs\punit>cd d2

    c:\xampp\htdocs\punit\d2>composer install
    Loading composer repositories with package information
    Installing dependencies (including require-dev)
    Your requirements could not be resolved to an installable set of packages.

    Problem 1

    - The requested package dwolla/dwolla-php No version set (parsed as 1.0.0) c

    ould not be found.

    Potential causes:

    Read https://getcomposer.org/doc/articles/troubleshooting.md for further commo
    n problems.

    c:\xampp\htdocs\punit\d2>

    i am using same composer.json you have added in https://github.com/Dwolla/dwolla-php

    Thanks

    Punit

    David Stancu
    @mach-kernel
    ah, @punit-creolestudios, all you need to do is specify a version constraint
    so do composer require dwolla-php 2.*
    and it should work
    Punit
    @punit-creolestudios

    Microsoft Windows [Version 6.1.7600]
    Copyright (c) 2009 Microsoft Corporation. All rights reserved.

    C:\Users\DSK09>cd c:/xampp/htdocs/punit/d2

    c:\xampp\htdocs\punit\d2>composer install
    Loading composer repositories with package information
    Installing dependencies (including require-dev) from lock file
    Nothing to install or update
    Generating autoload files

    c:\xampp\htdocs\punit\d2>composer require dwolla-php 2.*
    ./composer.json has been updated
    Loading composer repositories with package information
    Updating dependencies (including require-dev)
    Your requirements could not be resolved to an installable set of packages.

    Problem 1

    - The requested package dwolla-php could not be found in any version, there

    may be a typo in the package name.

    Potential causes:

    Read https://getcomposer.org/doc/articles/troubleshooting.md for further commo
    n problems.

    Installation failed, reverting ./composer.json to its original content.

    c:\xampp\htdocs\punit\d2>


    still same problem buddy. :-(
    David Stancu
    @mach-kernel
    try
    composer require dwolla/dwolla-php
    sorry
    Punit
    @punit-creolestudios

    Again . . .

    c:\xampp\htdocs\punit>cd d2

    c:\xampp\htdocs\punit\d2>composer require dwolla/dwolla-php
    Using version ^2.1 for dwolla/dwolla-php
    ./composer.json has been updated
    Loading composer repositories with package information
    Updating dependencies (including require-dev)
    Your requirements could not be resolved to an installable set of packages.

    Problem 1

    - The requested package dwolla/dwolla-php No version set (parsed as 1.0.0) c

    ould not be found.

    Potential causes:

    Read https://getcomposer.org/doc/articles/troubleshooting.md for further commo
    n problems.

    Installation failed, reverting ./composer.json to its original content.

    c:\xampp\htdocs\punit\d2>


    Help me dude . it seem there are some problems with this composer library . .

    Punit
    @punit-creolestudios
    Hello , you got any solution ? ?
    Punit
    @punit-creolestudios
    Hello, Anybody there to help me ?
    David Stancu
    @mach-kernel
    hi @punit-creolestudios, I just tried to reproduce the issue on OS X and Windows and was unable to
    how about this
    let's hop on a screenshare call sometime today so I can walk you through installing this
    this is how I did it in both instances
    Punit
    @punit-creolestudios
    This way its installing Dwolla successfully , But after when i try use the examples given in dwolla-php folder. it throws the error that " Fatal error: Class 'GuzzleHttp\Client' not found in C:\xampp\htdocs\punit\d5\vendor\dwolla\dwolla-php\lib\client.php on line 348 "
    Can we talk on skype if it is possible , ? my skype id: punit.creolestudios
    David Stancu
    @mach-kernel
    that is because you need to do at the top of your php file
    require 'vendor/autoload.php';
    // do stuff here
    the autoloader will hotload all the classes that you need
    we can skype if you wish but sending me code snippets of your PHP would be more helpful :)
    Punit
    @punit-creolestudios
    Yeah sure buddy , please add me on skype : punit.creolestudios
    marlonbuendia
    @marlonbuendia
    Hi guys
    anyone there to help me?
    my Dwolla sandbox does not have enough money for sending. what should i do?
    David Stancu
    @mach-kernel
    Hi @marlonbuendia, what's your Sandbox dwolla account?
    let me send you some money! :)
    kendantinio
    @kendantinio
    Hi this is marlon, using another account. I have no idea where to find my dwolla ID. Does dwolla provide test bank accounts?
    David Stancu
    @mach-kernel
    @kendantinio, you can use the e-mail you signed up with as your dwolla id
    or by clicking on the gear