Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • 03:00
    dependabot[bot] labeled #311
  • 03:00
    dependabot[bot] labeled #311
  • 03:00

    dependabot[bot] on maven

    Bump jackson-databind from 2.11… (compare)

  • 03:00
    dependabot[bot] opened #311
  • 03:00
    dependabot[bot] labeled #310
  • 03:00
    dependabot[bot] labeled #310
  • 03:00
    dependabot[bot] opened #310
  • 03:00

    dependabot[bot] on maven

    Bump jackson-databind from 2.11… (compare)

  • Apr 15 2021 15:56

    mandar2812 on master

    Updated TF Scala version. (compare)

  • Mar 19 2021 13:28

    mandar2812 on master

    minor mods. (compare)

  • Mar 17 2021 11:02

    mandar2812 on master

    Updated POMs (compare)

  • Mar 17 2021 08:05

    dependabot[bot] on maven

    (compare)

  • Mar 17 2021 08:04

    dependabot[bot] on maven

    (compare)

  • Mar 17 2021 08:04

    dependabot[bot] on maven

    (compare)

  • Mar 17 2021 08:04

    dependabot[bot] on maven

    (compare)

  • Mar 17 2021 08:04
    dependabot[bot] commented #304
  • Mar 17 2021 08:04
    dependabot[bot] commented #303
  • Mar 17 2021 08:04
    dependabot[bot] commented #302
  • Mar 17 2021 08:04
    mandar2812 closed #304
  • Mar 17 2021 08:04
    dependabot[bot] commented #301
Israel Herraiz
@iht
it did not work in my case
breeze is also imported by spark
So I removed the import of breeze, and excluding org.spire-math in the spark dependencies
Mandar Chandorkar
@mandar2812
after excluding spire from breeze, the project compiles but running legacy code is having a runtime error
Mandar Chandorkar
@mandar2812
okay I realise that including tensorflow_scala is causing all sorts of problems with respect to spire dependency resolution
i am going to spend some time to find out how we can resolve them
Israel Herraiz
@iht
thank you for that :)
Mandar Chandorkar
@mandar2812
because tensorflow support is going to be an important feature in DynaML
so i dont want to sacrifice it!
:D
Israel Herraiz
@iht
the main problem is because tensorflow is redefining the organization of spire (and others)
and spire is imported without using the organization name
the package names in spire should include the organization
and tensorflow should not rename the organizations
that way, it would be easy to let sbt handle the conflicts
Mandar Chandorkar
@mandar2812
From what I know about the spire project i know there are two orgs which deliver it
and
typelevel
Israel Herraiz
@iht
yes
Mandar Chandorkar
@mandar2812
breeze imports spire from the first one
while TF imports from second
Israel Herraiz
@iht
and who is republishing spire? typelevel?
Mandar Chandorkar
@mandar2812
yes i think typelevel took over it
Israel Herraiz
@iht
maybe it is related to this project? -> https://github.com/typelevel/algebra
Mandar Chandorkar
@mandar2812
which is why the newest versions all come from the source 2
while spire older versions < 0.13
come from source 1
Israel Herraiz
@iht
ahm!
Mandar Chandorkar
@mandar2812
yes
Israel Herraiz
@iht
and breeze is still using the old versions
Mandar Chandorkar
@mandar2812
yes
i guess from a long term perspective I would prefer to use typelevel
but breeze is used heavily in legacy code of DynaML
Mandar Chandorkar
@mandar2812
Hi @iht I think I have a bunch of sbt exclusions which might solve this spire issue!
I will push some changes to the main branch soon
please give them a try, after refreshing your coursier and ivy2 caches and tell me if it works
Israel Herraiz
@iht
are they in master?
ah
Mandar Chandorkar
@mandar2812
yes soon
Israel Herraiz
@iht
i did not read the second sentence :)
i will give it a try and will provide feedback
Mandar Chandorkar
@mandar2812
in a few minutes if everything goes well on my side
thanks!
Israel Herraiz
@iht
Thanks a lot !!
Mandar Chandorkar
@mandar2812
You can check out transcendent-ai-labs/DynaML@b997b29
it seems to be working for me with respect to spire
Israel Herraiz
@iht
great, i have pulled those changes
Mandar Chandorkar
@mandar2812
and now spire 0.14.1 is used as a direct dependency in DynaML