Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Martin Gottweis
    @Gottwik
    do you get any errors?
    what does stopped working mean?
    can you console.log something from the extension?
    or just wait, I'll try to check this in the evening
    could be that this got broken with introduction of the brick/plugin infrastructure
    (tests are passing though...)
    Martin Gottweis
    @Gottwik
    @tmclemons just checked and the admin extension logic seems to be working just fine
    Sergutsu
    @Sergutsu_twitter
    some noob questions: how to change default port of app, how to run on server in background and reload mode
    Martin Gottweis
    @Gottwik
    you have 3 options:
    environment variable: PORT=5001 enduro dev
    cli flag: enduro dev --port=5001
    or via enduro.json config file, just add port: 5001 line there
    Let me know if this works for you
    Nick Lambert
    @rnlambert7
    Hey @Gottwik you asked for suggestions for the docs. Definitely add every type of terminator or field option. For instance I found _size for arrays so I could make arrays full width instead of bootstraps col-md-4. Any others would be great, these are very useful and as you make more would be much easier than searching enduro’s code for them :P
    Sergutsu
    @Sergutsu_twitter
    Thank you Martin, cli flag worked, now what about daemonizing app and restarting when server reloads?
    Martin Gottweis
    @Gottwik
    @rnlambert7 yea, that's a good tip
    @Sergutsu_twitter I use heroku, which takes care of that. Others use pm2 and it sounds like it's working fine.
    Nick Lambert
    @rnlambert7
    @Gottwik Any chance of allowing generator template files go deeper than one level? I understand inside /cms/generators/:generator name/:pagename keeping that one level for simplicity, however inside /pages/generators/:generatorname.hbs I cannot go any deeper. (For instance if I wanted /here/is/an-awesome/page using generators)
    Nick Lambert
    @rnlambert7
    I can probably rephrase it better. When you create a new generated page it creates it at the first level of the folder still, no matter how deep you nest folders. However the pages/generators can seem to still get the files, but there’s some wierdness there.
    Nick Lambert
    @rnlambert7
    I went ahead and just made this an issue, since there are bugs related to it: Gottwik/Enduro#184
    Martin Gottweis
    @Gottwik
    @rnlambert7 sorry for late reply
    good ideas
    khalid-valed
    @khalid-valed
    Hi folks ,
    I kind of stuck on installation part, tried quickly go through above comments and I guess no body has that problem yet
    so I have nodejs v9.3.0 and npm 5.5.1
    under linux mint 18
    I am getting this : fetchMetadata: sill fetchPackageMetaData error for promised-handlebars@git+https://github.com/Gottwik/promised-handlebars.git Command
    while i am running npm install enduro -g
    khalid-valed
    @khalid-valed
    I wanted to use cms for tech docs purposes and enduro would be best fit to our company
    dbj
    @DBJDBJ

    Has anyone tested this on Win10 ?

    <pre>
    dusan@WS01 MINGW64 /d/github/dbjduro
    $ enduro dev

    ┌————————————————————~—Enduro started—~————————————————————┐
    │ Development server started at: │
    │ localhost:3000 │
    │ Admin ui available at: │
    │ localhost:5000/admin │
    ├——————————————————————————————————————————————————————————┤
    │ Admin has no live-reload! │
    └——————————————————————————————————————————————————————————┘
    [14:04:07 | + 4.2] developer start
    [14:04:07 | + 0.08] Render started
    [14:04:07 | + 0.02] js compiling not enabled, add babel options to enduro.json to enable
    [14:04:07 | + 0] Sass compiling started


    ▼▼▼▼▼▼▼▼▼▼▼▼▼▼▼▼▼▼▼▼▼▼▼▼ Sass error ▼▼▼▼▼▼▼▼▼▼▼▼▼▼▼▼▼▼▼▼▼▼▼▼
    assets\css\vendor\bootstrap_selection.scss
    Error: File to import not found or unreadable: ../../vendor/bootstrap/scss/variables.
    Parent style sheet: D:/github/dbjduro/assets/css/vendor/bootstrap_selection.scss
    on line 2 of assets/css/vendor/bootstrap_selection.scss
    >> @import '../../vendor/bootstrap/scss/variables';
    ^

    ▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲▲


    [14:04:07 | + 0.06] Sass compiling finished
    [14:04:07 | + 0.04] Render finished
    [14:04:07 | + 0] browsersync started
    [14:04:07 | + 0.02] production server starting
    [14:04:07 | + 0.06] Production server started at port 5000
    </pre>

    This is what I get after following the readme ...

    Travis D. Warlick, Jr.
    @tekwiz
    @Gottwik Any particular reason bluebird is used in Enduro server side? I can’t find any Promise functionality in Enduro that bluebird provides that’s not native to Node.js 6 (quick reference: http://node.green/). Presuming that is accurate, would you entertain a pull-request to remove the dependency?
    @DBJDBJ This may be too late, but I think you need to run bower to install the vendor dependencies to dev in the admin. Run bower install
    Joe Qureshi
    @JoeQureshi
    Quick q - Im trying to minify css using express-minify. I added the code needed to my app.js in the init function (where my js compression stuff is) and it doesn't look like anything is being minifyed. Could anyone suggest a way of debugging this issue? Thanks!
    dbj
    @DBJDBJ

    @tekwiz "../ may be too late" sounds a bit ominous :) OK, win10 + enduro.js it seems does not "entertain" in either dev or prod mode ... I even went as far as installing Ubuntu VM .. bat have given up on that since I have no time to entertain this kind of projects ... yet. Meaning it is me who is not ready, Enduro perhaps is.

    As a matter of interest can we somehow proceed in some separate "room" or whatever? I have few high level questions to ask.

    cykohl
    @cykohl
    Does someone deploy enduro to Amazon beanstalk?
    Nico Saueressig
    @NicoSa
    I'm trying out endurojs for a bigger project right now and I really like it - however I am seeing inconsistent csr/ssr behaviour across browsers. this is the test app: https://test-heidelboarding.herokuapp.com/en/ Anybody have an idea how I could fix it or is there a way to disable CSR possibly? Could be a problem with how I am embedding the js snippets maybe?
    Travis D. Warlick, Jr.
    @tekwiz
    @Gottwik Do you have a policy on compatibility & versioning for Enduro and the Enduro admin?
    Travis D. Warlick, Jr.
    @tekwiz
    @NicoSa It looks like you’ve got the rendering behavior fixed up, but let me know if I can still help.
    Alexander Dominguez
    @anderalexdr
    Hi there! I have my enduro app in Digital Ocean. I'm using SSH to connect to the server. It works when I type in the terminal 'enduro start'. My question is: How could I leave the server without killing the enduro process? Thanks in advance. :')
    Nico Saueressig
    @NicoSa
    @tekwiz Hm, is it? What I mean by inconsistency is that I see a lot of page reloads. I would expect more CSR, I mean it's not a very dynamic site lol.
    Travis D. Warlick, Jr.
    @tekwiz
    @NicoSa I think I comprehend what you’re referring to now — on the Reservation page. If that’s what you’re concerned about, it looks like there are some substantial performance issues, but they are coming from the booking.viatocrs.de site. I don’t see anything you can do on your site.
    Egor Kin
    @Wigtertainment
    Hi there, does anybody of you have a problem with Multilingual, if you use a collection in your content files?
    galingong
    @galingong
    Cheers, what's the most convenient way to have enduro generate minified css from scss?
    Nikita Nafranets
    @dimensi
    hi, how i can extend gulp? How minify css,js and other? How server simple static ?
    Leon
    @leonio
    Hi all, really enjoying Enduro (thanks) - I've found an oddity with multilingual functionality. In dev mode the url site/de/index will render quickly as you'd expect, but when using the production mode this times out, or after many requests will finally render... it only happens for non root sites, and for the default culture this is no delay. There is no custom express code used here, so am trying to figure out why this is the case (happens both locally, on Heroku and Azure)
    Leon
    @leonio
    oops, found the problem - seems that when a url looks for a *.css file (which is was due to a problematic template) it will skip this in the exclude calls... unsure as to why this brings down the full request.
    EuroWeb5.com
    @euroweb5_twitter
    Hello guys!
    i am exploring Enduro, just discovered it! I have cloned the endurojs_website from github as i believe this is the fastest way to see all enduro features in action and learn
    but i can't access admin area. Can i remove existing admin user and create new one?
    Saurabh Dutta
    @saurabh73
    How can we add google analytics on Admin Dashboard?