Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 18 20:57
    Lopner closed #210
  • Sep 18 10:28
    khorevaa commented #210
  • Sep 18 10:22
    Lopner commented #210
  • Sep 18 10:06
    Lopner commented #210
  • Sep 18 10:01
    Lopner commented #210
  • Sep 18 09:45
    Lopner commented #210
  • Sep 18 09:44
    Lopner commented #210
  • Sep 18 09:40
    Lopner commented #210
  • Sep 18 09:34
    Lopner commented #210
  • Sep 18 09:32
    Lopner commented #210
  • Sep 18 09:30
    Lopner commented #210
  • Sep 18 09:30
    Lopner commented #210
  • Sep 18 09:29
    Lopner commented #210
  • Sep 18 09:11
    Bazooka2091 opened #144
  • Sep 18 09:07
    Bazooka2091 opened #143
  • Sep 17 14:26
    nixel2007 closed #211
  • Sep 17 14:26
    nixel2007 commented #211
  • Sep 17 12:09
    khorevaa commented #210
  • Sep 17 11:18
    Lopner commented #210
  • Sep 17 10:18
    roman1379 commented #182
Nikita Gryzlov
@nixel2007
Верно. Если только ниже явно эти свойства не переопределят
Nikolai Eliseev
@1823244_gitlab
Добрый день. packman + gitlab-ci.yml: нужно собирать дистрибутив (полный + обновление). как в пайплайне обновлять номер предыдущей версии для создания cfu? команда: - call packman make-cf -update-from 1.0.1.4 -cfu-basedir c:\PROJECTS\
Параметр -update-from 1.0.1.4 нужно обновлять с каждой сборкой, это вообще реализуемо? Ну кроме, как руками править.
Борис
@zeratulayuris
Как вариант можно использовать теги для билдов и парсить их, выбирая максимальную версию ниже текущей (которую брать в CI_COMMIT_TAG).
Andrey
@KrapivinAndrey
Привет. Вопрос оффтопный. К докладчикам на ИС. А как вы понимаете что доклад стоит отправить на ИС? Потому что есть вроде как интересная тема, но с 1с она связана только тем, что я 1с занимаюсь))
Nikita Gryzlov
@nixel2007
Тема должна быть интересна 1сникам :)
Andrey
@KrapivinAndrey
Ну это собственно и есть вопрос. У меня вот в команде 20 человек и все в восторге. Но это ж слабая выборка.
Artur Ayukhanov
@artbear
кроме инфостарта есть и другие конференции :)
Andrey
@KrapivinAndrey
До вашей не успеваю( просто так приеду
Evgeny Martynenkov
@JohnyDeath
Так на пулевской вроде бы вообще не будет докладов
Andrey
@KrapivinAndrey
А о каких тогда речь?
bambr1975
@bambr1975
Andrey
@KrapivinAndrey
На эти тем более не успеть
Ndochp
@Ndochp
А что-то мне казалось, что генератор макетов из xUnit (пакет add) умеет работать с константами. Казалось?
Если да, то кто как решает с константами (особенно если нужно сценарий с разными настроками гонять) - устанавливать кодом, а не через макет?
Anton Kvashenkin
@jugatsu

коллеги, доброе утро.
подскажите пжста как продебажить ошибку команды runner lockrepo

C:\Users\vagrant>runner lockrepo --storage-name tcp://localhost/of-prod --storage-user release --storage-pwd release --ibconnection /Slocalhost\of-release --db-user Администратор
vanessa-runner v1.6.0
ИНФОРМАЦИЯ - Выполняю обновление конфигурации из хранилища
ИНФОРМАЦИЯ - Обновление конфигурации из хранилища успешно завершено

ИНФОРМАЦИЯ - Обновление конфигурации из хранилища завершено
ИНФОРМАЦИЯ - Выполняю захват объектов в хранилище
ОШИБКА - Получен ненулевой код возврата 1. Выполнение скрипта остановлено!
ОШИБКА - Ошибка захвата объектов в хранилище

КРИТИЧНАЯОШИБКА - {Модуль C:\Program Files (x86)\OneScript\lib\vanessa-runner\src\Классы\КомандаЗахватитьВХранилище.os / Ошибка в строке: 84 / {Модуль C:\Program Files (x86)\OneScript\lib\vanessa-runner\src\Классы\МенеджерКонфигуратора.os / Ошибка в строке: 730 / ЗахватитьОбъектыВХранилище
{Модуль C:\Program Files (x86)\OneScript\lib\vanessa-runner\oscript_modules\v8runner\src\v8runner.os / Ошибка в строке: 1105 / Ошибка захвата объектов в хранилище
}
} ВызватьИсключение ВыводКоманды();
} ВызватьИсключение ТекущаяПроцедура + "

исходники смотрел, пока мыслей нет
задача: захватить все объекты
Anton Kvashenkin
@jugatsu
Также пробовал с использованием ключа --objects files.xml

содержание файла files.xml

<Objects xmlns="http://v8.1c.ru/8.3/config/ objects" version="1.0">
<Configuration includeChildObjects = "true"/>
</Objects>

Anton Kvashenkin
@jugatsu
звпустил в дебаг-режиме
set LOGOS_CONFIG=logger.rootLogger=DEBUG
смотрю, отпишусь если что
Artem Kuznetsov
@arkuznetsov
@jugatsu Все в телегу перехали https://t.me/oscript_library
Anton Kvashenkin
@jugatsu
понятно спс
Ndochp
@Ndochp
день добрый, а кто знает, можно получть отчет о сравнении конфигураций из командной строки? Пытаюсь автоматизировать пункт из "технологии разветвленных", что "отчет о сравнении с конфигурацией поставщика до и после обновления должен совпадать (с точностью до номеров строк)"
Марина
@Ofg6jBmI8My4TSl_twitter

Добрый день! При синхронизации по нескольким хранилищам git, через gitsync all, появляется следующая ошибка: ОШИБКА - {Модуль С:\Program Files (x86)\OneScript\lib\gitsync\src\core\Классы\КонтроллерПакетнойСинхронизации.os /Ошибка в строке: 105 / Свойство объекта не обнаружено (КоличествоКоммитовДоPush)}.
содержание файла.xml, который запускаю через gitsync all
gitsync-options>

<global>

<email-domain>info@lalala.ru</email-domain>

<v8-version>8.3.12.1685</v8-version>

<git-executable>git</git-executable>
</global>

<repositories>

<repo name="Itilium">

<git-local-path>D:\Configuration Repository Git\Дастион - Итилиум\src\config</git-local-path>

<git-remote>http://git.corp.dastion.ru/scm/dst/itilium.git</git-remote>

<v8-storage-dir>D:\Configuration Repository\Дастион - Итилиум</v8-storage-dir>

<email-domain/>

<v8-version/>

<git-executable/>
</repo>
</repositories>
</gitsync-options>
помогите пожалуйста решить проблему!(

Nikita Gryzlov
@nixel2007
@Ndochp если мне память не изменяет, получение отчёта есть в библиотеке v8storage.
Ndochp
@Ndochp
Это не то, там отчет по хранилищу. А нужен отчет о сравнении конфигурации с конфой поставщика или с внешним ЦФ файлом. (Тот который "Запустить сравнение основной конфигурации и конфигурации поставщика (Конфигурация – Сравнить конфигурации). Результаты сравнения сохранить в файл – это изменения, внесенные в конфигурацию при работе над техническим проектом. В меню «Действия» выбрать пункт «Отчет о сравнении конфигураций»." )
Nikita Gryzlov
@nixel2007
Просто получение отчёта есть в v8runner/vanessa-runner. Процедуры парсинга mxl вроде как есть в v8storage
Ndochp
@Ndochp
Спасибо.
Vasily Popov
@pallid
image.png
Коллеги, ЧЯДНТ?
Образ evilbeaver/onescript:1.0.21
Nikita Gryzlov
@nixel2007
В 1.0.21 для опм ещё нужен параметр --file @pallid.
Только в последних версиях опм файл сделали аргументом. Изначально он был значением опции --file.
Vasily Popov
@pallid
но в винде же 1Script Execution Engine. Version 1.0.21.298 opm push --token e0bf46 --channel stable ./build/pack.ospx работает
opm version 0.15.1
Nikita Gryzlov
@nixel2007
Проверьте версию опм внутри контейнера
demoninfernal
@demoninfernal
Здравствуйте.
image.png
справочная информация у формы списка регистра бухгалтерии "Хозрасчетный" пустая. В чем может быть дело?
Andrey Petrov
@freedive_gitlab
Здравствуйте! Подскажите, как сделать так, чтобы при получении отчета по версиям не удалялись комментарии начинающиеся с "//"?
AVZharkov0502
@AVZharkov0502
Добрый день! Как сделать GitSync 3 инкрементальным? Как установить и активировать плагин понятно. Но как его использовать? Хелпы почему-то не работают.
AVZharkov0502
@AVZharkov0502
Добрый день снова! Пожалуйста, подскажите как сделать третий GitSync инкрементальным. Если ответа нет, может кто-нибудь подскажет как безболезненно вернуться ко второй версии? Она работала безупречно. А с третим один коммит грузится полтора-два часа - скорость абсолютно неприемлемая.
Alexander Kuntashov
@kuntashov
@freedive_gitlab @AVZharkov0502 все переехали в телеграм, нужные вам люди сейчас тусуются на каналах:
https://t.me/silvernation
https://t.me/oscript_library
Андрей Озеров
@xppepel_gitlab
Всем привет, прошу пояснить как пользоваться pacman.. Выкачиваю из Git репозиторий, в папке репозитория запускаю команду:"packman load-src -v8version 8.3.13.1644". Ответ:
"Не найдена лицензия. Не обнаружен ключ защиты программы или полученная программная лицензия! "
По лицензии нет проблем, при запуске клиента..
packman make-cf -v8version 8.3.13.1644. Та же ошибка. указываю другую версию, сообщает о том что версия не совпадает.
Андрей Озеров
@xppepel_gitlab
разобрался, нужна серверная лицензия, а не пользовательская.
Artem Kuznetsov
@arkuznetsov
@xppepel_gitlab Нет тут никого, все в телеге: https://t.me/oscript_library