Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 26 16:34
    nagdevops2 closed #283
  • Sep 26 16:34
    nagdevops2 commented #283
  • Sep 22 15:53
    240596448 synchronize #282
  • Sep 22 12:26

    artbear on native-api

    настройки отладки (compare)

  • Sep 22 10:01

    artbear on native-api

    Релиз 1.12.0 GitHub actions + и… CI ведется на платформе 1.5.0 Этап тестирования запускается п… and 8 more (compare)

  • Sep 22 09:03
    VchSimonov commented #281
  • Sep 22 08:56
    nixel2007 commented #283
  • Sep 21 21:21
    240596448 synchronize #282
  • Sep 21 17:38
    nagdevops2 commented #283
  • Sep 21 17:37
    nagdevops2 commented #283
  • Sep 21 17:11
    nagdevops2 commented #283
  • Sep 21 17:09
    nixel2007 commented #283
  • Sep 21 17:08
    nagdevops2 commented #283
  • Sep 21 16:39
    nagdevops2 commented #283
  • Sep 21 16:23
    nixel2007 commented #283
  • Sep 21 16:22
    nagdevops2 commented #283
  • Sep 21 16:21
    nagdevops2 opened #283
  • Sep 20 08:41
    nixel2007 commented #282
  • Sep 19 19:20
    240596448 commented #282
  • Sep 19 18:59
    240596448 synchronize #282
Alexey Sosnoviy
@asosnoviy
Этож не прекоммит
fishca
@fishca
а не прекоммит4onec
Slava Nedorezov
@slavawashere
вот только что установил и такая ошибка
а
Alexey Sosnoviy
@asosnoviy
это прекоммитFor1nec
fishca
@fishca
на последнем прекоммите ругается, но работает
Slava Nedorezov
@slavawashere
ок, попробую, просто прочитал в доке что precommit4onec более функциональный
Alexey Sosnoviy
@asosnoviy
ну и за это более требовательный к первичной настройке
Slava Nedorezov
@slavawashere
а какой плагин посоветуете для выгрузки конфигурации из базы, а не из хранилища?
я так понял внешние обработки выгружаем через precommit1c, а конфигурацию из хранилища через gitsync
Alexey Sosnoviy
@asosnoviy
https://github.com/oscript-library/vanessa-runner посмотри, может подойдет
Maximov Valery
@theshadowco
@slavawashere как ты добился такой ошибки? у меня 100+ человек пользуются и норм
fishca
@fishca
это от ДотНет-а зависит, как я понял
и винды определенной версии
Maximov Valery
@theshadowco
жуть какая-то
fishca
@fishca
ишуз в прекоммите есть такой
Andrei Ovsiankin
@EvilBeaver

В связи с багом в движке OneScript до версии 1.0.21
Внешнее исключение (System.ArgumentException): Элемент уже добавлен. Ключ в словаре: "HOME" Добавляемый ключ: 'home'

ГОСПОДА! Ну кто додумался именно так сформулировать ошибку, вместо того, чтобы реализовать обход??!

признайтесь сразу, git blame ведь все равно покажет
Maximov Valery
@theshadowco
:-)
Nikita Gryzlov
@nixel2007
@slavawashere может помочь откат 1коммандс на более старую версию. Через opm install 1commands@Версия
Список версий можно посмотреть на hub.oscript.io
Slava Nedorezov
@slavawashere
@nixel2007 спасибо, попробую!
Kirill Krasnov
@Kirill

Немного оффтопика: так совпало, что после обновления платформы с 8.3.10 до 8.3.12 перестал работать код &НаСервере

    Попытка
        xmlhttp = Новый COMОбъект("Microsoft.XMLHTTP");
    Исключение
        ТекстОшибки = "Не удалось подключить COM-объект ""XMLHTTP"". Убедитесь что у вас установлена данная библиотека." + "(Подробности см. в журнале регистрации)";

При том, что локально на сервере в режиме &НаКлиенте этот код работает. Думал дело в платформе, но на другом сервере с этой платформой код работает как на сервере, так и на клиенте.
Единственное, что я нашел по этой теме https://forum.infostart.ru/forum9/topic30957/, но так и не понял как именно он решил. regsvr32 msxml3.dll и regsvr32 msxml6.dll сделал. Не помогло. Может надо сервер перезагружать?

Kirill Krasnov
@Kirill
отбой. перезагрузка (в том числе админы наставили кучу обновлений на систему) помогла
Slava Nedorezov
@slavawashere
https://github.com/oscript-library/vanessa-runner посмотри, может подойдет
@asosnoviy после установки запускаю runner help пишет:
runner help
{Модуль C:\Program Files (x86)\OneScript\lib\vanessa-runner\src\main.os / Ошибка в строке: 12 / Библиотека не найдена add}
когда устанавливал писала вот что:
>opm install vanessa-runner
ПРЕДУПРЕЖДЕНИЕ - Ошибка получения списка пакетов с хаба ЗапаснойСерверПакетов по причине {Модуль C:\Program Files (x86)\OneScript\lib\opm\src\core\Классы\СерверПакетов.os / Ошибка в строке: 94 / Ошибка подключения к зеркалу }
ИНФОРМАЦИЯ - Скачиваю файл: vanessa-runner.ospx
ИНФОРМАЦИЯ - Устанавливаю пакет vanessa-runner
ИНФОРМАЦИЯ - Регистрация приложения: runner
ИНФОРМАЦИЯ - Регистрация приложения: vrunner
ИНФОРМАЦИЯ - Регистрация приложения: vanessa-runner
ИНФОРМАЦИЯ - Регистрация приложения: runner-old
ИНФОРМАЦИЯ - Установка завершена
ИНФОРМАЦИЯ - Устанавливаю зависимость: <logos> из каталога локальных зависимостей
ПРЕДУПРЕЖДЕНИЕ - Нестандартное имя узла Задачи
ИНФОРМАЦИЯ - <logos> уже установлен. Пропускаем.
ИНФОРМАЦИЯ - Устанавливаю зависимость: <cmdline> из каталога локальных зависимостей
ИНФОРМАЦИЯ - <cmdline> уже установлен. Пропускаем.
ИНФОРМАЦИЯ - Устанавливаю зависимость: <tempfiles> из каталога локальных зависимостей
ИНФОРМАЦИЯ - <tempfiles> уже установлен. Пропускаем.
ИНФОРМАЦИЯ - Устанавливаю зависимость: <asserts> из каталога локальных зависимостей
ИНФОРМАЦИЯ - <asserts> уже установлен. Пропускаем.
ИНФОРМАЦИЯ - Устанавливаю зависимость: <v8runner> из каталога локальных зависимостей
ИНФОРМАЦИЯ - <v8runner> уже установлен. Пропускаем.
ИНФОРМАЦИЯ - Устанавливаю зависимость: <strings> из каталога локальных зависимостей
ИНФОРМАЦИЯ - <strings> уже установлен. Пропускаем.
ИНФОРМАЦИЯ - Устанавливаю зависимость: <json> из каталога локальных зависимостей
ИНФОРМАЦИЯ - <json> уже установлен. Пропускаем.
ИНФОРМАЦИЯ - Устанавливаю зависимость: <1commands> из каталога локальных зависимостей
ИНФОРМАЦИЯ - <1commands> уже установлен. Пропускаем.
ИНФОРМАЦИЯ - Устанавливаю зависимость: <1bdd> из каталога локальных зависимостей
ИНФОРМАЦИЯ - <1bdd> уже установлен. Пропускаем.
ИНФОРМАЦИЯ - Устанавливаю зависимость: <fs> из каталога локальных зависимостей
ИНФОРМАЦИЯ - <fs> уже установлен. Пропускаем.
ИНФОРМАЦИЯ - Устанавливаю зависимость: <ParserFileV8i> из каталога локальных зависимостей
ПРЕДУПРЕЖДЕНИЕ - Нестандартное имя узла Задачи
ИНФОРМАЦИЯ - Устанавливаю зависимость: <v8storage> из каталога локальных зависимостей
ПРЕДУПРЕЖДЕНИЕ - Нестандартное имя узла Задачи
ИНФОРМАЦИЯ - Устанавливаю зависимость: <v8unpack> из каталога локальных зависимостей
ИНФОРМАЦИЯ - <v8unpack> уже установлен. Пропускаем.
ИНФОРМАЦИЯ - Устанавливаю зависимость: <opm> из каталога локальных зависимостей
ПРЕДУПРЕЖДЕНИЕ - Нестандартное имя узла Задачи
Artem Kuznetsov
@arkuznetsov
@slavawashere opm install add, но похоже на глюк
Alexey Sosnoviy
@asosnoviy
add в жестких зависимостях???
Nikita Gryzlov
@nixel2007
В дев ветке уже поправили. В мастере - в жёстких неявных, да
Andrei Ovsiankin
@EvilBeaver
а бывают нежесткие зависимости?
в опм?
Nikita Gryzlov
@nixel2007
В опм - нет. В прикладном по - могут быть. Напрмер в пэкэдждефе у тебя вообще нет зависимости. Но в справке у тебя написано - хочешь юзать эту фичу - поставь пакет
Artur Ayukhanov
@artbear

@slavawashere может помочь откат 1коммандс на более старую версию. Через opm install 1commands@Версия
Список версий можно посмотреть на hub.oscript.io

@slavawashere не нужно откатывать на старую версию, тебе как раз не поможет :(
обнови движок 1скрипта на 21 версию и проблема исчезнет.

Slava Nedorezov
@slavawashere
@artbear так у меня как раз 21 версия и была изначально
yadimetrio
@yadimetrio
Microsoft Windows [Version 10.0.17134.472]
(c) Корпорация Майкрософт (Microsoft Corporation), 2018. Все права защищены.

F:\repo\ct\acc>gitrules -i
{Модуль C:\Program Files (x86)\OneScript\lib\reflector\src\Классы\РефлекторОбъекта.os / Ошибка в строке: 325 / Неверное значение аргумента {Тип не может быть отражен.}}

F:\repo\ct\acc>gitrules install
{Модуль C:\Program Files (x86)\OneScript\lib\reflector\src\Классы\РефлекторОбъекта.os / Ошибка в строке: 325 / Неверное значение аргумента {Тип не может быть отражен.}}

F:\repo\ct\acc>gitrules install --help
{Модуль C:\Program Files (x86)\OneScript\lib\reflector\src\Классы\РефлекторОбъекта.os / Ошибка в строке: 325 / Неверное значение аргумента {Тип не может быть отражен.}}
я что то не так делаю, или с пакетом проблемы?
Aleksey Khorev
@khorevaa
Установил версию оскрипта 1.0.21
С новой рефлектор сломали... или изменили
yadimetrio
@yadimetrio
Сейчас у меня "1Script Execution Engine. Version 1.0.21.1" нужен 1.20 ?
Nikita Gryzlov
@nixel2007
А рефлектор последний?
yadimetrio
@yadimetrio
opm update --all делал
Aleksey Khorev
@khorevaa
opm install reflector@0.5.1 надо установить более младшую версию
@yadimetrio воообще в телеге тусим гиттер почти не заходим
Aleksey Khorev
@khorevaa
@yadimetrio видимо ты используешь еще тестовую сборку 1.0.21. Надо переустановить движок с сайта
Andrey
@KrapivinAndrey
Всех с прошедшими праздниками!! А чего вот этой полезной вещи нет в библиотеке? https://github.com/BlackDrak0n/oscript-AutoUpdateIB Или не присылали запрос?
Max A Mazin
@realMaxA
OFF: (улыбнуло) https://developerslife.ru/16999
Andrei Ovsiankin
@EvilBeaver
@KrapivinAndrey чтобы попасть в библиотеку автору наверное надо хотеть туда попасть. Написать нам, чтобы мы форкнули в oscript-library
Я например не знал про эту разработку
Andrey
@KrapivinAndrey
@EvilBeaver Судя по всему, автор давно забил на разработку. Я тогда ее форуму и приготовлю для library
yadimetrio
@yadimetrio
не хочу занудствовать, но dt <> резервная копия. Это к https://github.com/BlackDrak0n/oscript-AutoUpdateIB