by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Aug 06 12:23

    EvilBeaver on develop

    Обновление конфигурации после з… Замена табов на пробелы Merge pull request #120 from xz… (compare)

  • Aug 06 12:23
    EvilBeaver closed #120
  • Aug 05 10:47
    xzfantom synchronize #120
  • Jul 29 13:25
    xzfantom opened #120
  • Jul 22 16:27
    artbear closed #109
  • Jul 22 16:27
    artbear commented #109
  • Jul 22 16:27
    artbear milestoned #109
  • Jul 22 16:27

    artbear on develop

    Реализовано автоопределение вер… (compare)

  • Jul 22 16:27
    artbear closed #115
  • Jul 22 16:27
    artbear milestoned #115
  • Jul 22 11:46
    Spi1y commented #180
  • Jul 22 09:01
    nixel2007 commented #180
  • Jul 22 08:21
    Spi1y opened #180
  • Jul 08 10:58
    nixel2007 commented #19
  • Jul 08 10:09
    240596448 edited #19
  • Jul 08 10:07
    240596448 commented #19
  • Jul 08 10:07
    240596448 commented #19
  • Jul 08 10:00
    nixel2007 commented #19
  • Jul 08 09:57
    240596448 commented #19
  • Jul 08 09:50
    nixel2007 commented #19
Vasily Popov
@pallid
мне очень интересно )))
спасибо
я 100% это буду использовать
Aleksey Khorev
@khorevaa
@vasvl123 - вот ему надо спасибо )) Я всего оформил в либу )
Vasily Popov
@pallid
а свой вчера недоделанный проект для jwt удалю
Artur Ayukhanov
@artbear

ИНФОРМАЦИЯ - Устанавливаю пакет params
ПРЕДУПРЕЖДЕНИЕ - Не удалось обработать описание частичного распакованного пакета

Выполняю полную распаковку пакета

{Модуль C:\Windows\system32\oscript_modules\params\packagedef / Ошибка в строке:
2 / Внешнее исключение (System.IO.DirectoryNotFoundException): Не удалось найти
часть пути "C:\Windows\system32\oscript_modules\params\src\Модули\ПараметрыСист
емы.os".}
ИНФОРМАЦИЯ - Установка завершена

@akademik1986 это многострочное предупреждение, а не ошибка :(

видимо, придется все-таки перевести это предупреждение в тип "отладка" вместо "предупреждение"

Борис
@zeratulayuris

precommit1c [2.2.0]

Репозиторий: https://github.com/xDrivenDevelopment/precommit1c
Автор публикации: zeratulayuris

Changelog:

Добавлено:

  • возможность использовать штатную сборку/разборку платформы
  • возможность указать сервисную базу для сборки/разборки
  • bdd-тесты

Исправлено:

  • mxl-файлы вне обработок теперь разбираются корректно
bambr1975
@bambr1975
Не прошло и три года))) Спасибо.
Борис
@zeratulayuris
Самому не верится )
Artem Kuznetsov
@arkuznetsov
@zeratulayuris А в хабе когда появится?
Борис
@zeratulayuris
@arkuznetsov уже должно появиться, у меня opm update precommit1c установил 2.2.0
Artem Kuznetsov
@arkuznetsov
@zeratulayuris У меня так и остался 2.1.1
Борис
@zeratulayuris
Странно, прошлый 2.1.3.
А вывод opm update precommit1c можно в студию?
Artem Kuznetsov
@arkuznetsov
image.png
bambr1975
@bambr1975
мне тоже жаловались, что на разных компьютерах по opm install устанавливаются разные версии пакетов. Интересно, почему?
И да, у меня тоже opm update precommit устанавливает 2.1.1
Борис
@zeratulayuris
Теперь мне стало интересно. Какие у вас версии oscript и opm?
а внутри-то все хорошо
изображение.png
Artem Kuznetsov
@arkuznetsov
@zeratulayuris oscript 21, opm последний из хаба
Борис
@zeratulayuris
прикольно, однако.
Борис
@zeratulayuris
Сделай opm list и поймёшь, что с 2.1.1 так и не бампили версию в самой утилите, только в packagedef
Artem Kuznetsov
@arkuznetsov
@zeratulayuris Как я вижу появиласть возможность использовать конфигуратор для разбора отчетов/обработок, а как/где указать необходимые параметры (использование конфигуратора, база и т.п) в случае когда прекоммит установлен в репу?
Борис
@zeratulayuris
@arkuznetsov можно в команде install указать общие параметры и тогда они будут прописаны в хуке.
Вообще можно посмотреть feature файлы - там есть буквально примеры использования.
Artem Kuznetsov
@arkuznetsov
@zeratulayuris А если ранее выгружалась обработка "стандартным" precommit'ом, старые файлы разбора удаляться?
@zeratulayuris И второй вопрос, без указания --install с параметрами, где можно ручками подправить?
Nikita Gryzlov
@nixel2007
@arkuznetsov .git/hooks/pre-commit
Artem Kuznetsov
@arkuznetsov
@nixel2007 Пасиб
Artem Kuznetsov
@arkuznetsov
@zeratulayuris Может кто версию забампит? :-)
Борис
@zeratulayuris
@arkuznetsov если получится, у меня пока траблы с пушем в хаб по моему токену.
Artem Kuznetsov
@arkuznetsov
@zeratulayuris Так тебе нужен твой собственный токен, ты его сам можешь создать в своем профиле на GitHub.
Борис
@zeratulayuris
В том и дело, что собственный токен не канает )
image.png
Возможно, у меня просто нет доступа на запись к нужному репо.
Artem Kuznetsov
@arkuznetsov
@zeratulayuris Да, похоже в oscript-library прав нет.
Борис
@zeratulayuris
@arkuznetsov вроде теперь порядок с версией.
Artem Kuznetsov
@arkuznetsov
@zeratulayuris +1
Красивый вывод в консоль )
Artur Ayukhanov
@artbear
С прекоммит1с все в порядке, верно?
я исправлял и публиковал 2.2.1
номер версии 2.2.1, все выгружается?
Борис
@zeratulayuris
Всё хорошо вроде.
Тесты проходят, версия правильная отображается и в списке либ, и в самой утилите.
Mavi1200
@Mavi1200
Всем привет. Подскажите пожалуйста как подключить или у кого есть библиотека чтобы работать с датой или ее аналог на OneScript. Мне нужно текст перевести в дату , но там стандартный функция в One script я не нашел . нашел такую библиотеку но как воспользоваться не понял # datetime.
Alexey Kostromin
@alexkmbk
@Mavi1200 За библиотеку не подскажу, но мне известны следующие варианты:
Дата = Дата("20151215204222");
Дата = ПрочитатьДатуJSON("2008-09-15T15:53:00", ФорматДатыJSON.ISO); // в текущей версии поддерживаются даты в формате ISO или Microsoft.
Nikita Gryzlov
@nixel2007
@Mavi1200 а что вам нужно делать с датой?
А, увидел. Библиотеку можно подклляиьь в скрипт с помощью директивы #использовать. Предварительно её надо установить через opm
Подключить*