These are chat archives for Exa-Networks/exabgp

7th
Mar 2015
Thomas Mangin
@thomas-mangin
Mar 07 2015 10:13
@sanjmonkey where is the code located ?
and good morning
Thomas Mangin
@thomas-mangin
Mar 07 2015 10:31
sorry I am blind
Thomas Mangin
@thomas-mangin
Mar 07 2015 11:01
will look later on - can not find anything obviously wrong
it would like the socket is not setup correctly for MD5 and therefore the kernel is not matching the incoming packet to the socket but AFAICS all was setup fine .
sanjmonkey
@sanjmonkey
Mar 07 2015 11:13
ok thomas thanks for checking. enjoy your day!
Thomas Mangin
@thomas-mangin
Mar 07 2015 11:14
going to Jitsu - will be mid aft. I have an idea.
Thomas Mangin
@thomas-mangin
Mar 07 2015 14:09
There is a connect.conf file with the test.conf ..
using it works …
the connection is not accepted as the source IP is not right but it establishes
could you let me know what is at the other end of the session ?
I will be back later on today - ttfn
sanjmonkey
@sanjmonkey
Mar 07 2015 17:21
hi @thomas-mangin. seen your findings. I agree - if it stays local it binds, and capture shows the sending and receiving of TCP MD5. In this case the other end is an identical 14.04 / exa3.4.8. Trying with a Cisco router (IOS 15 something) shows the same, with MD5 on it never makes it to exa.
Thomas Mangin
@thomas-mangin
Mar 07 2015 17:21
hum ...
sanjmonkey
@sanjmonkey
Mar 07 2015 17:22
I’m going to investigate other OS’ and hypervisors vs physical (in case it is some offloading in vswitch perhaps)
Thomas Mangin
@thomas-mangin
Mar 07 2015 17:22
can you try master on the other node .. in case there is an issue..
yes - it could be .. I will try to test between two host later on ( currently working on some other code )
sanjmonkey
@sanjmonkey
Mar 07 2015 17:23
other node is 3.4.8 master (not from your tree)
I’ll let you know how it goes
Thomas Mangin
@thomas-mangin
Mar 07 2015 17:28
thanks