These are chat archives for Exa-Networks/exabgp

21st
Sep 2015
Charles Ng
@charlescng
Sep 21 2015 14:11
@thomas-mangin I'm trying to run the 3.4 branch but I'm getting this error:
Traceback (most recent call last):
  File "/usr/local/bin/exabgp", line 9, in <module>
    load_entry_point('exabgp==3.4.12', 'console_scripts', 'exabgp')()
  File "/home/charles/exabgp/lib/exabgp/application/__init__.py", line 11, in run_exabgp
    from exabgp.application.bgp import main
  File "/home/charles/exabgp/lib/exabgp/application/bgp.py", line 17, in <module>
    from exabgp.reactor.loop import Reactor
  File "/home/charles/exabgp/lib/exabgp/reactor/loop.py", line 29, in <module>
    from exabgp.reactor.api.decoder import Decoder
  File "/home/charles/exabgp/lib/exabgp/reactor/api/decoder/__init__.py", line 71, in <module>
    Decoder.register_command(name,getattr(command,FUNCTION[name]))
AttributeError: 'module' object has no attribute 'announce_attribute'
Thomas Mangin
@thomas-mangin
Sep 21 2015 14:31
Hello
can you delete all the *.pyc files it will fix it
The new code in master does this for you but it was not backported to 3.4
as it would change expected behaviour in the 3.4 series
but perhaps I should backport this
@charlescng let me know if it does not fix the issue
(in /sbin/exabgp)
I will go offline but hopefully should you reply my phone should let me know :wink2:
Charles Ng
@charlescng
Sep 21 2015 14:53
:+1: That worked. Thanks! (This is the first time I've done Python really :smile: )