These are chat archives for Exa-Networks/exabgp

3rd
Mar 2017
Thomas Morin
@tmmorin
Mar 03 2017 16:16
hi @thomas-mangin, are you around ?
integrating bagpipe (networking-bagipe & bagpipe-bgp) into openstack would require declaring exabgp as an "official" requirement of the openstack project
there a few things to check before this is possible: https://github.com/openstack/requirements#for-new-requirements
most of these are ok (maitained code, licence, packaged in key distros)
Thomas Mangin
@thomas-mangin
Mar 03 2017 16:20
so need to make sure the code is P3 happy
Thomas Morin
@tmmorin
Mar 03 2017 16:20
yes, this is the key obstacle I see remaining
"At this point adding non python 3 compatible libraries should only be done under extreme need. It should be considered a very big exception."
I think it will be hard to get an "exemption"
I can try though, but having an idea of your plans would help
I can possibly give some help to make the code py3 happy where it is not
Thomas Mangin
@thomas-mangin
Mar 03 2017 16:21
It reads like “must do"
I will but atm my coding time is very limited
Thomas Morin
@tmmorin
Mar 03 2017 16:22
well... yes...
I guess you will accept py3 fixing patches if I provide any ?
Thomas Mangin
@thomas-mangin
Mar 03 2017 16:30
oh ! yes :-)
Thomas Morin
@tmmorin
Mar 03 2017 17:07
@thomas-mangin ok, I'll probably push some as I find issues...