These are chat archives for Exa-Networks/exabgp

23rd
May 2017
Brian Johnson
@brijohn
May 23 2017 18:49
@thomas-mangin Yeah current master works again, but the bug described by issue 441 still seems to be in master. Whenever i send a reload signal to exabgp any existing unchanged peers resend their entire RIB regardless.
Thomas Mangin
@thomas-mangin
May 23 2017 18:50
Possible using signal is a known issue of 4.0.0 - I am even contemplatinmg removing the feature altogether .
I ended not doing ...
Brian Johnson
@brijohn
May 23 2017 18:52
I also tried sending the reload API command to exabgp as well, but that also seems to cause the same issue. Is there anyother recommended way to reload the config then?
Thomas Mangin
@thomas-mangin
May 23 2017 18:53
no, this is still the way .. need fixing .. workign on the core engine now - when I finished it is will easier to look into this
Thomas Mangin
@thomas-mangin
May 23 2017 19:35
@brijohn can you please pull ?
Brian Johnson
@brijohn
May 23 2017 19:48
I pulled the latest version. Any particular issues the latest merge fixes? Or just more general changes to the reactor loop and refactoring?
Thomas Mangin
@thomas-mangin
May 23 2017 19:51
Just simplifying anre refactoring the code so I can try to fix the signal issue more easily later
for example, the logic for reload_completed is not right in the loop
Thomas Mangin
@thomas-mangin
May 23 2017 20:04
£$%$£^% I broke the API
Thomas Mangin
@thomas-mangin
May 23 2017 21:51
ok - seems to work as expected - some of the issues were not mine :clap: ExaBGP is now MUCH faster when establishing connections
Thomas Mangin
@thomas-mangin
May 23 2017 22:16
still not fixed this issue regarding reload_completed ..