Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Aug 15 14:15
    vincentbernat commented #910
  • Aug 15 07:46
    sincerywaing edited #910
  • Aug 15 05:19
    sincerywaing opened #910
  • Aug 14 21:40
    Vascko commented #909
  • Aug 13 10:04
    thomas-mangin labeled #909
  • Aug 13 10:04
    thomas-mangin assigned #909
  • Aug 13 10:02
    thomas-mangin commented #909
  • Aug 12 07:32
    wavezhang commented #908
  • Aug 12 07:32
    wavezhang commented #908
  • Aug 11 23:04
    Vascko opened #909
  • Aug 09 21:44
    thomas-mangin commented #908
  • Aug 09 21:44

    thomas-mangin on master

    accepting patch suggestion from… (compare)

  • Aug 08 12:53
    vincentbernat commented #908
  • Aug 08 12:48
    vincentbernat commented #908
  • Aug 08 10:36
    thomas-mangin commented #908
  • Aug 08 10:35
    thomas-mangin commented #908
  • Aug 08 10:33

    thomas-mangin on master

    free resources before calling t… (compare)

  • Aug 08 10:30

    thomas-mangin on master

    withdraw routes when exit treate EXIT as DISABLE for metr… fix bug that reload and termina… and 2 more (compare)

  • Aug 08 10:30
    thomas-mangin closed #908
  • Aug 08 08:12
    wavezhang synchronize #908
Vincent Bernat
@vincentbernat
for example each output could be collected in a thread, or a loop with select()

I am also getting this:

Sun, 20 Mar 2016 00:02:48 | ERROR    | 29879  | configuration | syntax error in section process
Sun, 20 Mar 2016 00:02:48 | ERROR    | 29879  | configuration | line 12: run ./api-nexthop-self.run ;
Sun, 20 Mar 2016 00:02:48 | ERROR    | 29879  | configuration |
Sun, 20 Mar 2016 00:02:48 | ERROR    | 29879  | configuration | can not execute directories "/etc/exabgp"

when /etc/exabgp exists.

Unfortunately, I don't have much time this week.
I could just skip those tests
I suppose it's important you run them, I don't need to run them myself
Thomas Mangin
@thomas-mangin
Thank you - I will look into this /etc/exabgp issue
You can indeed skip the tests - I run them on my laptop before release
They do not need to be run on the build
Thomas Mangin
@thomas-mangin
@vincentbernat /etc issue resolved on master - silly pebkac. Exa-Networks/exabgp@2eda799
Thomas Mangin
@thomas-mangin
Screen Shot 2016-03-20 at 09.34.02.png
Go understand !
sigh !
Thomas Mangin
@thomas-mangin
@vincentbernat search in /etc/exabgp backported too
Thomas Mangin
@thomas-mangin
@vincentbernat my laptop and codeship have no issue with running the tests
If it is failing on your machine, could you just find one of the failing test (not green) when your run ./qa/bin/conversation
and then use two terminals
SERVER=<code of the test, i.e.: A> ./qa/bin/conversation
CLIENT=<code> ./qa/bin/conversation
and provide me the outpout so I can see why it is not completing (if they still fail)
If it passes - they it is an issue due to forking and lost likely as you pointed communicate
Vincent Bernat
@vincentbernat
@thomas-mangin: for example, on test 0, I see the client is trying to connect to port 179 instead of the port specified in exabgp.tcp.port
while the server is correctly bound to port 38833
nothing in the logs (port not displayed), but I see that on tcpdump
Thomas Mangin
@thomas-mangin
Thank you
Now I have no idea why this is happening
I assume you are running sid
@vincentbernat if so I will make a vm and try to replicate
Vincent Bernat
@vincentbernat
@thomas-mangin: wouldn't it be possible that exabgp reads my /etc/exabgp/exabgp.env and ignore the environment variables?
Thomas Mangin
@thomas-mangin
.... It should not but it is a good lead worth investigating
Vincent Bernat
@vincentbernat
deleting the directory, still the same behavior
should the client use exabgp.tcp.port or does it get the port information from somewhere else?
Thomas Mangin
@thomas-mangin
I would guess that using exabgp_tcp_port may fix it
It may be due to the way . are handled
Vincent Bernat
@vincentbernat
yes, it works
Thomas Mangin
@thomas-mangin
Ok easy fix but not sure why this behaviour is os specific
Vincent Bernat
@vincentbernat
replacing other vars in the same works too
maybe it's related to the shell
Thomas Mangin
@thomas-mangin
I will fix and release 4.16 as I have two other bug fixes already
Vincent Bernat
@vincentbernat
on Debian, /bin/sh is /bin/dash
Thomas Mangin
@thomas-mangin
Yes, I use bash
Vincent Bernat
@vincentbernat
sbin/exabgp is #!/bin/sh
Thomas Mangin
@thomas-mangin
Yes which is bash on OS X
Vincent Bernat
@vincentbernat
ok
on Ubuntu, /bin/sh is also dash
Thomas Mangin
@thomas-mangin
I will double check
Vincent Bernat
@vincentbernat
what distribution is codeship running?
Thomas Mangin
@thomas-mangin
No idea
Will check
Could be centos