Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Aug 23 17:56
    pettai opened #912
  • Aug 22 12:08
    thomas-mangin labeled #911
  • Aug 22 12:03
    thomas-mangin closed #910
  • Aug 22 12:03
    thomas-mangin commented #910
  • Aug 22 09:31
    thomas-mangin commented #911
  • Aug 22 09:29
    thomas-mangin labeled #911
  • Aug 22 09:28
    thomas-mangin assigned #911
  • Aug 22 03:58
    andy19910403 edited #911
  • Aug 22 03:58
    andy19910403 opened #911
  • Aug 15 14:15
    vincentbernat commented #910
  • Aug 15 07:46
    sincerywaing edited #910
  • Aug 15 05:19
    sincerywaing opened #910
  • Aug 14 21:40
    Vascko commented #909
  • Aug 13 10:04
    thomas-mangin labeled #909
  • Aug 13 10:04
    thomas-mangin assigned #909
  • Aug 13 10:02
    thomas-mangin commented #909
  • Aug 12 07:32
    wavezhang commented #908
  • Aug 12 07:32
    wavezhang commented #908
  • Aug 11 23:04
    Vascko opened #909
  • Aug 09 21:44
    thomas-mangin commented #908
Thomas Mangin
@thomas-mangin
and then use two terminals
SERVER=<code of the test, i.e.: A> ./qa/bin/conversation
CLIENT=<code> ./qa/bin/conversation
and provide me the outpout so I can see why it is not completing (if they still fail)
If it passes - they it is an issue due to forking and lost likely as you pointed communicate
Vincent Bernat
@vincentbernat
@thomas-mangin: for example, on test 0, I see the client is trying to connect to port 179 instead of the port specified in exabgp.tcp.port
while the server is correctly bound to port 38833
nothing in the logs (port not displayed), but I see that on tcpdump
Thomas Mangin
@thomas-mangin
Thank you
Now I have no idea why this is happening
I assume you are running sid
@vincentbernat if so I will make a vm and try to replicate
Vincent Bernat
@vincentbernat
@thomas-mangin: wouldn't it be possible that exabgp reads my /etc/exabgp/exabgp.env and ignore the environment variables?
Thomas Mangin
@thomas-mangin
.... It should not but it is a good lead worth investigating
Vincent Bernat
@vincentbernat
deleting the directory, still the same behavior
should the client use exabgp.tcp.port or does it get the port information from somewhere else?
Thomas Mangin
@thomas-mangin
I would guess that using exabgp_tcp_port may fix it
It may be due to the way . are handled
Vincent Bernat
@vincentbernat
yes, it works
Thomas Mangin
@thomas-mangin
Ok easy fix but not sure why this behaviour is os specific
Vincent Bernat
@vincentbernat
replacing other vars in the same works too
maybe it's related to the shell
Thomas Mangin
@thomas-mangin
I will fix and release 4.16 as I have two other bug fixes already
Vincent Bernat
@vincentbernat
on Debian, /bin/sh is /bin/dash
Thomas Mangin
@thomas-mangin
Yes, I use bash
Vincent Bernat
@vincentbernat
sbin/exabgp is #!/bin/sh
Thomas Mangin
@thomas-mangin
Yes which is bash on OS X
Vincent Bernat
@vincentbernat
ok
on Ubuntu, /bin/sh is also dash
Thomas Mangin
@thomas-mangin
I will double check
Vincent Bernat
@vincentbernat
what distribution is codeship running?
Thomas Mangin
@thomas-mangin
No idea
Will check
Could be centos
Vincent Bernat
@vincentbernat
I remember something about dot in environment variables
afaik, you can have dot in environment variables, but maybe shells may feel otherwise because they have to map that to variables names
so maybe some of them are cleaning up the environment
env titi.toto=3 sh -c env | grep titi
env titi.toto=3 bash -c env | grep titi
first one is empty, second one shows the environment variable
that may be a change in recent versions of dash since it is not working with 3.4.13 either while I am pretty sure it worked previously
and Debian is using dash as sh since a long long time
Thomas Mangin
@thomas-mangin
Yes. Fun fun fun
Vincent Bernat
@vincentbernat
note that there is no problem of replacing /bin/sh by /bin/bash if you find this change less invasive
Thomas Mangin
@thomas-mangin
No simpler to use _ I added them as I had this issue around two years ago and it fixed itself
Perhaps more than two .. Times flies
Need to go in 5 minutes so doing it now
Thomas Mangin
@thomas-mangin
dots with underscore breaks the program on my mac, I will need to look at it tonightk - replacing .
s/./replacing dots with underscore breaks the program on my mac, I will need to look at it tonight.
sigh