by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 18 08:30
    coveralls commented #323
  • Sep 18 08:29
    randytarampi synchronize #323
  • Sep 18 08:25
    randytarampi synchronize #323
  • Sep 17 12:36
    randytarampi synchronize #323
  • Sep 17 12:19
    coveralls commented #323
  • Sep 17 12:15
    randytarampi synchronize #323
  • Sep 15 16:34
    utkarshdubey commented #259
  • Sep 14 06:56
    randytarampi synchronize #323
  • Sep 14 06:41
    coveralls commented #323
  • Sep 14 06:36
    randytarampi synchronize #323
  • Sep 14 06:36
    randytarampi synchronize #323
  • Sep 13 21:14
    randytarampi synchronize #323
  • Sep 13 20:17
    coveralls commented #323
  • Sep 13 20:10
    randytarampi synchronize #323
  • Sep 13 20:06
    coveralls commented #323
  • Sep 13 20:00
    randytarampi synchronize #323
  • Sep 13 19:59
    randytarampi synchronize #323
  • Aug 29 20:12
    coveralls commented #323
  • Aug 29 19:58
    randytarampi synchronize #323
  • Aug 29 19:34
    randytarampi synchronize #323
Raine Virta
@raine
good morning
I'm looking for a way to put an Image on top of a simple colored canvas so that parts of the image may not be visible in the resulting image, so far I've tried creating a new Image with color and pasting the image on top of that, but I get an error because the Image doesn't fit. I'd like to avoid cropping the Image first
Raine Virta
@raine
basically if I was able to paste with negative coordinates and not caring about if the image fits or not, it'd would be great...
Raine Virta
@raine
maybe i'll just make a big canvas, put the image in the middle, merge them and then crop
Raine Virta
@raine
hmm, there's some kind of off by one error in crop
Raine Virta
@raine
what's the easiest way to remove pixels from a rectangle?
Raine Virta
@raine
i ended up just using setPixel
Ankur Kaushal
@ankurkaushal
Is anyone familiar with x-code errors while installing lwip?
Jonathan Cremin
@kudos
hello :)
@EyalAr have you given any consideration to smart thumbnailing?
something like what the Reddit guys do with histograms and PIL
Eyal Arubas
@EyalAr
@kudos Cool idea, and shouldn't be too hard to implement. Do you want to open a feature request issue?
@ankurkaushal what kind of errors do you have?
@raine Seems like creating a big canvas, pasting and then cropping would work, wouldn't it?
Alistair MacDonald
@F1LT3R
The second time I try to npm install lwip I get build errors. Is this expected?
warning generated. CC(target) Release/obj.target/lwip_decoder/src/lib/gif/gif_err.o CC(target) Release/obj.target/lwip_decoder/src/lib/gif/gifalloc.o SOLINK_MODULE(target) Release/lwip_decoder.node ld: library not found for -lgcc_s.10.5 clang: error: linker command failed with exit code 1 (use -v to see invocation) make: *** [Release/lwip_decoder.node] Error 1 gyp ERR! build error gyp ERR! stack Error:makefailed with exit code: 2
The first time I installed lwip everything worked fine. But after running npm install lwip --save and the running npm install it fails.
I can no longer get lwip to install.
Eyal Arubas
@EyalAr
@F1LT3R I suggest you try to clear your node_modules dir and try again. Let me know if the problem persists.
Bruno Sampaio Pinho
@bpinhosilva
Does somebody have any problem installing lwip on win 8 64-bit machine?
Eyal Arubas
@EyalAr
@bpinhosilva what's the problem?
Felix Becker
@felixfbecker

If someone is struggling with installing this, these are the steps I went through (Windows 10):

  • Install latest Python 2.x (2.7.10), tell setup to add binary to PATH
  • Install Visual Studio 2015 Community Edition, tell setup to install basic C++ tools
  • npm install -g node-gyp
  • npm install lwip

Worked without any env variable or extra SDK downloads :)

Felix Becker
@felixfbecker
I have my image in a stream. Does anyone know how I can create a buffer from it to pass it to lwip?!
sasnfbi1234
@sasnfbi1234
hello I am having trouble installing lwip and was wondering if this is the correct place to get help
Vaviloff
@Vaviloff
@sasnfbi1234 It is :)
David Kagerer
@c0un7-z3r0
Has anyone found a solution for PNG decoding error
this is happing now since lwip version 0.0.8
Cyril Perraud
@pCyril
Someone else got this error libpng error: Incompatible libpng version in application and library ?
I can't update my libpng which is version 1.2.50 to 1.6.18
When i clone the github projet and run tests i don't have the problem png tests passed successfully so i don't understand why i have this issue
Cyril Perraud
@pCyril
So i found the solution i rebuild with node-gyp rebuild
sorry
jatinder bhola
@jatinderbhola

hi there, i am trying to install lwip on node 8.1.4 and running into build error

```CC(target) Release/obj.target/lwip_decoder/src/lib/png/png.o
In file included from ../src/lib/png/png.c:14:0:
../src/lib/png/pngpriv.h:805:4: error: #error ZLIB_VERNUM != PNG_ZLIB_VERNUM "-I (include path) error: see the notes in pngpriv.h"

   #  error ZLIB_VERNUM != PNG_ZLIB_VERNUM     ^
   make: *** [Release/obj.target/lwip_decoder/src/lib/png/png.o] Error 1
   make: Leaving directory `/tmp/build_da353704106590ab9988ccae439b3a5d/RugCoPro-rugcopro-ec742a020d2114442ddc5e52de1200bce22694a6/node_modules/lwip/build'
   gyp ERR! build error
   gyp ERR! stack Error: `make` failed with exit code: 2
   gyp ERR! stack     at ChildProcess.onExit (/tmp/build_da353704106590ab9988ccae439b3a5d/RugCoPro-rugcopro-ec742a020d2114442ddc5e52de1200bce22694a6/.heroku/node/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:258:23)
   gyp ERR! stack     at emitTwo (events.js:125:13)
   gyp ERR! stack     at ChildProcess.emit (events.js:213:7)
   gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:197:12)
   gyp ERR! System Linux 3.13.0-123-generic
   gyp ERR! command "/tmp/build_da353704106590ab9988ccae439b3a5d/RugCoPro-rugcopro-ec742a020d2114442ddc5e52de1200bce22694a6/.heroku/node/bin/node" "/tmp/build_da353704106590ab9988ccae439b3a5d/RugCoPro-rugcopro-ec742a020d2114442ddc5e52de1200bce22694a6/.heroku/node/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
   gyp ERR! cwd /tmp/build_da353704106590ab9988ccae439b3a5d/RugCoPro-rugcopro-ec742a020d2114442ddc5e52de1200bce22694a6/node_modules/lwip
   gyp ERR! node -v v8.1.4
   gyp ERR! node-gyp -v v3.6.2
   gyp ERR! not ok
   npm ERR! code ELIFECYCLE
   npm ERR! errno 1
   npm ERR! lwip@0.0.9 install: `node-gyp rebuild`
   npm ERR! Exit status 1
   npm ERR!
   npm ERR! Failed at the lwip@0.0.9 install script.
   npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

   npm ERR! A complete log of this run can be found in:
   npm ERR!     /app/.npm/_logs/2017-07-13T23_32_34_979Z-debug.log```

can you please help me with any suggestion or solution. super thankful. :)