Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • May 23 2020 14:46

    jangernert on v2.11.0

    (compare)

  • May 23 2020 14:41

    jangernert on master

    v2.11 release (compare)

  • May 20 2020 00:31
    tylerregas opened #995
  • May 19 2020 12:28
    pwithnall commented #982
  • May 19 2020 12:26
    pwithnall commented #993
  • May 17 2020 16:56
    Monirzadeh commented #197
  • May 17 2020 05:08
    zohozer opened #994
  • May 14 2020 19:27
    ripefig edited #993
  • May 14 2020 19:26
    ripefig opened #993
  • May 14 2020 09:34
    Monirzadeh commented #197
  • May 14 2020 09:31
    Monirzadeh closed #992
  • May 14 2020 09:24
    Monirzadeh opened #992
  • May 09 2020 06:00

    jangernert on master

    fix midnight theme I had creat… Merge pull request #991 from An… (compare)

  • May 09 2020 06:00
    jangernert closed #991
  • May 09 2020 05:47
    Antoine-Derouin opened #991
  • May 08 2020 16:47
    Antoine-Derouin commented #990
  • May 08 2020 16:36

    jangernert on master

    add theme Gruvbox Merge pull request #990 from An… (compare)

  • May 08 2020 16:36
    jangernert closed #990
  • May 08 2020 16:36
    jangernert commented #990
  • May 08 2020 16:34

    jangernert on master

    Revert e1dda2a Merge pull request #984 from xc… (compare)

Felix Bühler
@Stunkymonkey
Screenshot-2020-05-18_210438.png
tuxedotje
@tuxedotje
Hi My question, How to Remove a feed from feedreader? Thanks
I do mean the feed already in Feedreader (Slashdot)
tuxedotje
@tuxedotje
quit
Jan Lukas Gernert
@jangernert
I'm not following, I think. You can right click a feed and remove it or select it an click the minus button at the bottom.
TechyGrue
@TechyGrue
hmmm... running ubuntu 20.04, since NewsFlash is not yet on flathub, how do I install it? I keep getting error "error: Remote bundles are not supported" and I'm having a heck of a time tracking down how to fix this error.
TechyGrue
@TechyGrue
Oh snap, an old dog can learn new tricks. I think I got it working. NewsFlash rc1 doesn't have a desktop icon in Ubuntu, but hot damn I got it to run! You can disregard the above query.
Jan Lukas Gernert
@jangernert
@bilelmoussaoui ping
Morgan Nunan
@morgannunan
Hi there, I can't figure out where feedreader stores its configuration. I'm on Ubuntu and I don't see .feedreader or .config/feedreader
I'm asking because I'm on HiDPI and I can't seem to make the reading pane zoom level persistent.
Morgan Nunan
@morgannunan
Nevermind, I'm being dumb. Setting the font size fixed my problem. I'd still be curious to know where those theme files are.
shbach
@shbach_gitlab
Does The Old Reader work in FeedReader for anybody? Support seems to be broken. I realize FeedReader isn't being actively worked on anymore but would it be possible to fix this?
Bilal Elmoussaoui
@bilelmoussaoui
Hey @jangernert
Jan Lukas Gernert
@jangernert
Hi
Bilal Elmoussaoui
@bilelmoussaoui
so far for adding the secrets, I have talked to bart about it
the issue is that the builds are managed by buildbot and we can't easily setup secrets from there as it's made to just build stuff and report build status and sadly our integration layer is limited to github for now
so adding them would require "manual intervention", bart is going to take care of that next week hopefully as they are the sysadmin
Jan Lukas Gernert
@jangernert
but it would have to be set up just once, right? so not for every version i push to flathub
Bilal Elmoussaoui
@bilelmoussaoui
yes indeed
that's the plan
Jan Lukas Gernert
@jangernert
okay cool, hopefully not too much extra work for him
do you know if the PR has to be merged for the secrets to be set up? Or can barthalion set them up and then I can submit a final code bundle before merging?
Bilal Elmoussaoui
@bilelmoussaoui
I can merge it already if you want, the backends that requires a token will not work and once bart takes care of the secrets you can just trigger a new build from https://flathub.org/builds
you need to log in with your github account
Jan Lukas Gernert
@jangernert
ah okay, give me a bit so I can get in the latest fixes and do a proper release
I'll ping in the MR when I'm ready
thank you already :)
Bilal Elmoussaoui
@bilelmoussaoui
happy to help :) sorry for taking too long, way too much stuff on the todo list
Jan Lukas Gernert
@jangernert
same for me tbh, having lots of time was the one great thing about lockdown :D
Bilal Elmoussaoui
@bilelmoussaoui
@jangernert just to be sure, you want newsflash to be merged to beta?
Jan Lukas Gernert
@jangernert
Or stable. I'm ready, only thing missing are the environment variables
Bilal Elmoussaoui
@bilelmoussaoui
sure, I will merge it in stable and we will figure out the env variables later
Bilal Elmoussaoui
@bilelmoussaoui
done, feel free to add a new issue to track the secrets issue
Jan Lukas Gernert
@jangernert
thanks, I'll do that
Bilal Elmoussaoui
@bilelmoussaoui
I just checked if I had access to the secrets but It doesn't seems to be the case
ah also, you might want to check this one https://gitlab.gnome.org/World/read-it-later/-/tree/master/data/resources/article, I have made a wallabag client few months ago and borrowed the article preview theme from epiphany which looks great in case you want to re-use it
it also ships with highlight js for proper code highlighting
Jan Lukas Gernert
@jangernert
I made you a maintainer of news_flash_gtk, now you should definitely have access to the CI variables
I'm pretty happy with the css by now, a lot of people contributed small tweaks, but the syntax highlighting sounds nice
Bilal Elmoussaoui
@bilelmoussaoui
Nice, thanks! I can confirm that I have access to the CI variables now
Felix Bühler
@Stunkymonkey
@jangernert when downloading the latest release of news_flash_gtk it still refers to an rc-version of news_flash_base. could we bump the current release version to update the dependencies? Otherwise its more complicated for packaging.
Jan Lukas Gernert
@jangernert
You mean the one on flathub?
Felix Bühler
@Stunkymonkey
when downloading the tar.gz file from the release page on gitlab
Jan Lukas Gernert
@jangernert
ah, that's simply because I didn't tag 1.0.0 and 1.0.1
but I didn't put the release notes up. they're in the appdata already
Felix Bühler
@Stunkymonkey
thanks :+1:
Felix Bühler
@Stunkymonkey
@jangernert little update on the google reader api:
I belive that all needed methods are implemented from freshrss.
innoreader, theoldreader and feedhq are untested, but also lot of features are supported.
special function calls are defined, but not yet implemented.
in september I will have my next exams, so not sure how much i will work on it
Jan Lukas Gernert
@jangernert
Cool stuff! Take your time and good luck with your exams. Is this the kind that are on the end of the semester holidays? I preferred having them before. Makes it easier to enjoy the time off.
Also definitely focus most of your energy on freshrss as that is what you're using. At some point I want to do a more prominent announcement that we're looking for people working on service implementations. Having docs was the first step =) Maybe people will join you in developing greader_api for other services.