by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 06:46
    trananhtuan synchronize #2713
  • Aug 02 21:16
    BrutuZ review_requested #2710
  • Aug 02 05:44
    trananhtuan synchronize #2713
  • Aug 02 03:26
    trananhtuan opened #2713
  • Aug 02 01:04
    BrutuZ commented #2712
  • Aug 01 14:18
    quekky commented #2712
  • Aug 01 14:17
    quekky commented #2712
  • Aug 01 11:11
    ianstalk commented #2712
  • Aug 01 11:11
    ianstalk commented #2712
  • Aug 01 06:39
    crawln45 commented #2712
  • Aug 01 03:53
    quekky edited #2712
  • Aug 01 03:52
    quekky opened #2712
  • Jul 25 20:25
    BrutuZ review_requested #2710
  • Jul 25 13:18

    gazpachoking on clean

    Automated ChangeLog update (compare)

  • Jul 25 13:15

    FlexGet-Bot on master

    Automated ChangeLog update (compare)

  • Jul 25 13:14

    FlexGet-Bot on develop

    [Add] webui version 2.0.20 (compare)

  • Jul 24 23:47

    gazpachoking on develop

    Make only_new run last priority… (compare)

  • Jul 24 21:56
    BrutuZ commented #2710
  • Jul 24 21:05
    BrutuZ synchronize #2710
  • Jul 23 23:55
    ianstalk commented #2710
FlexGet Bot
@FlexGet-Bot
barnseenio (irc) guess thats further down the line
barnseenio (irc) shit youve even got schedule and irc
FlexGet Bot
@FlexGet-Bot
barnseenio (irc) im back with a new dumb question - im trying to get proxying of rss requests going, and its not requesting via proxy, even though it seems to say it is in the flex log.
barnseenio (irc) my task config is here : https://pastebin.com/raw/eEuSVsQ8
barnseenio (irc) in the log i see Setting proxy to {'socks5': 'socks5://localhost:9050'} but on the server side i see my request come from the original IP, not via the proxy
barnseenio (irc) ive tried a few variations on config layout to no avail, and mixing up using http/socks5
barnseenio (irc) im pretty sure the proxy is working as i can curl to it as follows curl --socks5-hostname localhost:9050 ifconfig.me and i see the proxy IP
barnseenio (irc) any suggestions i can try out?
FlexGet Bot
@FlexGet-Bot
liiight (slack) @gazpachoking https://pre-commit.ci/
liiight (slack) Looks super promising
FlexGet Bot
@FlexGet-Bot
barnseenio (irc) Missing dependencies for SOCKS support
barnseenio (irc) oh no, its made a mess
barnseenio (irc) ran this pip3 install -U urllib3[socks]
barnseenio (irc) saw these
barnseenio (irc) ERROR: requests 2.21.0 has requirement urllib3<1.25,>=1.21.1, but you'll have urllib3 1.25.9 which is incompatible.
barnseenio (irc) ERROR: flexget 3.1.61 has requirement urllib3==1.24.2, but you'll have urllib3 1.25.9 which is incompatible.
barnseenio (irc) and now its all broke :(
barnseenio (irc) /usr/local/lib/python3.8/dist-packages/requests/init.py:89: RequestsDependencyWarning: urllib3 (1.25.9) or chardet (3.0.3) doesn't match a supported version!
barnseenio (irc) warnings.warn("urllib3 ({}) or chardet ({}) doesn't match a supported "
FlexGet Bot
@FlexGet-Bot
barnseenio (irc) hmm, ran pip3 install -U urllib3==1.24.2 and now appears to be back working, and with proxy support
FlexGet Bot
@FlexGet-Bot
barnseenio (irc) anyone awake for an rss/regex question?
barnseenio (irc) if i have an rss feed that has many entries, and includes a <category>abc</category> element, can you advise how i would filter that to only pick up category xyz
FlexGet Bot
@FlexGet-Bot
Brandon (slack) @barnseenio I think you could configure the rss plugin to have an other_fields: [category] entry, and then later on in your config use the if plugin to do something like:
  - "category != 'xyz'": reject
FlexGet Bot
@FlexGet-Bot
barnseenio (irc) thanks brandon, /w 14
barnseenio (irc) oops
barnseenio (irc) thanks brandon
barnseenio (irc) i kind of got it going with the regexp plugin, though it didnt work quite as i had expected. the category field defied being picked up by the regex, but if i used the description field it worked. so i settled for a regex on the description
FlexGet Bot
@FlexGet-Bot
paranoidi (slack) barnseenio: sounds like our requirements are not correct if proxy was broken like that
FlexGet Bot
@FlexGet-Bot
Shrike (irc) flexget forgets all seen items on a certain task EVERY SUNDAY
Shrike (irc) wouldn't mind, but that task basically makes my NAS redownload everything on my seedbox. every sunday.
FlexGet Bot
@FlexGet-Bot
liiight (slack) @Shrike seen plugin does not have db cleaning period at all AFAIK
liiight (slack) so that’s not supposed to happen…
Shrike (irc) I do see ANALYZE being run just before the issue reappears
Shrike (irc) I even nuked my databases and it still persists (I thought the issue might be my HUGE DB)
liiight (slack) could you show that task config?
Shrike (irc) sure, sec.
Shrike (irc) only_new and seen:local are the onlu suspicious parts in there
Shrike (irc) and this has worked for 2-3 years and started failing about 1-2 months ago
liiight (slack) dafaq is only_new
liiight (slack) why does it even exist?
liiight (slack) seen plugin kidna guruntees that already, doesnt it?
FlexGet Bot
@FlexGet-Bot
Shrike (irc) ¯_(ツ)_/¯
liiight (slack) yeah, read it. seems to predate seen to me
Shrike (irc) I'll remove that from my config and we'll check back next sunday? :)
liiight (slack) looking at its code its definitly conflicting with seen plugin
liiight (slack) i’d argue that we should even remove it from flexget at all
Shrike (irc) yeah, sounds like it
Shrike (irc) I'll nuke it from my configs