Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Oct 19 19:57
    lherschi opened #258
  • Oct 14 12:59

    evadot on 20211014_1

    (compare)

  • Oct 14 12:59

    evadot on master

    i915: Fix typo coffelake vs cof… (compare)

  • Oct 14 12:25

    evadot on 20211014

    (compare)

  • Oct 14 10:19

    evadot on master

    i915: Add a way to select which… amdgpu: Add a way to select whi… radeon: Add a way to select whi… (compare)

  • Oct 13 09:29

    evadot on master

    README: Fix 5.5 and 5.6 names … (compare)

  • Oct 11 07:29

    evadot on master

    amdgpu: Rollback firmware to 20… (compare)

  • Oct 08 15:11

    evadot on master

    amdgpu: Do not build green_sard… (compare)

  • Oct 08 13:55
    evadot closed #6
  • Oct 08 13:55
    evadot commented #6
  • Oct 08 13:53

    evadot on master

    i915: Add RAWVERSION for newer … gitignore: Add _bin and .h to t… i915: skl: Add latest GuC/HuC f… and 9 more (compare)

  • Oct 08 12:54

    evadot on master

    i915: Order lines in the Makefi… (compare)

  • Oct 08 12:44

    evadot on master

    intel: guc/huc: Use version nam… (compare)

  • Oct 08 12:36
    evadot closed #20
  • Oct 08 12:36
    evadot commented #20
  • Oct 08 12:35

    evadot on master

    intel: Remove unused tgl dmc fi… intel: Hook Tigerlake DMC firmw… (compare)

  • Oct 08 12:28

    evadot on master

    intel: dmc: Use version name in… (compare)

  • Oct 08 12:20

    evadot on master

    README: Rename Main firmware to… (compare)

  • Oct 08 12:18

    evadot on master

    README: Rename kms-firmware to … (compare)

  • Oct 08 12:17

    evadot on master

    README: Add notes on how to upd… (compare)

fbsdgitter
@fbsdgitter
[irc] <manu> oh ok found it
[irc] <manu> nm
[irc] <markuss> I have only integrated graphics. If it helps my laptop is HP Probook 455 G7
[irc] <manu> afaik we have everything for this chip in 5.6
[irc] <manu> so you did try with modesetting and xf86-video-amdgpu ?
fbsdgitter
@fbsdgitter
[irc] <markuss> I let both xorg start with default settings (xorg -configure gives me a file, which has set modesetting as default) and xf86-video-amdgpu with amdgpu driver written in a config file by me
[irc] <markuss> which gave me no success
[irc] <manu> delete the config file, don't generate one and just do startx
[irc] <manu> and paste the xorg log somewhere please
fbsdgitter
@fbsdgitter
[irc] <markuss> without even configuring xorg it freezes. The test I wanted to see is what driver xorg chooses, when generating a xorg config file
[irc] <markuss> and how can I take xorg log if everything freezes
[irc] <manu> can you ssh or the whole machine is frozen ?
[irc] <markuss> oh right I will try ssh
[irc] <markuss> someone told me told I should be able to go back to tty doing ctrl + alt + f2, but that didn't work
fbsdgitter
@fbsdgitter
[irc] <markuss> when I type startx it spits out that it has 2 missing files and it sits like that. Those two files are called .Xauthority and .serverauth.1313 and xorg says they are missing
[irc] <markuss> and after it gives out those lines I can't move the mouse and type anything
Alex
@shkhln
The log file should still be there after a reboot.
fbsdgitter
@fbsdgitter
[irc] <markuss> when I reboot there is nothing
[irc] <markuss> like there is no log to read
[irc] <markuss> maybe it doesn't save one if it "successfully" starts?
[irc] <manu> no there is always a log file
[irc] <manu> you don't have any /var/log/Xorg.0.log ?
fbsdgitter
@fbsdgitter
[irc] <markuss> manu: I don't have no xorg logs saved. Two things I'm thinking of. 1. I force shutdown the system while holding the power button and it doesn't save the log file 2. I turned on remove tmp at startup when installing freebsd.
fbsdgitter
@fbsdgitter
[irc] <markuss> y'all won't believe but I got xorg to start :D. I'm so hapoy
[irc] <markuss> fbsdgitte:
[irc] <markuss> Thanks to you both, I wouldn't gotten so far
[irc] <markuss> manu:
[irc] <markuss> all I did I reinstalled the system and did everything from scratch. Only this time I strictly lauched xorg from my user account, instead using root to launch xorg
fbsdgitter
@fbsdgitter
[irc] <markuss> only thing I just noticed is the bad screen tearing if I move a window around fast
fbsdgitter
@fbsdgitter
[irc] <manu> @unrelentingtech: ping
[irc] <manu> @unrelentingtech: could you test https://github.com/Beckhoff/drm-kmod/tree/manu/linux_fb with your amdgpu efifb conflict ?
[irc] <manu> @unrelentingtech: thanks :)
[irc] <manu> I can't reproduce here sorry
unrelentingtech
@unrelentingtech:mozilla.org
[m]
yea I'll test in a minute
woah that's a lot of commits
unrelentingtech
@unrelentingtech:mozilla.org
[m]
manu: works great!
I've added debug prints — so in my case the first overlap condition (fb->fb_pbase == a->ranges[i].base) is true (at 0x7c00000000) with the native GOP mode (which is actually currently only 1440p, it stopped being 4K after a mainboard firmware update or something o_0)
fbsdgitter
@fbsdgitter
[irc] <manu> @unrelentingtech: awesome
[irc] <manu> @unrelentingtech: yeah I basically rewrote fb.h and friends in this series
[irc] <manu> @unrelentingtech: thanks for testing, I wasn't 100% sure that the flag NOWRITE would work :)
unrelentingtech
@unrelentingtech:mozilla.org
[m]
hm actually I should also test again without the flag, I think it did fail at 1440p but I'm not 100% sure now
fbsdgitter
@fbsdgitter
[irc] <manu> based on the vt code we really shouldn't write to the framebuffer if it's set but maybe I've missed something
fbsdgitter
@fbsdgitter
[irc] <manu> for your GOP resolution problem, can't you change it in loader with the gop command ? maybe it default to 1440p now but 4k is still available ?
unrelentingtech
@unrelentingtech:mozilla.org
[m]
no, not available. from what I've observed, the amd gop driver only offers the highest possible mode as the first one, and then there's a bunch of classic 4:3 stuff.
but that doesn't matter, just tested, 1440 is affected just fine on vega :)
fbsdgitter
@fbsdgitter
[irc] <manu> ok so using the flags worked then ?
unrelentingtech
@unrelentingtech:mozilla.org
[m]
commented out the nowrite flag, now psp command failed and l2 protection fault and load failed in general and it stayed on efifb
fbsdgitter
@fbsdgitter
[irc] <manu> perfect then
[irc] <manu> thanks a lot !
[irc] <manu> will polish a few stuff and merge this early next week