Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Aug 17 09:32
    User @bjorno43 unbanned @linkin-park
  • Jun 20 21:19
    @bjorno43 banned @shenerd140
  • Apr 25 17:13
    @mstellaluna banned @cmal
  • Jan 08 22:05
    @mstellaluna banned @dertiuss323
  • Nov 07 2018 04:42
    User @texas2010 unbanned @ows-ali
  • Nov 02 2018 16:25
    @texas2010 banned @ows-ali
  • Oct 12 2018 05:50
    @bjorno43 banned @NACH74
  • Oct 05 2018 23:02
    @mstellaluna banned @JomoPipi
  • Sep 16 2018 12:21
    @bjorno43 banned @yash-kedia
  • Sep 16 2018 12:16
    @bjorno43 banned @vnikifirov
  • Sep 05 2018 08:12
    User @bjorno43 unbanned @androuino
  • Sep 05 2018 07:38
    @bjorno43 banned @androuino
  • Aug 23 2018 16:57
    User @bjorno43 unbanned @rahuldkjain
  • Aug 23 2018 16:23
    @bjorno43 banned @rahuldkjain
  • Jul 29 2018 14:13
    User @bjorno43 unbanned @jkyereh
  • Jul 29 2018 01:00
    @bjorno43 banned @jkyereh
  • Jul 10 2018 22:09
    @bjorno43 banned @manafn
  • Jul 06 2018 15:20
    @texas2010 banned @imlegend19
  • Jul 03 2018 12:28
    @bjorno43 banned @vbvmatta
  • Jun 29 2018 13:54
    @bjorno43 banned @OGTechnoBoy
neovks
@neovks
sure, so the border in question is the bottom one (the one around twitch) it's supposed to be thick etc but I can't change it as it is (.border in css)
Manan Shah
@mananshah51
@neovks you want the border to be thick ?
neovks
@neovks
well I want it to be like in my css part
.border {
border-style: solid;
border-width: 5px;
border-color: black;
border-radius: 5px;
width: 200px;
background-color: white;
margin: auto;
}
but none of this works except if I disable bootstrap 4
Gulsvi
@gulsvi
@neovks .border is a reserved utility class in bootstrap. Name your class something else, like .logo-border and it will work.
https://github.com/twbs/bootstrap/blob/v4-dev/dist/css/bootstrap.css#L6354
Ken Haduch
@khaduch
@neovks - you probably just have a conflict with a bootstrap class. Oops - @gulsvi just posted what I was going to say - pick a different name for the class and use that instead! ;)
@KWFE - I can see a problem when the dir="rtl" is added, even with the pages in English - as long as I'm seeing the same things that you are. The radio button circle is colliding with the text, so I'm trying to reconfigure the HTML, it is generated by the javascript code and I kind of have it working, just trying to figure out one other thing that I think should be working but doesn't seem to be.
neovks
@neovks
AHH !! DANG !thanks a lot!
thanks @gulsvi
CamperBot
@camperbot
neovks sends brownie points to @gulsvi :sparkles: :thumbsup: :sparkles:
:star2: 2639 | @gulsvi |http://www.freecodecamp.org/gulsvi
neovks
@neovks
thanks @khaduch
CamperBot
@camperbot
neovks sends brownie points to @khaduch :sparkles: :thumbsup: :sparkles:
:star2: 3772 | @khaduch |http://www.freecodecamp.org/khaduch
the fbi agent watching you
@krennical_twitter
On the Profile Lookup activity, why do you use return at the end of the for loop? Why can’t you use an else statement at the end of your first if statement instead?
Ken Haduch
@khaduch
@krennical_twitter - the reason is that you do not know if you have found a match in the list until you go all the way through the list, so you want to exit the for loop (which happens when you reach the end of the list.) If you haven't found a name match within the loop, and looked at every entry, then you know that you have no match...
To put it another way, if the first name doesn't match, you cannot just return. You have to look at the second, third, fourth, etc. for however many names are in the list. You can never assume that the next name isn't the one, so you have to look at it.
the fbi agent watching you
@krennical_twitter
@khaduch Thank you!! I've watched a good 4+ videos trying to wrap my head around it and what you said finally made me understand. I wasn't thinking about it in terms of going through the loop each time!
CamperBot
@camperbot
krennical_twitter sends brownie points to @khaduch :sparkles: :thumbsup: :sparkles:
:star2: 3773 | @khaduch |http://www.freecodecamp.org/khaduch
Ken Haduch
@khaduch
@neovks and @krennical_twitter - you're welcome. Happy to help out!
Ken Haduch
@khaduch

@KWFE - I hope that you can get this file and try it - it's not exactly right, but I think that it might help? What I did was to set up the page (the English version) using the global dir="rtol"and in the Chrome browser, I saw on the question modal that the label and the radio buttons were being mashed together, which kind of looks like what you were seeing in the image that you posted. At least that is what I think it was. So i made a copy of the main.js module from that original project and made some modifications to restructure the HTML for the label and radio button - they don't quite line up but they don't overlap now, at least on the English "rtol" site. The one function that I changed - here is the code:

// Get question info from array, prepare
// make a unique string to add to the ID, for testing
let idU = 0;
function getOptions(question) {
  var $buttonDiv = $('<div id="disabled" class="btn-group" data-toggle="buttons"></div>');
  idU++;
  question.options.forEach(function(opt, idx) {
    var $div = $('<div class="radio2">'); // use a non-existent class "radio2" because "radio" was giving bad styling
    let id = `quest${idx}_${idU}`;
    var $label = $(`<label class="radio-inline" for="${id}">${opt}</label>`);
    var $input = $(`<input type="radio" name="opts" value="${opt}" id="${id}">`);
    $div.append($input);
    //$label.append(opt);
    $div.append($label);
    $buttonDiv.append($div);
  });
  return $buttonDiv;
}

Maybe you could try that in the copy of the site that you are working on? Just replace that function with the text from above. Although I copied the whole file onto pastebin, but I'm not sure if you can get to it? Here is the link: pastebin copy of main.js. But I think that that function is the only thing that I changed, and added that one variable idU to try and see if I could get the label element for attribute to work, but for some reason that isn't working. I don't understand that, but the main thing is to see if you see any better result using that function with the reconfigured HTML code. I hope that it helps?

Darren
@DarrenfJ
evening fCC
coderNewby
@coderNewby
@DarrenfJ :wave:
thanks @DarrenfJ for the answers yesterday :D
CamperBot
@camperbot
codernewby sends brownie points to @darrenfj :sparkles: :thumbsup: :sparkles:
:star2: 2413 | @darrenfj |http://www.freecodecamp.org/darrenfj
Darren
@DarrenfJ
@coderNewby ah no worries brutha..
Ali Abbas
@Abbas-000
Hi guys can someone help me regarding to twitch TV challenge
Razvan Jackson
@RazvanJackson
Hello Guys!
Can someone help me?
I have multiple divs inline-table, but when one has more content than other all have a margin-top
Matej Bošnjak
@mbosnjak01
link your codepen
maybe someone could help u then :P
@Abbas-000 you as well :) and also what kind of issue you have?
Razvan Jackson
@RazvanJackson
alpox
@alpox
@RazvanJackson Which part of this is the one you are talking about?
Matej Bošnjak
@mbosnjak01
hmm not sure what you mean, it works fine to me
Razvan Jackson
@RazvanJackson
@alpox press generate button
and the last divs

Herr

Geschäftsführer (CEO)

phone: +

these ones should have started top
not center
alpox
@alpox
@RazvanJackson
.custom-row div {
    display: inline-table;
    vertical-align: top;
}
Does the trick
Razvan Jackson
@RazvanJackson
Thanks
alpox
@alpox
@RazvanJackson np
Ivan Ngundela
@ingundela
@ingundela
hello everyone.. may you please help with my project https://ingundela.github.io/fore/ . how can I add overlay and keep text content bright? when I add overlay it is also affecting the text content
when I add <div class="overlay"></div> (HTML) and this .overlay{
position: absolute;
width: 100%;
height: 100vh;
left: 0;
top: 0;
background-color: rgba(0,0,0,.6);
z-index: 2;
}
overlay is affecting the text content… please guide me to fix this.Thanks