Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • May 14 2020 22:38
    @bjorno43 banned @minitechtips_twitter
  • May 14 2020 22:37
    @bjorno43 banned @real-action
  • Feb 01 2020 00:26
    @bjorno43 banned @Ndoua
  • Jan 07 2020 03:07
    @bjorno43 banned @doctor-sam
  • Jun 20 2019 21:20
    @bjorno43 banned @shenerd140
  • May 10 2019 09:13
    @bjorno43 banned @zhaokunhaoa
  • Apr 25 2019 17:12
    @mstellaluna banned @cmal
  • Jan 08 2019 22:05
    @mstellaluna banned @dertiuss323
  • Oct 12 2018 05:50
    @bjorno43 banned @NACH74
  • Oct 05 2018 23:02
    @mstellaluna banned @JomoPipi
  • Sep 16 2018 12:21
    @bjorno43 banned @yash-kedia
  • Sep 16 2018 12:16
    @bjorno43 banned @vnikifirov
  • Sep 05 2018 08:13
    User @bjorno43 unbanned @androuino
  • Sep 05 2018 07:38
    @bjorno43 banned @androuino
  • Aug 23 2018 16:58
    User @bjorno43 unbanned @rahuldkjain
  • Aug 23 2018 16:23
    @bjorno43 banned @rahuldkjain
  • Jul 29 2018 14:15
    User @bjorno43 unbanned @jkyereh
  • Jul 29 2018 01:00
    @bjorno43 banned @jkyereh
  • Jul 10 2018 22:08
    @bjorno43 banned @manafn
  • Jul 06 2018 15:24
    @texas2010 banned @imlegend19
onriv
@onriv
docker? ld reallocated?
Christopher Jaeger
@caJaeger

When I do a systemctl start on a unit, does it use environment variables I have exported?

If it does, and the service crashes and restarts, are those variables still available to it?

Hussam Al-Tayeb
@ht990332
@caJaeger how did you set those environment variables?
If you set them just now and did systemctl start service, don't expect that to work.
if you want those environment variables to apply to the whole system, place them in /etc/environment.d/myvar.conf.
if you want them to be specific to that particular service, edit the unit file and add Environment=myvar=myvalue in the [Service] section.
Christopher Jaeger
@caJaeger
@hussamT That was my suspicion, thanks! I inherited a bunch of bash scripts that need updates and I am just trying to make sure I don't break anything. I didn't think services could ingest variables exported like that, but these scripts made me question myself!
Hussam Al-Tayeb
@ht990332
I would go for the last option
Christopher Jaeger
@caJaeger
Perfect, thanks! And thanks for the clarity, I am more confident with these changes now!
Christopher Jaeger
@caJaeger

@hussamT While you are here, I wonder if you have any idea how to accomplish something -

Say I have a variable defined in my shell. something=thing

How can I use the "env" keyword (or any method beyond export) to have that variable present in a child process if it's already set?

Hussam Al-Tayeb
@ht990332
the easiest way would be to "myvar=value childprocess"
Christopher Jaeger
@caJaeger
Right, but I already have the variable set elsewhere in the script
would I just myvar=$myvar childprocess? It seems redundant
Hussam Al-Tayeb
@ht990332
the child process should read it then as long as it was defined earlier.
Christopher Jaeger
@caJaeger
Oh I thought it needed to be explicitly exported to be read
Hussam Al-Tayeb
@ht990332
just childprocess will do
Christopher Jaeger
@caJaeger
huh. Okay, I definitely thought I had a handle on how that works but apparently not!
Hussam Al-Tayeb
@ht990332
here is a simple example https://pastebin.com/raw/9EkYkf7z
Hussam Al-Tayeb
@ht990332
now if you want your variables to be available only to the subcommand, you can wrap it in a function() and use "local myvar=value" then run 'function'
Carlos Valdez
@carlos_lvm_twitter
I have a question, is it possible to create interactive pdf forms with LaTeX?
Buğra
@BgR8
hi while i run the Yolo v4 COCO - WebCam 0: darknet detector demo cfg/coco.data cfg/yolov4.cfg yolov4.weights -c 0 terminal shows me GStreamer warning: GStreamer: pipeline have not been created and after that VIDIOC_QBUF: Invalid argument
or Yolo v4 COCO for net-videocam - Smart WebCam: darknet detector demo cfg/coco.data cfg/yolov4.cfg yolov4.weights http://192.168.0.80:8080/video?dummy=param.mjpg or another ip that android camera give and it shows me in red text "Connection to tcp://ipadress failed: No route to host and after that Video-stream stopped!
on Nvidia Jetson TX2
Guney01
@Guney01
hello dear , can anybody help me for .js app installer problem
my problem is on the screenshot
Carlos Valdez
@carlos_lvm_twitter
Does anybody have exp with brainfuck programming language?
Nadia
@nadiaschutz
is there a way to install linux on mac without erasing any data?
(◕‿‿◕。)
@yuumami97
@nadiaschutz You may try using a virtual machine, I use it for testing linux stuffs a lot
Nadia
@nadiaschutz
@yuumami97 thank you! forgot about this at all haha.
Jayce
@jaycethanks
hi friends
I have a question ,anybody can have a look
image.png
why the hostname are different between /etc/hostname file and the prompt notifier
Buğra
@BgR8
hi, how to plug Raspberry Pi Camera v2.1 to Jetson TX2
Buğra
@BgR8
hi, i want to write an application with PyQt5 or etc. on ubuntu and want to run like a calculator, office program, just click and launch, i mean launch not via terminal, not like python3 gui.py on terminal
Hussam Al-Tayeb
@ht990332
@jaycethanks Why is /etc/hostname two lines?
Carlos Valdez
@carlos_lvm_twitter
does anyone have experience with JACK?
Francis Rodrigues
@francisrod01
Hi there, please I need help to setup Chinese keyboard to my Debian stretch.
WebGearMT
@WebGearMT

Hi everyone! I've got a little concern here.

I'm running linux mint and have upgraded from 19.3 to 20. During the upgrade a lot of errors appeared, one of them is this one:

Unhandled Exception:
System.TypeInitializationException: The type initializer for 'Sys' threw an exception. ---> System.DllNotFoundException: System.Native assembly:<unknown assembly> type:<unknown type> member:(null)

Here's the full stack trace:

Unhandled Exception:
System.TypeInitializationException: The type initializer for 'Sys' threw an exception. ---> System.DllNotFoundException: System.Native assembly:<unknown assembly> type:<unknown type> member:(null)
  at (wrapper managed-to-native) Interop+Sys.LChflagsCanSetHiddenFlag()
  at Interop+Sys..cctor () [0x00000] in <12b418a7818c4ca0893feeaaf67f1e7f>:0 
   --- End of inner exception stack trace ---
  at System.IO.FileSystem.FileExists (System.ReadOnlySpan`1[T] fullPath, System.Int32 fileType, Interop+ErrorInfo& errorInfo) [0x0000f] in <12b418a7818c4ca0893feeaaf67f1e7f>:0 
  at System.IO.FileSystem.FileExists (System.ReadOnlySpan`1[T] fullPath) [0x00006] in <12b418a7818c4ca0893feeaaf67f1e7f>:0 
  at System.IO.File.Exists (System.String path) [0x00058] in <12b418a7818c4ca0893feeaaf67f1e7f>:0 
  at Mono.Tools.Driver.LoadConfig (System.Boolean quiet) [0x00031] in <c1f3f44c980c4c748aff61945c8f618f>:0 
  at Mono.Tools.Driver.Main (System.String[] args) [0x00347] in <c1f3f44c980c4c748aff61945c8f618f>:0 
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: The type initializer for 'Sys' threw an exception. ---> System.DllNotFoundException: System.Native assembly:<unknown assembly> type:<unknown type> member:(null)
  at (wrapper managed-to-native) Interop+Sys.LChflagsCanSetHiddenFlag()
  at Interop+Sys..cctor () [0x00000] in <12b418a7818c4ca0893feeaaf67f1e7f>:0 
   --- End of inner exception stack trace ---
  at System.IO.FileSystem.FileExists (System.ReadOnlySpan`1[T] fullPath, System.Int32 fileType, Interop+ErrorInfo& errorInfo) [0x0000f] in <12b418a7818c4ca0893feeaaf67f1e7f>:0 
  at System.IO.FileSystem.FileExists (System.ReadOnlySpan`1[T] fullPath) [0x00006] in <12b418a7818c4ca0893feeaaf67f1e7f>:0 
  at System.IO.File.Exists (System.String path) [0x00058] in <12b418a7818c4ca0893feeaaf67f1e7f>:0 
  at Mono.Tools.Driver.LoadConfig (System.Boolean quiet) [0x00031] in <c1f3f44c980c4c748aff61945c8f618f>:0 
  at Mono.Tools.Driver.Main (System.String[] args) [0x00347] in <c1f3f44c980c4c748aff61945c8f618f>:0 
W: removing assembly: policy.2.10.glib-sharp, Version=0.0.0.0, Culture=neutral, PublicKeyToken=35e10195dab3c99f failed!

It threw out this stack trace a couple of times until it eventually stopped and continued. The part that worries me a bit is the part that says (basically the same as the message at the beginning of the stack trace, only with the words fatal unhandled):

[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: The type initializer for 'Sys' threw an exception. ---> System.DllNotFoundException: System.Native assembly:<unknown assembly> type:<unknown type> member:(null)

However, I restarted my pc after the upgrade was done and I had no issues. it does however throw out a bunch of errors in a terminal which ends up in a login request asking for my password, then suddenly dissapearing and starting like normal.

I searched this error and found solutions that entailed that I might have to downgrade back to 19.3 and restart the upgrade. So far however I had no serious issues but I'm worried that I might have some later on, is this serious? Do I still need to downgrade back to 19.3 or can it be easily fixed?

Here's my system info if it might help:

OS: Linux Mint 20 (Ulyana)
Architecture: AMD 64 bit

thanks in advance!
chama-chomo
@chama-chomo
@WebGearMT looks like some Mono related stuff, I wouldn't be too much worried about it unless you use it
WebGearMT
@WebGearMT
@chama-chomo ok, thanks
Buğra
@BgR8
hey, when i run import numpy as np for python3 in ubuntu terminal it shows illegal instruction (core dumped)
GcoderK
@GcoderK_twitter
Hi. I'm finally making the shift from Win 10 to Linux. I have tried Linux mint in the past, with a dual boot. Now I'm going all in with Linux. Any distro suggested for the beginners? I'd shortlisted to Ubuntu, Linux Mint & Pop OS. And I'm leaning towards Pop OS. Any other distro suggestion for a novice? I understand that it is a personal preference. Yet I wanted to know the pulse.
Hussam Al-Tayeb
@ht990332
@GcoderK_twitter this depends on why you want to use Linux and your previous workflow on Windows
I would go for ubuntu 2
20.04