Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • May 14 2020 22:38
    @bjorno43 banned @minitechtips_twitter
  • May 14 2020 22:37
    @bjorno43 banned @real-action
  • Feb 01 2020 00:26
    @bjorno43 banned @Ndoua
  • Jan 07 2020 03:07
    @bjorno43 banned @doctor-sam
  • Jun 20 2019 21:20
    @bjorno43 banned @shenerd140
  • May 10 2019 09:13
    @bjorno43 banned @zhaokunhaoa
  • Apr 25 2019 17:12
    @mstellaluna banned @cmal
  • Jan 08 2019 22:05
    @mstellaluna banned @dertiuss323
  • Oct 12 2018 05:50
    @bjorno43 banned @NACH74
  • Oct 05 2018 23:02
    @mstellaluna banned @JomoPipi
  • Sep 16 2018 12:21
    @bjorno43 banned @yash-kedia
  • Sep 16 2018 12:16
    @bjorno43 banned @vnikifirov
  • Sep 05 2018 08:13
    User @bjorno43 unbanned @androuino
  • Sep 05 2018 07:38
    @bjorno43 banned @androuino
  • Aug 23 2018 16:58
    User @bjorno43 unbanned @rahuldkjain
  • Aug 23 2018 16:23
    @bjorno43 banned @rahuldkjain
  • Jul 29 2018 14:15
    User @bjorno43 unbanned @jkyereh
  • Jul 29 2018 01:00
    @bjorno43 banned @jkyereh
  • Jul 10 2018 22:08
    @bjorno43 banned @manafn
  • Jul 06 2018 15:24
    @texas2010 banned @imlegend19
Buğra
@BgR8
hi, how to plug Raspberry Pi Camera v2.1 to Jetson TX2
Buğra
@BgR8
hi, i want to write an application with PyQt5 or etc. on ubuntu and want to run like a calculator, office program, just click and launch, i mean launch not via terminal, not like python3 gui.py on terminal
Hussam Al-Tayeb
@ht990332
@jaycethanks Why is /etc/hostname two lines?
Carlos Valdez
@carlos_lvm_twitter
does anyone have experience with JACK?
Francis Rodrigues
@francisrod01
Hi there, please I need help to setup Chinese keyboard to my Debian stretch.
WebGearMT
@WebGearMT

Hi everyone! I've got a little concern here.

I'm running linux mint and have upgraded from 19.3 to 20. During the upgrade a lot of errors appeared, one of them is this one:

Unhandled Exception:
System.TypeInitializationException: The type initializer for 'Sys' threw an exception. ---> System.DllNotFoundException: System.Native assembly:<unknown assembly> type:<unknown type> member:(null)

Here's the full stack trace:

Unhandled Exception:
System.TypeInitializationException: The type initializer for 'Sys' threw an exception. ---> System.DllNotFoundException: System.Native assembly:<unknown assembly> type:<unknown type> member:(null)
  at (wrapper managed-to-native) Interop+Sys.LChflagsCanSetHiddenFlag()
  at Interop+Sys..cctor () [0x00000] in <12b418a7818c4ca0893feeaaf67f1e7f>:0 
   --- End of inner exception stack trace ---
  at System.IO.FileSystem.FileExists (System.ReadOnlySpan`1[T] fullPath, System.Int32 fileType, Interop+ErrorInfo& errorInfo) [0x0000f] in <12b418a7818c4ca0893feeaaf67f1e7f>:0 
  at System.IO.FileSystem.FileExists (System.ReadOnlySpan`1[T] fullPath) [0x00006] in <12b418a7818c4ca0893feeaaf67f1e7f>:0 
  at System.IO.File.Exists (System.String path) [0x00058] in <12b418a7818c4ca0893feeaaf67f1e7f>:0 
  at Mono.Tools.Driver.LoadConfig (System.Boolean quiet) [0x00031] in <c1f3f44c980c4c748aff61945c8f618f>:0 
  at Mono.Tools.Driver.Main (System.String[] args) [0x00347] in <c1f3f44c980c4c748aff61945c8f618f>:0 
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: The type initializer for 'Sys' threw an exception. ---> System.DllNotFoundException: System.Native assembly:<unknown assembly> type:<unknown type> member:(null)
  at (wrapper managed-to-native) Interop+Sys.LChflagsCanSetHiddenFlag()
  at Interop+Sys..cctor () [0x00000] in <12b418a7818c4ca0893feeaaf67f1e7f>:0 
   --- End of inner exception stack trace ---
  at System.IO.FileSystem.FileExists (System.ReadOnlySpan`1[T] fullPath, System.Int32 fileType, Interop+ErrorInfo& errorInfo) [0x0000f] in <12b418a7818c4ca0893feeaaf67f1e7f>:0 
  at System.IO.FileSystem.FileExists (System.ReadOnlySpan`1[T] fullPath) [0x00006] in <12b418a7818c4ca0893feeaaf67f1e7f>:0 
  at System.IO.File.Exists (System.String path) [0x00058] in <12b418a7818c4ca0893feeaaf67f1e7f>:0 
  at Mono.Tools.Driver.LoadConfig (System.Boolean quiet) [0x00031] in <c1f3f44c980c4c748aff61945c8f618f>:0 
  at Mono.Tools.Driver.Main (System.String[] args) [0x00347] in <c1f3f44c980c4c748aff61945c8f618f>:0 
W: removing assembly: policy.2.10.glib-sharp, Version=0.0.0.0, Culture=neutral, PublicKeyToken=35e10195dab3c99f failed!

It threw out this stack trace a couple of times until it eventually stopped and continued. The part that worries me a bit is the part that says (basically the same as the message at the beginning of the stack trace, only with the words fatal unhandled):

[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: The type initializer for 'Sys' threw an exception. ---> System.DllNotFoundException: System.Native assembly:<unknown assembly> type:<unknown type> member:(null)

However, I restarted my pc after the upgrade was done and I had no issues. it does however throw out a bunch of errors in a terminal which ends up in a login request asking for my password, then suddenly dissapearing and starting like normal.

I searched this error and found solutions that entailed that I might have to downgrade back to 19.3 and restart the upgrade. So far however I had no serious issues but I'm worried that I might have some later on, is this serious? Do I still need to downgrade back to 19.3 or can it be easily fixed?

Here's my system info if it might help:

OS: Linux Mint 20 (Ulyana)
Architecture: AMD 64 bit

thanks in advance!
chama-chomo
@chama-chomo
@WebGearMT looks like some Mono related stuff, I wouldn't be too much worried about it unless you use it
WebGearMT
@WebGearMT
@chama-chomo ok, thanks
Buğra
@BgR8
hey, when i run import numpy as np for python3 in ubuntu terminal it shows illegal instruction (core dumped)
GcoderK
@GcoderK_twitter
Hi. I'm finally making the shift from Win 10 to Linux. I have tried Linux mint in the past, with a dual boot. Now I'm going all in with Linux. Any distro suggested for the beginners? I'd shortlisted to Ubuntu, Linux Mint & Pop OS. And I'm leaning towards Pop OS. Any other distro suggestion for a novice? I understand that it is a personal preference. Yet I wanted to know the pulse.
Hussam Al-Tayeb
@ht990332
@GcoderK_twitter this depends on why you want to use Linux and your previous workflow on Windows
I would go for ubuntu 2
20.04
Or Oracle linux 8
GcoderK
@GcoderK_twitter
@ht990332 Thanks for the inputs. I've moved to Pop!_OS, based on Ubuntu, with lean GNOME. So far, I'm loving it.
Hussam Al-Tayeb
@ht990332
nice. have fun.
edisonlu
@edisonlu
hello, everybody
is anyone here?
igorgolm
@igorgolm
jep :)
Hussam Al-Tayeb
@ht990332
hi
AngeloFly
@AngeloFly
hi guys. i am beginner. Hope to communicate with everyone
deepakravibabu
@deepakravibabu
Hi,
I am using petalinux to build linux image for my zynq board. Can anyone please let me know how I can tell petalinux to include kernel-headers in the image file generated.
Arkankhan Pathan
@arkankhan-ak
Hello, I am facing problem in mint linux once i have restarted my machine, 'a start job is running until boot process finishes up'
If anyone of you can help me out i will be thankful to you !
12annumishra17
@12annumishra17
Hey Team
I am trying one command 'yum list kernel'
And trying to capture kernel version which is there across available packages
Can anbody help with bash over here
Andme
@YanHuaSuiMei

hi, what's the ala means here:

Tree is a recursive directory listing program that produces a depth indented listing of files, which is colorized ala dircolors if the LS_COLORS environment variable is set and output is to tty.

come from: man tree

can anyone help me?

vikeshkataria
@vikeshkataria

I am getting 502 Bad gateway reverse proxy server , when i am accessing API.

Configured krestel service port on 5001 and defined into appsetting.json

I performed these steps

  1. Publish code through command for Linux :
    dotnet publish --self-contained -c Release -r linux-x64
  2. Copied published data on var/www/API folder
  3. Created krestel service with below configuration

           [Unit]
           Description=WebAPIApp
           [Service]
           WorkingDirectory=/var/www/API
           ExecStart=/usr/bin/dotnet /var/www/API/WebAPI.dll
           Restart=always
           # Restart service after 10 seconds if the dotnet service crashes:
           RestartSec=10
           KillSignal=SIGINT
           SyslogIdentifier=dotnet-example
           User=www-data
           Environment=ASPNETCORE_ENVIRONMENT=Production
    
           Environment=DOTNET_PRINT_TELEMETRY_MESSAGE=false
    
           [Install]
           WantedBy=multi-user.target
  4. tested krestel service and its working without any error.
  5. Now, I created site on nginx with below configuration
           server {
           listen        4001;
           location / {
               proxy_pass         http://MachineNamewithDomain:5001;
               proxy_http_version 1.1;
               proxy_set_header   Upgrade $http_upgrade;
               proxy_set_header   Connection keep-alive;
               proxy_set_header   Host $host;
               proxy_cache_bypass $http_upgrade;
               proxy_set_header   X-Forwarded-For $proxy_add_x_forwarded_for;
               proxy_set_header   X-Forwarded-Proto $scheme;
           }
       }
  6. enabled site in sites-enabled directory..
  7. allowed or open 4001 ,5001 port on network.
  8. i made entry on /etc/hosts as well defined URL
    10.10.10.10 API
  9. reboot of machine.
  10. After reboot, I checked service is Up and running on port number 4001 .. I tried to access swagger and it is also working but
    when i am executing API its execute only once after that it is giving 502 bad gateway error.. I checked the logs there was nothing.
    11 then i tried to access krestel service , its also running and up.. I tried to access swagger , it is also working and able to access all API without any error.

  11. I configured krestel service URL (port number 5001) with Angular UI.. Application is working now but i observed two challanges there

    1. sometimes it is not responding and response is coming blank.. I check on browser network HTTPstatuscode 200
    2. Paralle request genrating from UI ( 20 requests of same single API ) in that case it is taking time and few requests converting into CORS error and getting response of some request.. i checked the log i am getting socket exception error
      2021-04-26 06:10:52,700 [139] ERROR System.Threading.Tasks.TaskCanceledException: The operation was canceled.
      ---> System.IO.IOException: Unable to read data from the transport connection: Operation canceled.
      ---> System.Net.Sockets.SocketException (125): Operation canceled
      --- End of inner exception stack trace ---
      at System.Net.Sockets.Socket.AwaitableSocketAsyncEventArgs.ThrowException(SocketError error, CancellationToken cancellationToken)
      at System.Net.Sockets.Socket.AwaitableSocketAsyncEventArgs.GetResult(Int16 token)
      at System.Net.Http.HttpConnection.FillAsync()
      at System.Net.Http.HttpConnection.ReadNextResponseHeaderLineAsync(Boolean foldedHeadersAllowed)
      at System.Net.Http.HttpConnection.SendAsyncCore(HttpRequestMessage request, CancellationToken cancellationToken)
      --- End of inner exception stack trace ---
      at System.Net.Http.HttpConnection.SendAsyncCore(HttpRequestMessage request, CancellationToken cancellationToken)
      at System.Net.Http.HttpConnectionPool.SendWithNtConnectionAuthAsync(HttpConnection connection, HttpRequestMessage request, Boolean doRequestAuth, CancellationToken cancellationToken)
      at System.Net.Http.HttpConnectionPool.SendWithRetryAsync(HttpRequ