Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Nov 19 02:58
    cmdcolin commented #1556
  • Nov 19 02:56
    cmdcolin commented #1556
  • Nov 19 02:55

    cmdcolin on uniqueID_remove_gff3tabix

    Remove uniqueID from featureData (compare)

  • Nov 18 06:49
    Jungal10 commented #1556
  • Nov 17 20:36
    cmdcolin commented #1556
  • Nov 17 20:33
    cmdcolin commented #1556
  • Nov 13 19:04
    jrobinso opened #118
  • Nov 13 18:22
    Jungal10 commented #1556
  • Nov 13 18:21
    Jungal10 commented #1556
  • Nov 13 15:41
    cmdcolin commented #1556
  • Nov 13 06:24
    Jungal10 commented #1556
  • Nov 12 22:59
    cmdcolin commented #1556
  • Nov 12 22:39
    Jungal10 edited #1556
  • Nov 12 22:38
    Jungal10 opened #1556
  • Nov 12 21:52
    cmdcolin commented #1555
  • Nov 12 21:47
    cmdcolin commented #1555
  • Nov 12 21:46
    cmdcolin commented #1555
  • Nov 12 17:43
    GFJHogue opened #1555
  • Nov 10 00:38
    jrobinso commented #79
  • Nov 09 22:57
    cmdcolin commented #67
David Eccles (gringer)
@gringer

Here it is with all BAM filters turned off, no change in the 4-5.1k region:

max coverage still 8

David Eccles (gringer)
@gringer
Copied the BAM file to another file name in the same directory (test.bam), and it's working...
BAM track showing much greater coverage
David Eccles (gringer)
@gringer
But the md5 hashes for the files match:
[tracks.bw-GC_0013_S2_B16WTcDNA_BC12-both-track ]
storeClass     = StrandedPlotPlugin/Store/SeqFeature/StrandedBigWig
urlTemplate    = bw/mm2_called_GC_0013_S2_B16WTcDNA_BC12_vs_MmusG.bw
category       = MinION / Coverage
type           = StrandedPlotPlugin/View/Track/Wiggle/StrandedXYPlot
key            = Minimap2 coverage from B16.WT#A [GCOct20]
scale          = log
scoreType      = maxScore
autoscale      = global
style.pos_color = #228B22
style.neg_color = lightskyblue

[tracks.bw-test-track ]
storeClass     = StrandedPlotPlugin/Store/SeqFeature/StrandedBigWig
urlTemplate    = bw/dummy.bw
category       = MinION / Coverage
type           = StrandedPlotPlugin/View/Track/Wiggle/StrandedXYPlot
key            = Dummy coverage from B16.WT#A [GCOct20]
scale          = log
scoreType      = maxScore
autoscale      = global  
style.pos_color = #228B22
style.neg_color = lightskyblue
$ md5sum bw/dummy.bw.plus bw/mm2_GC_0013_S2_called_BC12_vs_MmusG.bw.plus
6cb081b194ba930818fd7099fe9bc81f  bw/mm2_GC_0013_S2_called_BC12_vs_MmusG.bw.plus
6cb081b194ba930818fd7099fe9bc81f  bw/dummy.bw.plus
Colin Diesh
@cmdcolin
thats pretty weird
@scottcain i hit the reboot button on covid19.jbrowse.org
David Eccles (gringer)
@gringer
I've renamed the copied files to "_allReads" and deleted the originals. I just hope I don't have to do this every time I update a track.
Colin Diesh
@cmdcolin
the most likely thing is client side cache
but i know you mentioned the other browser weirdness so hard to say
there is also a thing called cacheBusting where you can add a random string to the end of the url
but we dont do that generally
(i gotta watch movie now but lemme know if anything comes up)
David Eccles (gringer)
@gringer
Seems to just be those two tracks; other tracks where I've updated the underlying files aren't displaying the same issues
Scott Cain
@scottcain
@cmdcolin from Terence at NCBI: "Thanks again for the report. We’ve made some changes to our web server so that the “Content-Type: application/x-bam” header should be consistently returned. It looks like this has fixed the problem for IGV. Does that fix the JBrowse problem as well?"
Colin Diesh
@cmdcolin
should work now ya
Colin Diesh
@cmdcolin
i will check shortly but quickly looking at a previous example where it failed it is no longer returning content-encoding:gzip which is what we wanted
send terence a big thanks :]
Scott Cain
@scottcain
I sent him a response thanking him and his team and said it almost certainly fixed the problem but I would let him know if we run into anything else.
Scott Cain
@scottcain
@cmdcolin I think the wigglehighlighter plugin may have stopped working recently. At https://staging.wormbase.org/tools/genome/jbrowse-simple/?data=data%2Fc_elegans_PRJNA13758&loc=II%3A1..1758000&tracks=ALY-2%20Combined%20(GFP%20ChIP)_%20ALY-2_GFP_L2%20w%20peaks I get an error message like TypeError: s.config.highlightColor is not a function TypeError: s.config.highlightColor is not a function Is that more likely something I did, or something that happened in JBrowse core?
The bigwig and bigbed files both continue to exist. The bigbed has Content-Encoding: bzip2 and Content-Type: binary/octet-stream
Colin Diesh
@cmdcolin
might have changed a little bit
there was a user coding and iterating the wigglehighlighter codebase
lemme check
Scott Cain
@scottcain
Oh, and in case it matters, I’m using the dev branch for jbrowse.
Colin Diesh
@cmdcolin
could try to pull from wigglehighlighter master
it has an update
Scott Cain
@scottcain
I’m guessing I can supress that somehow
Colin Diesh
@cmdcolin
I think you have showLabels: true on there
or actually
can set showLabels:false
i guess its true by default
i could switch it if it seems easier
Scott Cain
@scottcain
Interesting—I don’t think the labels were there before. Anyway, making it false by default would be a lot easier since I have quite a few tracks, and I suspect most people would want it off in a context like this anyway.
Colin Diesh
@cmdcolin
ok
ill just switch it off
Scott Cain
@scottcain
👍
Colin Diesh
@cmdcolin
should be updated again
Scott Cain
@scottcain
Looks good; thanks @cmdcolin
Colin Diesh
@cmdcolin
very good
Scott Cain
@scottcain
In the indexed file tutorial, it doesn’t mention bgziped fasta as a option. I’m guessing those are supported though, right? So I should be good if I supply .gz, .gz.fai and .gz.gzi files, ya?
Garrett Stevens
@garrettjstevens
Should work, and you can use faiUrlTemplate and gziUrlTemplate if it doesn't pick them up automatically from the urlTemplate
Scott Cain
@scottcain
👍
Domenico Simone
@domenico-simone

Hello,

I am using maker2jbrowse with this GFF:

https://github.com/domenico-simone/jbrowse_mini_test/blob/test/input_data_201021/all.batches.wseqs.annotation.test.2.clean.gff

This is an excerpt of the settings I'm using in the script:

my %commands = (

    #MAKER anotations
    gene            => [ '--key' => "Gene spans",
                         '--className' =>  'feature',
                         '--type' => 'gene:maker',
                         '--noSubfeatures'
                       ],
    maker           => [ '--key' => "Transcripts",
                         '--className' => 'transcript',
                         '--subfeatureClasses' => '{"exon": "exon", "CDS": "CDS", "five_prime_UTR": "five_prime_UTR", "three_prime_UTR": "three_prime_UTR"}',
                         '--type'  => 'mRNA:maker',
                         '--nameAttributes' => 'name,alias,id,note,dbxref,ontology_term'
                       ],

The building process works fine, but when I open the genome browser the "Gene spans" track is not loaded (see attached figure)

am I missing anything from the configuration?

Thank you,

Domenico

image.png
Colin Diesh
@cmdcolin
@domenico-simone I found this error too recently GMOD/jbrowse#1548
I think I know what it could be...will have to check into it
Domenico Simone
@domenico-simone
Thank you @cmdcolin, I'm following the thread on github
Colin Diesh
@cmdcolin
added a small pr...