Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Nov 19 02:58
    cmdcolin commented #1556
  • Nov 19 02:56
    cmdcolin commented #1556
  • Nov 19 02:55

    cmdcolin on uniqueID_remove_gff3tabix

    Remove uniqueID from featureData (compare)

  • Nov 18 06:49
    Jungal10 commented #1556
  • Nov 17 20:36
    cmdcolin commented #1556
  • Nov 17 20:33
    cmdcolin commented #1556
  • Nov 13 19:04
    jrobinso opened #118
  • Nov 13 18:22
    Jungal10 commented #1556
  • Nov 13 18:21
    Jungal10 commented #1556
  • Nov 13 15:41
    cmdcolin commented #1556
  • Nov 13 06:24
    Jungal10 commented #1556
  • Nov 12 22:59
    cmdcolin commented #1556
  • Nov 12 22:39
    Jungal10 edited #1556
  • Nov 12 22:38
    Jungal10 opened #1556
  • Nov 12 21:52
    cmdcolin commented #1555
  • Nov 12 21:47
    cmdcolin commented #1555
  • Nov 12 21:46
    cmdcolin commented #1555
  • Nov 12 17:43
    GFJHogue opened #1555
  • Nov 10 00:38
    jrobinso commented #79
  • Nov 09 22:57
    cmdcolin commented #67
Colin Diesh
@cmdcolin
lemme check
Scott Cain
@scottcain
Oh, and in case it matters, I’m using the dev branch for jbrowse.
Colin Diesh
@cmdcolin
could try to pull from wigglehighlighter master
it has an update
Scott Cain
@scottcain
I’m guessing I can supress that somehow
Colin Diesh
@cmdcolin
I think you have showLabels: true on there
or actually
can set showLabels:false
i guess its true by default
i could switch it if it seems easier
Scott Cain
@scottcain
Interesting—I don’t think the labels were there before. Anyway, making it false by default would be a lot easier since I have quite a few tracks, and I suspect most people would want it off in a context like this anyway.
Colin Diesh
@cmdcolin
ok
ill just switch it off
Scott Cain
@scottcain
👍
Colin Diesh
@cmdcolin
should be updated again
Scott Cain
@scottcain
Looks good; thanks @cmdcolin
Colin Diesh
@cmdcolin
very good
Scott Cain
@scottcain
In the indexed file tutorial, it doesn’t mention bgziped fasta as a option. I’m guessing those are supported though, right? So I should be good if I supply .gz, .gz.fai and .gz.gzi files, ya?
Garrett Stevens
@garrettjstevens
Should work, and you can use faiUrlTemplate and gziUrlTemplate if it doesn't pick them up automatically from the urlTemplate
Scott Cain
@scottcain
👍
Domenico Simone
@domenico-simone

Hello,

I am using maker2jbrowse with this GFF:

https://github.com/domenico-simone/jbrowse_mini_test/blob/test/input_data_201021/all.batches.wseqs.annotation.test.2.clean.gff

This is an excerpt of the settings I'm using in the script:

my %commands = (

    #MAKER anotations
    gene            => [ '--key' => "Gene spans",
                         '--className' =>  'feature',
                         '--type' => 'gene:maker',
                         '--noSubfeatures'
                       ],
    maker           => [ '--key' => "Transcripts",
                         '--className' => 'transcript',
                         '--subfeatureClasses' => '{"exon": "exon", "CDS": "CDS", "five_prime_UTR": "five_prime_UTR", "three_prime_UTR": "three_prime_UTR"}',
                         '--type'  => 'mRNA:maker',
                         '--nameAttributes' => 'name,alias,id,note,dbxref,ontology_term'
                       ],

The building process works fine, but when I open the genome browser the "Gene spans" track is not loaded (see attached figure)

am I missing anything from the configuration?

Thank you,

Domenico

image.png
Colin Diesh
@cmdcolin
@domenico-simone I found this error too recently GMOD/jbrowse#1548
I think I know what it could be...will have to check into it
Domenico Simone
@domenico-simone
Thank you @cmdcolin, I'm following the thread on github
Colin Diesh
@cmdcolin
added a small pr...
for the maker2jbrowse thing
Domenico Simone
@domenico-simone
Hi @cmdcolin thank you! this is what I get now:
image.png
which is already something :) although not exactly what I was expecting! :)
Colin Diesh
@cmdcolin
ah right. i guess technically the gene spans maybe used to be just a single box covering the gene region but maybe it automatically loads individual transcripts now
Scott Cain
@scottcain
Colin Diesh
@cmdcolin
ur gonna wanna set
storeClass: JBrowse/Store/SeqFeature/BgzipIndexedFasta
Scott Cain
@scottcain
👍
I figured the adapter would just “figure it out” :-)
Domenico Simone
@domenico-simone

ah right. i guess technically the gene spans maybe used to be just a single box covering the gene region but maybe it automatically loads individual transcripts now

@cmdcolin I think you're right. So far, in my case showing only the transcripts is ok. However, if this could be fixed it would be great :)

Scott Cain
@scottcain
@cmdcolin covid19.jbrowse.org is down. Can you please give it a swift kick? Thanks
Colin Diesh
@cmdcolin
@scottcain i rebooted it awhile ago and it did not come back up
is there an issue with it?
Scott Cain
@scottcain
:shrug: I don’t know anything about how it’s set up, but I don't think anything has changed recently.
Colin Diesh
@cmdcolin
i hit the reboot on it
confirmed that the ip in aws console == ping covid19.jbrowse.org ip
Ian Holmes
@ihh
is there a reason it needs to be an EC2 node and not just a static site?
Scott Cain
@scottcain
Nope. I’m not sure when that decision was made. I had a docker container so somebody (perhaps @nathandunn ) decided to just run an EC2 with the docker running on it. I can set up a static site fairly easily.
Colin Diesh
@cmdcolin
prolly upload the data to s3
i dunno whats goin on with that instance though
it says it is running now