Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 01:23
    codecov[bot] commented #119
  • 01:20
    codecov[bot] commented #119
  • 00:26
    dependabot[bot] labeled #1557
  • 00:26
    dependabot[bot] opened #1557
  • 00:26

    dependabot[bot] on npm_and_yarn

    Bump highlight.js from 9.12.0 t… (compare)

  • Nov 24 23:44
    dependabot[bot] labeled #28
  • Nov 24 23:44
    dependabot[bot] opened #28
  • Nov 24 23:44

    dependabot[bot] on npm_and_yarn

    Bump highlight.js from 9.15.8 t… (compare)

  • Nov 24 23:44
    dependabot[bot] labeled #45
  • Nov 24 23:44
    dependabot[bot] opened #45
  • Nov 24 23:44

    dependabot[bot] on npm_and_yarn

    Bump highlight.js from 9.15.8 t… (compare)

  • Nov 24 23:43
    dependabot[bot] labeled #27
  • Nov 24 23:43
    dependabot[bot] opened #27
  • Nov 24 23:43

    dependabot[bot] on npm_and_yarn

    Bump highlight.js from 9.15.8 t… (compare)

  • Nov 24 23:43
    codecov[bot] commented #15
  • Nov 24 23:43
    dependabot[bot] labeled #81
  • Nov 24 23:43
    dependabot[bot] opened #81
  • Nov 24 23:43

    dependabot[bot] on npm_and_yarn

    Bump highlight.js from 9.15.10 … (compare)

  • Nov 24 23:42
    codecov[bot] commented #15
  • Nov 24 23:42
    codecov[bot] commented #61
Colin Diesh
@cmdcolin
can set showLabels:false
i guess its true by default
i could switch it if it seems easier
Scott Cain
@scottcain
Interesting—I don’t think the labels were there before. Anyway, making it false by default would be a lot easier since I have quite a few tracks, and I suspect most people would want it off in a context like this anyway.
Colin Diesh
@cmdcolin
ok
ill just switch it off
Scott Cain
@scottcain
👍
Colin Diesh
@cmdcolin
should be updated again
Scott Cain
@scottcain
Looks good; thanks @cmdcolin
Colin Diesh
@cmdcolin
very good
Scott Cain
@scottcain
In the indexed file tutorial, it doesn’t mention bgziped fasta as a option. I’m guessing those are supported though, right? So I should be good if I supply .gz, .gz.fai and .gz.gzi files, ya?
Garrett Stevens
@garrettjstevens
Should work, and you can use faiUrlTemplate and gziUrlTemplate if it doesn't pick them up automatically from the urlTemplate
Scott Cain
@scottcain
👍
Domenico Simone
@domenico-simone

Hello,

I am using maker2jbrowse with this GFF:

https://github.com/domenico-simone/jbrowse_mini_test/blob/test/input_data_201021/all.batches.wseqs.annotation.test.2.clean.gff

This is an excerpt of the settings I'm using in the script:

my %commands = (

    #MAKER anotations
    gene            => [ '--key' => "Gene spans",
                         '--className' =>  'feature',
                         '--type' => 'gene:maker',
                         '--noSubfeatures'
                       ],
    maker           => [ '--key' => "Transcripts",
                         '--className' => 'transcript',
                         '--subfeatureClasses' => '{"exon": "exon", "CDS": "CDS", "five_prime_UTR": "five_prime_UTR", "three_prime_UTR": "three_prime_UTR"}',
                         '--type'  => 'mRNA:maker',
                         '--nameAttributes' => 'name,alias,id,note,dbxref,ontology_term'
                       ],

The building process works fine, but when I open the genome browser the "Gene spans" track is not loaded (see attached figure)

am I missing anything from the configuration?

Thank you,

Domenico

image.png
Colin Diesh
@cmdcolin
@domenico-simone I found this error too recently GMOD/jbrowse#1548
I think I know what it could be...will have to check into it
Domenico Simone
@domenico-simone
Thank you @cmdcolin, I'm following the thread on github
Colin Diesh
@cmdcolin
added a small pr...
for the maker2jbrowse thing
Domenico Simone
@domenico-simone
Hi @cmdcolin thank you! this is what I get now:
image.png
which is already something :) although not exactly what I was expecting! :)
Colin Diesh
@cmdcolin
ah right. i guess technically the gene spans maybe used to be just a single box covering the gene region but maybe it automatically loads individual transcripts now
Scott Cain
@scottcain
Colin Diesh
@cmdcolin
ur gonna wanna set
storeClass: JBrowse/Store/SeqFeature/BgzipIndexedFasta
Scott Cain
@scottcain
👍
I figured the adapter would just “figure it out” :-)
Domenico Simone
@domenico-simone

ah right. i guess technically the gene spans maybe used to be just a single box covering the gene region but maybe it automatically loads individual transcripts now

@cmdcolin I think you're right. So far, in my case showing only the transcripts is ok. However, if this could be fixed it would be great :)

Scott Cain
@scottcain
@cmdcolin covid19.jbrowse.org is down. Can you please give it a swift kick? Thanks
Colin Diesh
@cmdcolin
@scottcain i rebooted it awhile ago and it did not come back up
is there an issue with it?
Scott Cain
@scottcain
:shrug: I don’t know anything about how it’s set up, but I don't think anything has changed recently.
Colin Diesh
@cmdcolin
i hit the reboot on it
confirmed that the ip in aws console == ping covid19.jbrowse.org ip
Ian Holmes
@ihh
is there a reason it needs to be an EC2 node and not just a static site?
Scott Cain
@scottcain
Nope. I’m not sure when that decision was made. I had a docker container so somebody (perhaps @nathandunn ) decided to just run an EC2 with the docker running on it. I can set up a static site fairly easily.
Colin Diesh
@cmdcolin
prolly upload the data to s3
i dunno whats goin on with that instance though
it says it is running now
but no ping
no http access
Scott Cain
@scottcain
That’s the (not really) funny thing: all the data are either on S3 already or being served from somewhere else (UCSC).
…although I do need to update the data, and I didn’t really want to do that today, but I also don’t want to do a half-assed job setting up a static site but not updating the data.
Scott Cain
@scottcain
Also, it turns out I have ssh access to the covid19 machine, so I’ll try to fix it.
…and it’s back. Yay, I don’t actually have to fix anything today.
git-u0
@git-u0
hello, not related to gbrowse
could anyone give an alternate to CMap (http://gmod.org/wiki/CMap#Documentation)
Scott Cain
@scottcain
There are not many good alternatives. The closest thing I know of is Tripal MapViewer (example https://www.cottongen.org/tools/mapviewer). While it is a good tool, the problem is that it requires that you also have tripal, which is a whole thing. I also heard a rumor a few years ago about somebody working on a JavaScript implementation of CMap but I don’t know if it ever saw the light of day. I’ll look around tomorrow morning when I’m at my desk.