Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Jan 31 2019 22:37

    bebatut on gh-pages

    Update on: Thu Jan 31 22:36:58 … (compare)

  • Jan 31 2019 22:00

    erasche on master

    Reports fix. Clear up issue in Galaxy docker… More reports fixes... and 1 more (compare)

  • Jan 31 2019 22:00
    erasche closed #1237
  • Jan 31 2019 22:00
    erasche commented #1237
  • Jan 31 2019 21:33
    jmchilton synchronize #1237
  • Jan 31 2019 21:01
    erasche labeled #1239
  • Jan 31 2019 21:01
    erasche opened #1239
  • Jan 31 2019 21:00
    natefoo opened #1238
  • Jan 31 2019 20:56
    jmchilton opened #1237
  • Jan 31 2019 20:17

    bebatut on gh-pages

    Update on: Thu Jan 31 20:17:17 … (compare)

  • Jan 31 2019 19:44

    erasche on master

    fix typos Merge pull request #1236 from g… (compare)

  • Jan 31 2019 19:44
    erasche closed #1236
  • Jan 31 2019 19:44
    martenson opened #1236
  • Jan 31 2019 19:44

    martenson on martenson-patch-2

    fix typos (compare)

  • Jan 31 2019 19:23

    bebatut on gh-pages

    Update on: Thu Jan 31 19:23:39 … (compare)

  • Jan 31 2019 19:06

    Slugger70 on master

    import some notes fix username and 1 more (compare)

  • Jan 31 2019 19:06
    Slugger70 closed #1234
  • Jan 31 2019 19:04
    erasche review_requested #1234
  • Jan 31 2019 19:03
    erasche synchronize #1234
  • Jan 31 2019 19:03
    erasche unlabeled #1234
pvanheus
@pvanheus
when trying to make serve-gitpod
oh, seems to have been caused by a typo...
Ollie White
@Ollie_W_White_twitter
Hi all, I have quite a specific question regarding using Novoplasty to assemble chloroplast genomes. I can get the program to run successfully with the example data provided here https://github.com/ndierckx/NOVOPlasty/tree/master/Test%20datasets/Chloroplast%20assembly but it looks like some of the output is missing in galaxy. Specifically, when I run it using the command line application, I get two files called 'Option_1_test_chloro.fasta' and 'Option_2_test_chloro.fasta', which are the two alternate assemblies with differing orientation of one of the contigs. When running the job I have made sure to include all output file options. I have made a workflow accessible here https://usegalaxy.eu/u/ollie_white/w/testing-chloroplast-assembly-novoplasty if anyone is interested. I am relatively new to Galaxy so apologies if I have missed something straightforward. Cheers, Ollie
1 reply
Midsummer723
@Midsummer723
HI , when I use the RStudio on Galaxy at https://usegalaxy.eu/?tool_id=interactive_tool_rstudio . I try to install the Seurat package, because I will use some more modified function. But I failed to install the "Seurat". (ERROR: dependencies ‘leiden’, ‘png’, ‘reticulate’ are not available for package ‘Seurat’). The package 'png' cannot be installed.
Faezeh Ghazvini
@f_ghazvini_twitter
Hi,
I am currently trying to use featurecounts and for some samples assigned percent are less than 50. can I use the samples which assigned percent are less than 50?
1 reply
Afif Pranaya Jati
@afifpj_twitter
Hello, I am currently practicing Reference-based RNA seq data analysis https://training.galaxyproject.org/training-material/topics/transcriptomics/tutorials/ref-based/tutorial.html#visualization-of-the-expression-of-the-differentially-expressed-genes, but I could not find Read Distribution tool on the tools panel, what should I do?
3 replies
akankshabafna
@akankshabafna
@bgruening @gmauro:matrix.org @beatrizserrano My jobs have stopped due to lack of disk space. I have filled the quota request form and also emailed the same but have not received any reply. Please can you help.
Björn Grüning
@bgruening
@akankshabafna it does not help if you ask the same question in 3 channels :(
akankshabafna
@akankshabafna
@bgruening .. Apologies for the same, I was not sure which channel to post.
Ollie White
@Ollie_W_White_twitter
image.png
2 replies

Hi all, I am trying to import data into an interactive Rstudio session using gx_get(). I can open Rstudio no problem but I seem to be having an issue with the gx_get command. Below is the command

> gx_get(350)
sh: 1: /usr/local/bin/get: not found
[1] "/import/350"
Warning message:
In system(command) : error in running command

Also attached is a screen grab of the file I am trying to read into R

Should also have mentioned, I am using https://usegalaxy.eu/
Björn Grüning
@bgruening
@akankshabafna we are working on that
sorry
Helena Rasche
@hexylena:matrix.org
[m]
It's a known bug, we're working on fixing it
Helena Rasche
@hexylena:matrix.org
[m]
We will!
Anton Nekrutenko
@nekrut
@hexylena:matrix.org can I have some guidance here:
image.png
I'm not sure where to add these tags
Anton Nekrutenko
@nekrut
Ahh ... looks like workflow annotation issues. Updated. Will see what hapend
Helena Rasche
@hexylena:matrix.org
[m]
Glad you found it @nekrut , the comments also show up directly in the "files changed" interface but they're easy to miss, I wish there was a way to have our bot post proper "review comments" with suggestions, since we have the line numbers where things need to be changed.
I'll try and have a look at it today
Anton Nekrutenko
@nekrut
yes, all good @hexylena:matrix.org , thanks!
Ollie White
@Ollie_W_White_twitter
Hi all, does anyone have any recommendations for software to create and edit videos? I want to create a video to share how galaxy works with colleagues. Cheers
1 reply
Dannon
@dannon
I liked using https://obsproject.com/ for recording and https://www.openshot.org/ for editing. Both free and cross platform. A little bit of setup to get started, but they work really well.
Ollie White
@Ollie_W_White_twitter
Thanks @dannon I will check them out!
Dave B.
@davebx
I use avidemux for editing, but openshot looks a lot easier to use
wm75 (Wolfgang Maier)
@wm75:matrix.org
[m]
Just noticed that building the GTN site is not only slow, but also requires a lot of memory. Since the jekyll build seems to do its entire job in memory before finally writing to _site it took a whopping 1.6 GB before completing. Is there no other way with jekyll or am I just not aware of a build flag or something?
1 reply
Helena Rasche
@hexylena:matrix.org
[m]
are you building with citations? that is the slowest part

I use a command line

jekyll serve --port 4002 --trace --config _config.yml,_config-dev.yml --incremental --destination ./_site/training-material/ --skip-initial-build --livereload -H 0.0.0.0

which has several speedups:

  • config-dev prevents the slow citations
  • incremental only rebuilds changed pages
  • skip-initial-build starts serving immediately, and only builds once things change.
Some of this is in make serve-quick wm75 (Wolfgang Maier)
  1. Part of the problem is duplicated citations, I suspect. We have 900 citations, like 380 of these are unique (by citation key at least). We're looking at options to cut these down significantly, the original thought was making it easy to keep references associated with tutorials, but, we may switch to one big reference file.
  2. The citation module we use doesn't cache, and that doesn't help either.
Helena Rasche
@hexylena:matrix.org
[m]
the one person who improved the citation plugin (by using the jekyll cache) doesn't have an open PR, and I can't even find their fork. So, that's where we are on improving citations. The real solution is just compile without citations and your life will be better :)
Helena Rasche
@hexylena:matrix.org
[m]
and if you're that memory constrained, we can recommend building on gitpod which PvH has been using successfully when you're ready to see how your fork renders.
wm75 (Wolfgang Maier)
@wm75:matrix.org
[m]
Thanks Helena Rasche ! Yes, the spike in memory consumption happens only with a full build.
make build FLAGS="--config _config.yml,_config-dev.yml" is rather fast and memory-friendly.
I didn't know about --skip-initial-build before - really useful! With _site built already make serve FLAGS="--incremental --skip-initial-build" is a superfast way to get the server up and running.
Cameron Hyde
@neoformit
Hi all, I'm just beginning the journey on Interactive Tool development. Since there are no docs on this yet (aside from server administration) I thought I'd start working on a page for the dev track - if I chip away at it I should have something useful in a few months. Any thoughts on this? Is this on anyone else's radar? Just want to make sure we're not crossing swords before I put too much time into it.
4 replies
bgruening
@bgruening:matrix.org
[m]
@neoformit that's sounds great. I'm not aware of anything in that direction.
ping @yvanlebras do you know?
Ollie White
@Ollie_W_White_twitter
Hi all! Sometimes when I run a workflow I get a random error for one of the intermediate steps and it stops the rest of the workflow from running. Is it possible to resubmit the intermediate step that produced an error and allow the rest of the workflow to finish? At the moment I just delete all the files produced by workflow start again. I thought there might be a better way than this!
Dave B.
@davebx
yes, it should give you the option, when you select rerun, to replace the original job in the workflow and try again
Ollie White
@Ollie_W_White_twitter
@davebx thanks for letting me know, I have selected a job to re-run but I can't see the option to replace the job in the original workflow? Could you tell me where you look?
Simon Bray
@simonbray:matrix.org
[m]
@Ollie_W_White_twitter: when you rerun the tool, you should see an option like this above the Execute button
just make sure to select Yes
Ollie White
@Ollie_W_White_twitter
@simonbray:matrix.org this is perfect, thanks for sharing. I assume this icon will only appear if an intermediate job fails? Ironically all my jobs are running perfectly now, and I assume this is why I can't see this?
Simon Bray
@simonbray:matrix.org
[m]
yes, this option only appears either on failed jobs which are part of workflows, or which form part of a collection
Ollie White
@Ollie_W_White_twitter
@simonbray:matrix.org I'm looking forward to a job failing now... Thanks for the tip
Simon Bray
@simonbray:matrix.org
[m]
You're welcome!
Simon Bray
@simonbray:matrix.org
[m]
:point_up: Edit: yes, this option only appears on failed jobs which either are part of workflows, or which form part of a collection
Setareh
@Setareh24116772_twitter
hello everyone, I am pretty new to Galaxy and do not have enough bioinformatic information :D I want to add a history, but the + buttom is not there and when i go to gear buttom there is no option as create new :| dose anyone have a clue? Thank you in advance
2 replies