Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
Glavin Wiechert
@Glavin001
Any luck?
Alex Wait
@bobber205
lmao
formatting fine with no errors
Glavin Wiechert
@Glavin001
Okay, what does it think is beautify_p
oh
hahahahaha
Alex Wait
@bobber205
looks like restarting atom didn't properly reload the module!
Glavin Wiechert
@Glavin001
Now THAT’s weird
Alex Wait
@bobber205
lmao
Glavin Wiechert
@Glavin001
Great to hear!
Alex Wait
@bobber205
yeah
nice plugins btw
super excited to use it
haven't found a good ruby formatter for atom till now
Glavin Wiechert
@Glavin001
Could you post in your GitHub issue that it’s all working and false alarm. Let me know if you have any further problems
Alex Wait
@bobber205
sure thing!
Glavin Wiechert
@Glavin001
Thanks!!
Glad you like it. Let me know if there’s anything missing / any more problems :)
I try to keep it up-to-date whenever I am not in school / working.
Speaking of which, I am at my office now so I best get back to work :P.
Alex Wait
@bobber205
thinking about filing a bug in atom land
same here!
ttyl
Glavin Wiechert
@Glavin001
Later! Enjoy :)
Thomas Carlsen
@tcarlsen
Hey @glavin any chance you had a look at the issue yet?
Marco Musella
@dev-mush
guys can somebody tell me why if I select all my script and run atom beautify, my script code gets (almost) duplicated three times ?
Glavin Wiechert
@Glavin001
That's a bug @dev-mush could you create an issue and give me some more details to work with? Thanks!
@tcarlsen I haven't had a chance yet, sorry. Work has piled up. Our interns are back to school now and so I have lots of Issues to implement all on my own :P. Hmm I can see if I can do it today. This issue tcarlsen/atom-message-panel#35 ?
Thomas Carlsen
@tcarlsen
Yeah but don't overdo you self
Glavin Wiechert
@Glavin001
Can’t help that :P
How does my sample code look (on issue post)? Do you think it makes sense / is a good way of implementing it?
Thomas Carlsen
@tcarlsen
In that case please look on some of my other issues :)
Glavin Wiechert
@Glavin001
?
Breakfast time, Gotta go!
Ernie Brodeur
@erniebrodeur
wow, this is a neat app.
hey Glavin, I just updated ruby-beautify pretty significantly. I commented on #25, but wasn't sure if you'd see it (it stayed closed).
Ernie Brodeur
@erniebrodeur
@Glavin001 I just made a new issue, thought I’d say hello.
Armen Darabyan
@armendarabyan
Hi guys
Kris Williams
@kriswill
I was wondering if there are any tools that do javascript semicolon OCD -> ASI formatting.
most of the time I can just search replace ";" -> ""
Glavin Wiechert
@Glavin001
Hey everyone! Happy holidays! I am trying to clean up a bunch of issues before my holidays are over. Let me know if there's anything else I can do. Thanks!
Dexter Miguel
@divmgl
hey, i'd like to design my own grammar for atom-beautify, specifically jade. does anyone have anywhere i can go to see documentation regarding this?
Glavin Wiechert
@Glavin001
At the current time I'm not sure. However I have been researching into Jison and grammars and am also very interested in building a generic framework for designing grammars used for beautification. No progress on my end yet but let me know what you find out and Id love to work with you to find a solution.
Sergey Prokhorov
@proxyfabio
I've got strange error during update to a newer version. Are there any possible methods to fix it?
Jason Scott
@js1972
Wish I could use this app as I'm used to the equivalent in sublime text... But for the life of me I cannot install it. Its the same problem as described in issue #174. It fails on "git clone git://github.com/ariya/esprima.git";. I thought it was our stupid corporate proxy but I have tried it connected to the internet via my phones 3G connection (so no chance of a corp proxy getting in the way) and it STILL doesn't work. Just impossible to install.
Glavin Wiechert
@Glavin001
That's strange. I don't know why it's happening and all of the research points to firewall/proxy issue and I cannot reproduce.
Jason Scott
@js1972
The issue also only occurs on my windows 7 work pc. It installs just fine on a mac for me.
I hate windows and I hate corporate proxies