Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    michael4096
    @michael4096
    hi
    I'm trying to install goclipse and following the standard rules. All goes smoothly until eclipse tries to install some goclipse package and I get...
    An error occurred during the org.eclipse.equinox.internal.p2.engine.phases.CheckTrust phase.
    session context was:(profile=C__Users_micha_eclipse_cpp-neon2_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.CheckTrust, operand=, action=).
    Error reading signed content.
    Exception in opening zip file: C:\Users\micha.p2\pool\plugins\com.googlecode.goclipse.core_0.16.1.v201607061938.jar
    michael4096
    @michael4096
    Environment...
    W10pro, brand new neon cpp
    michael4096
    @michael4096
    hi guys, I'm new on here so I don't know if I've broken some taboo - if so, I sincerely apologise - or if this simply confuses everybody. I've set this up before so I know it did work and I'd really appreciate it someone would tell me why it won't work this time
    Bruno Medeiros
    @bruno-medeiros
    Did you get a dialog asking whether to trust the Goclipse certificate?
    michael4096
    @michael4096
    hi Bruno, thanks for responding. No, no dialog. I've reinstalled neon and tried again but get the same. Should this dialog be produced by eclipse or W10?
    michael4096
    @michael4096
    Curiouser and curiouser. I downloaded and installed a new java neon and received same error in different place... C:\Users\micha.p2\pool\plugins\com.fasterxml.jackson.core.jackson-annotations_2.5.0.v201504151636.jar
    Bruno Medeiros
    @bruno-medeiros
    Hum, try again with a fresh java Neon and use the HTTPS update site URL: https://goclipse.github.io/releases/ , see if that makes any difference
    If not, open a bug report in Github, post the contents of the Eclipse log. But I don't have any more ideas about what might be the problem
    michael4096
    @michael4096
    thanks, Bruno - I tried again both cpp and java, it gave the standard version mismatch message because some plugin file versions were older than the latest neon but both options fail (upgrade old versions and downgrade new versions)
    I'll try an older version of eclipse before opening bug report
    michael4096
    @michael4096
    Well, well. cpp oxygen gives me the "do you trust Bruno..." dialog and then installs fine
    do you still need a bug report?
    Bruno Medeiros
    @bruno-medeiros
    nah, not unless it becomes a problem again, and you have more details to reproduce it.
    michael4096
    @michael4096
    Fully reproducable on neon, oxygen works fine. I guess it will go away :-)
    antman1p
    @antman1p
    Any idea why I can't add a breakpoint in GoClipse. I can on my work computer, but not on my home computer. Both in the Go Perspective.
    ChrisNabold
    @ChrisNabold
    I installed Goclipse 0.16.1 in an empty Eclipse IDE for Java Developers (V4.6.2) - however I can not configure Go in Windows>Preferences>Go
    andr-mueller
    @andr-mueller

    Hi, when I run "go test" from goclipse I do get weird "ESC" characters in the console output from the test. Any idea, why this is happening and if there's a quick and easy solution to this?

    Example:

    Running: /usr/local/go/bin/go test -v -gcflags "-N -l" github.com/SomeProject/...
    === RUN SomeTest
    Running Suite: Some Test Suite
    Random Seed: 1523284666
    Will run 3 of 3 specs

    •••
    Ran 3 of 3 Specs in 0.000 seconds

    zcurtis21
    @zcurtis21
    When starting eclipse with goclipse plugin I receive the following error: "Could not start goclipse because the java version is: -1". I am using java jdk 10 and eclipse oxygen 4.7.3. Please advise.
    zcurtis21
    @zcurtis21
    @zcurtis21 Ended up also installing the 1.8 jdk and updating the eclipse.ini to reference 1.8, which made the error go away. Not ideal, but I don't need the latest java version right now. Is this project even being maintained any more?
    Azman Kudus
    @azman6r6m1
    hi, i got installation error from update site.
    No repository found containing: osgi.bundle,org.objectweb.asm,5.2.0.v20180228-1718
    any update site that i missed?
    Azman Kudus
    @azman6r6m1
    ok got it. add eclipse orion into the update sites.
    tryfon
    @tryfon
    Hi. Is GoClipse being developed anymore? If not, is there perhaps a fork that is being actively developed and recommended?
    Eric Chazan
    @echaz

    unfortunately no @tryfon http://pureconcepture.blogspot.com/2017/07/goodbye-to-eclipse-end-of-era-for.html

    I'm not actively developing on Go atm, so I dnot know the status of any of the forks.

    dsilva36
    @dsilva36
    When I open Eclipse, it opens the dialog box, saying that it could not start Goclipse because the Java version is: 0 version 8 is needed, can anyone tell me why and how to solve it?
    dsilva36
    @dsilva36
    Opens the dialog with the following message: could not start Goclipse because Java version is: 0 version 8 is required, can anyone help me solve?
    Sean Hankins
    @scarabdesign

    Opens the dialog with the following message: could not start Goclipse because Java version is: 0 version 8 is required, can anyone help me solve?

    I finally found something on this. I was able to resolve it by deleting the jvmcheck file. Here is the link to the ticket.
    GoClipse/goclipse#256
    Your file name may be slightly different. I did a search for "jvmcheck" and deleted the one file that showed up.
    It's too bad this plugin was abandoned. I wish someone would take up the mantle; it seems like a popular plugin.