These are chat archives for IndySockets/Indy

20th
Dec 2017
Renanbg
@Renanbg
Dec 20 2017 10:32
@rlebeau thanks for your repply. No other problem.
hrdware
@hrdware
Dec 20 2017 15:22
Greetings. I am using Delphi 2007 with Indy 10.0.0.17. I need to do a SHA256 hash and have seen some articles that say this can be done with the indy components however it seems I need to upgrade in order to get the TIdHashSHA256 library. Where can I get the latest stable version that would include this? Thanks much.
hrdware
@hrdware
Dec 20 2017 15:54
The only thing I have been able to find on www.indyproject.org is version 10.0.52 which says is an old version and no longer recommended.
Kudzu
@czhower
Dec 20 2017 15:56
It does nto say that. Please read the text more carefully. Use the dev snapshot
hrdware
@hrdware
Dec 20 2017 15:58
I will look at the dev shapshot, but right under the link for dev snapshot it says, "Alternatively you can download the Source Code for Version 10.0.52. This is however a rather old version and is no longer recommended."
Kudzu
@czhower
Dec 20 2017 16:00
Read ABOVE that and note the word "alternatively"
hrdware
@hrdware
Dec 20 2017 18:37
@rlebeau So just to be clear, I can download the indy10_5438.zip file and extract the indy110. files and install those dpk files (after uninstalling the previous version) and then I should be all set. Correct?
Remy Lebeau
@rlebeau
Dec 20 2017 19:28
@hrdware in theory, yes, provided you don't have any other components installed that depend on the version of Indy that shipped with the IDE.