Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Dec 06 18:14
    rlebeau commented #183
  • Dec 06 18:00
    JPeterMugaas commented #183
  • Dec 06 17:42
    rlebeau commented #183
  • Dec 06 17:42
    rlebeau commented #183
  • Dec 06 17:41

    rlebeau on OpenSSL-1.1.x

    (compare)

  • Dec 06 17:18
    rlebeau commented #270
  • Dec 06 17:17
    jgv-Flexsys commented #183
  • Dec 06 17:10
    rlebeau commented #183
  • Dec 05 15:04
    Fulgan commented #270
  • Dec 05 13:25
    winkelsdorf commented #183
  • Dec 05 13:23
    winkelsdorf commented #183
  • Dec 03 22:30

    rlebeau on master

    Correctly define timezone funct… Merge pull request #272 from Bi… (compare)

  • Dec 03 22:30
    rlebeau closed #272
  • Dec 03 21:15

    rlebeau on master

    Fixing compiler errors in TIdIP… (compare)

  • Dec 03 20:50
    Bi0T1N opened #272
  • Dec 03 01:33

    rlebeau on master

    Fix for missing declaration of … Fix for compiler error in Local… Merge branch 'master' of https:… and 2 more (compare)

  • Dec 02 20:27

    rlebeau on master

    Update IdGlobal.pas Fix for co… (compare)

  • Dec 01 20:17

    rlebeau on master

    Update IdGlobal.pas Fix for mi… (compare)

  • Dec 01 10:46
    geoffsmith82 commented #192
  • Nov 30 16:54

    rlebeau on master

    Update IdGlobal.pas Fix for co… (compare)

Remy Lebeau
@rlebeau
are there any decent forum softwares worth migrating to that can import forum data from phpBB?
Ludwig Behm
@lbehm
did you use any additional plugins? any special modifications?
where do you want to go? .net? same host?
davidpn
@davidpn
thanks Remy
Remy Lebeau
@rlebeau
@czhower can you redirect forums2.atozed.com to a temp site that tells users why the site is down? or get PHP running and put it in read-only mode? Or something, so the users know that the site is intentionally down and not actually dead.
Remy Lebeau
@rlebeau
@czhower since you want to switch to a different forum solution, maybe we can do something like this to archive the current forum first: https://ibboard.co.uk/Programming/how-to-archive-phpbb.html
Kudzu
@czhower
yes... Remy my big issue now is time... Im still not fully functional after the surgery and Ive got such a huge backlog... Could you help with it?
Remy Lebeau
@rlebeau
@czhower I can't, because the php forum is down, and I don't have access to the server anyway.
Matthijs ter Woord
@mterwoord
@rlebeau Thats something we can probably fix (need to discuss with chad though)
@rlebeau so, assuming access is provided to you (in whatever form needed), you could help with moving?
Remy Lebeau
@rlebeau
@mterwoord I'm not sure I would be comfortable messing around with the server, I was just tossing out ideas. Do you even know what new forum software you want to migrate to? Maybe the existing PHPBB content can actually be moved into the new system, instead of just archiving a static backup copy of it.
Matthijs ter Woord
@mterwoord
@czhower has to answer that one....
Kudzu
@czhower
sorry Remy for late reply. was in hospital. catching up now... there are some .net based phpbb types and some can import from phpbb.. maybe look at those?
Kudzu
@czhower
and if you can narrow it down to a short list we can pick one
Remy Lebeau
@rlebeau
ok
davidpn
@davidpn
wishing you a speedy recovery, @czhower
Kudzu
@czhower
thanks
Nick Hodges
@NickHodges_twitter
Hey.
I have an Indy question if I may.
If you set the SSL version to SSLv12, will it automatically allow for downgrades to 1.1 and 1.0?
Or do you have to include those values in the set if you want them included?
Nick Hodges
@NickHodges_twitter
The reason I ask is that I'm seeing some strange behavior with regard to the SSLOptions.Methods property.
Remy Lebeau
@rlebeau
Hi Nick. There is no SSLv12, I assume you mean sslvTLS1_2. instead. No, enabling TLS 1.1 by itself will not perform a downgrade, you need to enable the other versions in the Set.
Use SSLOptions.SSLVersions to enable desired versions, the SSLOptions.Method will be updated accordingly (and vice versa). When multiple versions are enabled, the ssl23 method is used so version negotiation can be performed with the peer dynamically.
Remy Lebeau
@rlebeau
what kind of behavior are you seeing?
Nick Hodges
@NickHodges_twitter
I'm seeing our server only accetp V1.0 connections. I use fiddler, and if I tell fiddler to only send v1.1 and v1.2 connections, the server (Indy-based) obviously, will reject it, despite all three types put in the Methods property as a set. The server accepts teh connection if I add v1.0 to Fiddler.
Thanks for your assistance, BTW. Very much appreciated.
Nick Hodges
@NickHodges_twitter
Never mind. I figured out that I was loading an old version of ssleay32.dll that apparently didn't support 1.1 and 1.2.
Remy Lebeau
@rlebeau
Ok then
Wil32
@Wil32
has anyone figure out how to make the new requirement 'ipv6' work from apple(ios)
Remy Lebeau
@rlebeau
Indy has supported IPv6 for several years now. It defaults to IPv4 (there are IdIPv4 and IdIPv6 defines in IdCompilerDefines.inc to specify the default), but most Indy components have an IPVersion property that you can set to Id_IPv6 at runtime if needed, and then you can use IPv6 addresses and IPv6 hostname lookups as needed. In Delphi 10.1 Berlin, Embarcadero even compiled the bundled version of Indy to default to IPv6 on iOS.
phy0292
@phy0292
谁能看懂中文?
phy0292
@phy0292
我有一个重要的BUG要报告,在indy10和之前的版本一直存在。在IdZLib.pas中的CompressStream里,如果我们以大于1比如9的压缩level来调用IdCompressorZLibEx1->DeflateStream(in_ms,out_ms,9);那么CompressStream函数发生buffer error的概率30%,你可以试试以这样的方式依次来压缩某个文件中每个文件,压缩结果可以舍弃不要,你会发现在压缩某些文件或内容时报buffer error的错误。而以默认的IdCompressorZLibEx1->DeflateStream(in_ms,out_ms);来调用这个函数不会出错,但是实际上他是不压缩数据,结果基本上都是变大。如果把 if strm.avail_in = 0 then break; 这一行改成if (strm.avail_in = 0) and (strm.avail_out > 0) then break; 那么BUG消除。。。
Matthijs ter Woord
@mterwoord
@phy0292 You may have better luck trying in english...
davidpn
@davidpn
He says there's a bug in IdZLib.pas
Matthijs ter Woord
@mterwoord
what kind of bug?
davidpn
@davidpn
He didn't say exactly where, but going by the example it looks like it's in IndyCompressStream, going by what he says the fix is
hard to work out exactly what the bug is
Dodgy Google Translate translation:
I have an important BUG to report, and the previous version in indy10 persist. In IdZLib.pas in CompressStream, if we is greater than 1, such as compression level 9 to call IdCompressorZLibEx1-> DeflateStream (in_ms, out_ms, 9); then CompressStream function generating buffer error probability of 30%, so you can try to way turn to compress each file in a file compression results do not give up, you will find some files in the compressed contents Times buffer error or mistake. The default of IdCompressorZLibEx1-> DeflateStream (in_ms, out_ms); call this function without error, but in fact he is not compressed data, the results are basically large. If if strm.avail_in = 0 then break; into this line if (strm.avail_in = 0) and (strm.avail_out> 0) then break; then eliminate BUG
His first question was whether anyone understands Chinese ;-)
Matthijs ter Woord
@mterwoord
:)
davidpn
@davidpn
Oops.. my bad.. there is a line of code like that in DoCompressStreamEx
Matthijs ter Woord
@mterwoord
@davidpn I'd say we wait for him to translate to english?
davidpn
@davidpn
as well
@phy0292 你可以提供一个更好的例子吗?
I asked for a better example
Matthijs ter Woord
@mterwoord
you know english?
shoot, chinese?
davidpn
@davidpn
lol