Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jul 02 12:40
    phillip-haydon opened #2286
  • Jul 02 12:40
    phillip-haydon opened #2286
  • Jul 01 19:55
    jeremydmiller closed #733
  • Jul 01 19:55

    jeremydmiller on master

    Fix casing of .NET in docs (compare)

  • Jul 01 19:42

    jeremydmiller on master

    little fix for rabbit mq ping p… (compare)

  • Jul 01 18:48
    jeremydmiller closed #2258
  • Jul 01 18:48
    jeremydmiller closed #2258
  • Jul 01 18:48
    jeremydmiller commented #2258
  • Jul 01 18:48
    jeremydmiller commented #2258
  • Jul 01 18:48
    jeremydmiller closed #2284
  • Jul 01 18:48
    jeremydmiller closed #2284
  • Jul 01 18:48

    jeremydmiller on master

    re-enables test for getting inc… unnests id collection in subque… updates locator for flattened e… (compare)

  • Jul 01 18:48

    jeremydmiller on master

    re-enables test for getting inc… unnests id collection in subque… updates locator for flattened e… (compare)

  • Jul 01 18:47
    jeremydmiller closed #2274
  • Jul 01 18:47
    jeremydmiller closed #2274
  • Jul 01 18:47
    jeremydmiller closed #2281
  • Jul 01 18:47
    jeremydmiller closed #2281
  • Jul 01 18:47
    jeremydmiller closed #2282
  • Jul 01 18:47
    jeremydmiller closed #2282
  • Jul 01 18:47

    jeremydmiller on master

    better exception message when u… Excluse parent type from sub cl… Disregarding event streams with… and 2 more (compare)

Oskar Dudycz
@oskardudycz
Although I really don't think comfortable with not following strictly semantic versioning...
It’s even more confusing for the users more than it is for us...
We could, in theory, go with 4.0 just to be prim and proper
but then it won’t be good from the marketing perspective
As we already officially started a discussion on the plans for the v4
Babu Annamalai
@mysticmind
Note that there is already an issue raised by a user who attempted upgrading to Npgsql 4.1.0. JasperFx/marten#1359
Oskar Dudycz
@oskardudycz
Yeah, but it’s from v3
I think that we need to do a better job of being more proactive in the version checking (eg. as @baronfel did for us). I was thinking about some nightly build with the latest prerelease of npgsql
Oskar Dudycz
@oskardudycz
I’ll probably also create issues with that for them, but imho we should try to be closer to them, as it’s our major reference package
Babu Annamalai
@mysticmind
I think the user has incorrectly put details as v3
However close we work with Npgsql versions, any breaking changes will take time to resolve for us
Nightly build with pre-release versions of Npgsql would certainly help us to uncover issues sooner than later
Oskar Dudycz
@oskardudycz
Yes I agree, but if we work closely with them then we can discuss with them turnaround as @baronfel together with me did
In general, I’m trying to find some pragmatic approach
😉
Babu Annamalai
@mysticmind
We depend fully on Npgsql so it imperative for us to figure out a pragmatic approach :-)
Oskar Dudycz
@oskardudycz
Exactly - yelling at clouds won't help 😋
(unfortunately 😉)
Jeremy D. Miller
@jeremydmiller
I say to limit it to 4.0 to <4.1 for right now
Oskar Dudycz
@oskardudycz
Ok, I checked, Npgsql.Json.NET can't be removed
here's the PR
Oskar Dudycz
@oskardudycz
I discussed with @roji on https://gitter.im/npgsql/npgsql the plan for the upgrade. They're willing to revert the JSON.NET upgrade
So the plan would be for this time being we'll:
  • lock the version to <4.1
  • review other potential issues and send the feedback to npgsql team
  • wait for the fixes in 4.1.1
  • make the update
Shay Rojansky
@roji
I'm also OK with reverting anything else that doesn't mean a major conflict/break/rewrite
Oskar Dudycz
@oskardudycz
:+1:
I wasn't aware that you're also on our channel :)
Shay Rojansky
@roji
Neither was I :) I think it's because I just got mentioned?
Oskar Dudycz
@oskardudycz
might be, but that's cool - you're more than welcome here :)
Shay Rojansky
@roji
Jeremy D. Miller
@jeremydmiller
@roji Since you’re here, do y’all use any kind of automated tooling to check for SemVer violations in your API surface? The NServiceBus guys have something for that, but I’ve never used that. Or I’m guess that I’m asking, could you start doing that?
Shay Rojansky
@roji
Yeah, this release made me think about that more
In general things have been a bit too lax on that front
Jeremy D. Miller
@jeremydmiller
With Newtonsoft you might be able to get away with setting a pretty permissive version range. Newtonsoft is always a risk for diamond dependency issues
Shay Rojansky
@roji
We really don't plan for another minor release before 5 so I wouldn't say it's urgent. Also, this mess was a result of us not planning to have a 4.1 originally, and deciding to do one after breaking changes were already introduced
So there are some "justifications" for why this happened
Re Newtonsoft, I don't really have any specific dependency (or feelings) about a specific version. It's true that up to now we generally target the highest version to make sure we're compatible with that
Users can always override though if necessary
Jeremy D. Miller
@jeremydmiller
Dude, I’ve got plenty of sympathy here, but y’all are a foundational library
Shay Rojansky
@roji
Yeah, I dropped the ball on this, no excuses really.
Jeremy D. Miller
@jeremydmiller
Again, I’m sympathetic as a 15 year OSS author:)
Shay Rojansky
@roji
Thanks for saying that...
Oskar Dudycz
@oskardudycz
btw. there is a nice discussion on the "Maturity Ladder" that was mentioned on the channel. https://github.com/dotnet-foundation/project-maturity-model/issues/32#issuecomment-536282845 I've also put my few cents there.
Oskar Dudycz
@oskardudycz
3.8.1 version with locked Npgsql version released
Barry Hagan
@barryhagan
Was there a reason to set the range start back at npgsql 4.0.4? Seems a little odd because 3.8.0 used npgsql 4.0.9 and nuget restore will use the lowest in range by default. People are going to get npgsql 4.0.4 if they do a clean restore with 3.8.1 now.
Oskar Dudycz
@oskardudycz
Hm, I took the lowest possible, but that's valid point
Fred
@wastaz
Tbh isnt it in general better to choose lower versions if possible. That adds more leeway for getting a good combination of versions if many things depend on the same libs.
Also, the nuget clients "take the lowest possible"-default is imho a bad default and a good reason to switch to paket who does the opposite ;)
Oskar Dudycz
@oskardudycz
Ok, I can send 3.8.2, you’re right
@mysticmind thought?