Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jan 31 14:43
    MikaelEliasson opened #723
  • Jan 31 11:02
    JimBobSquarePants commented #664
  • Jan 31 10:59
    JimBobSquarePants commented #709
  • Jan 31 10:59

    JimBobSquarePants on autorotate

    (compare)

  • Jan 31 10:58
    JimBobSquarePants closed #709
  • Jan 31 10:58

    JimBobSquarePants on develop

    Clone autorotated image. Fix #7… Merge pull request #722 from Ji… (compare)

  • Jan 31 10:58
    JimBobSquarePants closed #722
  • Jan 31 10:45
    JimBobSquarePants labeled #722
  • Jan 31 10:45
    JimBobSquarePants opened #722
  • Jan 31 10:44

    JimBobSquarePants on autorotate

    Clone autorotated image. Fix #7… (compare)

  • Jan 31 10:20
    JimBobSquarePants commented #709
  • Jan 31 09:54

    JimBobSquarePants on postprocessor-png-fixes

    (compare)

  • Jan 31 09:52

    JimBobSquarePants on AmazonS3Cache

    (compare)

  • Jan 31 09:52

    JimBobSquarePants on develop

    Cleanup and add AmazonS3Cache t… Fix build script Merge branch 'develop' into Fea… and 3 more (compare)

  • Jan 31 09:52
    JimBobSquarePants closed #700
  • Jan 30 17:15
    AndyFelton commented #700
  • Jan 30 08:27
  • Jan 29 15:06
    alexsandr-sml starred JimBobSquarePants/ImageProcessor
  • Jan 29 11:28
    lars-erik commented on 1a8e712
James Jackson-South
@JimBobSquarePants
You’re probably missing the C++ Redistribution libraries listed here. https://imageprocessor.org/imageprocessor/plugins/webp/
Alok Sharma
@aloksharma1
i have that installed on server
vc++ 2012,13&15 are installed
even on my local project its not taking any effect
i am using .net framework 4.5.2
apart from height width & format (normal) other query params are also not working
like watermark etc
James Jackson-South
@JimBobSquarePants
Are the other query params enabled via the config files? If you haven’t installed already you need ImageProcessor.Web.Config
Also please download the project from GitHub and check the sample website. You will see working examples there
Alok Sharma
@aloksharma1
adding ImageProcessor.Web.Config made my project non-working
runtime errors
i will try the github sample and will let you know how it goes
James Jackson-South
@JimBobSquarePants
Please do. Maybe once you have an example to follow you will solve your issues.
Simon Yohannes
@yohsii_twitter
hi James. thinking of migrating a .net mvc 5 project (using imageprocessor.web) to .net core 3.0 and was wondering if there was any documentation on imagesharp.web? on how to do things like having images retrieved from azure blob storage and the querystring api (is the api the same as imageprocessor.web?) and such. thanks
Simon Yohannes
@yohsii_twitter
@JimBobSquarePants just including your handle so you get a notification (if that's how it works!)
James Jackson-South
@JimBobSquarePants
Super late here so using my phone to communicate. There’s a sample app for ImageSharp.Web in the repo which will show you available commands. Still working on docs.
Alok Sharma
@aloksharma1
i have fixed everything as per given sample project but on server there is still error of libwebp.dll
now i dont have any error on local system, so thats a progress
but server have all the same config. plus its a dedicated sytem
even restarted the server 2-3 times
Alok Sharma
@aloksharma1
ok created a fresh subdomain site with newly published app
same issue libwebp error
[TypeInitializationException: The type initializer for 'ImageProcessor.Plugins.WebP.Imaging.Formats.NativeMethods' threw an exception.]
ImageProcessor.Plugins.WebP.Imaging.Formats.NativeMethods.WebPFree(IntPtr pointer) +0
ImageProcessor.Plugins.WebP.Imaging.Formats.WebPFormat.EncodeLossly(Bitmap bitmap, Int32 quality, Byte[]& webpData) +268
ImageProcessor.Plugins.WebP.Imaging.Formats.WebPFormat.Save(Stream stream, Image image, Int64 bitDepth) +88
ImageProcessor.ImageFactory.Save(Stream stream) +69
ImageProcessor.Web.HttpModules.<ProcessImageAsync>d__31.MoveNext() +3576
System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task) +102
System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) +64
System.Web.TaskAsyncHelper.EndTask(IAsyncResult ar) +63
System.Web.AsyncEventExecutionStep.InvokeEndHandler(IAsyncResult ar) +156
System.Web.AsyncEventExecutionStep.OnAsyncEventCompletion(IAsyncResult ar) +123
does being on https be a problem for your library?
Alok Sharma
@aloksharma1
my application is set for full trust
Simon Yohannes
@yohsii_twitter
thanks James, i'll check out the repo
Alok Sharma
@aloksharma1
here is the thing now:
  • i checked read/write permissions
  • full trust
  • vc++ correct versions are installed
still this libwebp error?
o i need to replace this file where do i need to do this?
Alok Sharma
@aloksharma1
tomorrow i will try putting your testwebsite on server to see what happens
or if i am still missing something
its late now
maybe related to this imazen/resizer#191 ??
Alok Sharma
@aloksharma1
hi i have uploaded your test website on our server unfortunately same result :(
this is giving the libwebp error
i dont understand everything is working ok on local dev machine
vc++ versions are installed on both machines same
why is this happening on prod enviornment
the only diff. is server is win server 2012 while my dev machine is win 10
Alok Sharma
@aloksharma1
this only happens with webp
nevermind figured it out server iis was x86 version
had to install x86 vc++ and now its working
Alok Sharma
@aloksharma1
now the only thing i need is a fallback mechanism for webp
Alok Sharma
@aloksharma1
ok now i have got everthing sorted out
is there anyway to do this for web mvc?
even pointers are fine
then we will be able to use this in shared servers too
James Jackson-South
@JimBobSquarePants
Don’t do graphics programming in 32bit. You’re going to hit out of memory exceptions.