Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Shax
    @shaxxx
    This is my first touch with ElasticSearch and Kibana, but it looks like this is something that should be doable. However, if I try to create an Alert, I need to create a Monitor. If I want to create Monitor, I need to create indices. If I try to create Indices policy I get an error "[security_exception] no permissions for [indices:data/read/search] and User [name=...."
    1 reply
    Google points to various config files I have no idea about since I'm using cloud with "out of the box" security settings. Anyone?
    gayatriu
    @gayatriu
    Hi there, I am a new user of cloud.kaaiot.com,
    I created a fresh account and add raspberry pi as my first device.
    After that, I am trying a simple MQTT-based client for device connection as Kaa provides me with its documentation.
    Furthermore, I want to try this same client with COAP protocol, as a change, I replaced the MQTT client with HelperClient of COAP and change all publish and subscribe to request and response alternatively for COAP based client. But unfortunately, this code did not work at my place.
    So my query is only this change is sufficient for Kaa COAP based client or need anything else to change.
    3 replies
    Simzie
    @Simzie
    Hi! I'm also a new user and have an ESP32 running as both client and end point, with successful update and handling of command, provided the end point is regular communication with the KaaIoT broker. My device will be battery powered, so I need it to sleep for 30 minutes at a time (with the ULP performing actions), and I can't for the life of me get it to work asynchronously using PubSubClient. I have set the command retention to 1h, connected with cleanSession as false and subscribed and published with QoS 1. The command stays as "Pending" and the device never registers a callback. Would greatly appreciate any ideas or example code to help me here?
    2 replies
    waruta
    @waruta

    Hi all! I'm also trying out Kaa and have been running through the tutorials with a Raspbi 4 and some sensors and got stuck at the "sending data over MQTT" part. I do have a BMP280 sensor and when I try out the code it returns:

    [{"model": "BME/BMP 280", "fwVersion": "v0.0.1", "customer": "Andrew", "latitude": 40.71427, "longitude": -74.00597}]
    Traceback (most recent call last):
    File "/home/pi/client.py", line 109, in <module>
    main()
    File "/home/pi/client.py", line 84, in main
    payload = kaa_client.compose_data_sample()
    File "/home/pi/client.py", line 49, in compose_data_sample
    temperature, pressure, humidity = bme280.readBME280All()
    AttributeError: module 'bme280' has no attribute 'readBME280All'

    <-- Received message on topic "kp1/c149qeqrqa51q5h64ru0-sensors/epmx/8uNJ2gKVdL/update/keys/error":
    {"statusCode":400,"reasonPhrase":"Payload is not valid JSON object"}

    When running from the command line I get another error - "File "client.py", line 21
    self.metadata_update_topic = f'kp1/{APPLICATION_VERSION}/epmx/{ENDPOINT_TOKEN}/update/keys'
    SyntaxError: invalid syntax

    The sample file for those without the sensor works fine though.

    1 reply
    Peyman Yousefi
    @peyman.yousefi3_gitlab
    Hi all, I got an issue. in command widget, "commands definition" segment, when I set the dependency on "metadata" and "epr", sometimes it won't update correctly from EPR; other widgets have been updated correctly from the exact epr. Can anyone help me out, please?
    YuMChUM
    @YuMChUM
    Good Day, I've been struggling with a similar situation as @peyman.yousefi3_gitlab, epts telemetry data is updated immediately when devices connect but epr data (which I used to display Online/Offline Statuses, etc) can take some minutes or up to hours to update. Partial metadeta updates doesnt seem to budge the update either.
    1 reply
    AndrewPasika
    @AndrewPasika
    Hello! Sorry guys, we will check it up.
    6 replies
    Peyman Yousefi
    @peyman.yousefi3_gitlab
    Greetings, First of all, thank you for this great platform.
    in the chart widget, when the data points exceed a high amount of points (in my case 1500), the webpage froze and I have to exit it. I tested this with different PCs and different browsers. eventually, it will happen when the viewing time window is set to week or month. I guess the workaround is when the total points exceed your server's load threshold, it uses fewer points and shows the data with a less resolution. Could you please help me through this?
    2 replies
    Peyman Yousefi
    @peyman.yousefi3_gitlab
    Good day, my tenant has all admin privileges but in Kibana it says I have read-only access. How can I solve it guys?
    5 replies
    thelimas
    @thelimas
    I sucsessfully got my first device running. Really great plattform!!! but I am struggeling with the gps-coordinates. sending them to metadata is no problem,I can visualise them in the map. --but sending them to the epts I have problems with the map-widget,- yes I can send longitude and latitude and can see that the values have been recieved as auto-longitude and auto-lattude.-but I can not get them in the map-widget. If someone could help it was great. Thanks
    8 replies
    Denys Buzhor
    @geksilla
    image.png
    Anjana Anil
    @anjanaanil
    what is the querying URL for Tenant Manager ? https://docs.kaaiot.io/KAA/docs/current/Features/Multi-tenancy/TENANT-MANAGER/REST-API/#tenants_users__userid__get_response . I am facing an issue to get the user details.
    thelimas
    @thelimas
    User-management: when assigning a role in the usermanagement,- it works, for example read only.
    but following the usermanagment 7th tutorial I am strugle to limit a user to 1 endpoint, the user1 can not see the endpoint, or I have error 404:page not found. at the moment I have no ideas. thanks
    thelimas
    @thelimas
    Problem solved: it needs: user1: permission for application+user1:permisson for endpoint+user1: role read dash.
    YuMChUM
    @YuMChUM
    Good day Kaa People, I'm exploring the building management dashboard and excited for the new features in 1.3. But something that's always limited my Dashboard customizing has been the use of JSS Properties for widgets, Is there somewhere i can read up on all the available properties i can use?
    4 replies
    Anjana Anil
    @anjanaanil
    what is the querying URL for Tenant Manager ? https://docs.kaaiot.io/KAA/docs/current/Features/Multi-tenancy/TENANT-MANAGER/REST-API/#tenants_users__userid__get_response . I am facing an issue to get the user details.So what I am trying to do is after login through a custom dashboard. I don't want to ask the user about selecting the root / user account .
    Avoid redirecting to kaa login page
    3 replies
    ali samir
    @AliZidan39_twitter
    Hello, I want to know how to send commands from my app to KAA using MQTT protocol can anyone help me, please?
    Borel Kamnang
    @borel_kamnang_twitter
    Please I would like to know if there are possible confugurations on the KAA server so that it can respond automatically according to certain thresholds of defined value.
    For example, I have a sensor that sends the water level in a tank to the server and when the tank is full, the server must send a command to the pump to tell it to stop
    1 reply
    shilpa2299
    @shilpa2299
    Is there a way to delete an application?
    1 reply
    luisgarcia95
    @luisgarcia95
    How do I setup one value configuration widget with esp8266? I would like to use arrows to increment/decrement a parameter (i.e. speed). How do I do this and ensure the endpoint receives updated value from dashboard? Thanks!
    8 replies
    YuMChUM
    @YuMChUM
    Good Day Kaa community, I'd like to know if there's any way of duplicating a dashboard to a new Solution, or if possible export my dashboard created widgets and adding them to the Custom Widgets for later use?
    2 replies
    thelimas
    @thelimas
    Hallo community, I have created a dashbord "overview" with an endpointlist and a mapwidget, now I created in this solution a second dashboard "details" , that should show the details of a selected endpoint out of the overview-dashboard. but I find all the widgets out of "overview "in the "details" and if I delete a widget in details, it is also deleted in "overview". No idea what s going wrong. thanks for your help.
    1 reply
    Akhilesh Thorat
    @AkhileshThorat
    Hello,
    Is there any way to configure the JSON parser for incoming telemetry data,
    For Example: {"temp":344} should be converted to 34.4, so here I'm dividing the incoming value by 100
    YuMChUM
    @YuMChUM
    Good Day again Kaa. Is there by any chance a python version for the OTA code available?
    1 reply
    Valentin
    @vrivas83_twitter

    hello team,
    I am looking forward how to add and connect a device to kaa cloud.
    I need an IP and port then configure the protocol.
    but after create or adding a device I just receive a token
    where can I add a device using ip or dns and port?

    Best Regards

    1 reply
    kerosumi
    @kerosumi
    Hi ,I am totally new here. Just joined and played with some demo sensors. But after two days when I logged back I can not find my cloud."Client not found" under Kaaiot logo.Any idea what is going on?
    3 replies
    marek-szydlowski-wizzdev
    @marek-szydlowski-wizzdev
    Hi, I'm trying to create a connection between my device (ESP32) and KaaIoT cloud using two-way SSL/TLS communication but I am unable to generate TLS client certificate: After supplying CN and TTL I get "Internal Server Error". Any help would be appreciated.
    3 replies
    Niteesh Shanbog
    @nit1995

    Hey,

    I am new to Kaa and I have been sending some sensor data from Raspberry Pi through MQTT. How do I create an alert (based on the different sensor values) which gets displayed on the dashboard? Is there any tutorial for this?

    1 reply
    youssef
    @youssefsalahmohammed

    I am trying to send a sensor reads to the kaa IoT platform, but I am always getting the error message "Attempting MQTT connection to mqtt.cloud.kaaiot.com:8883 ... failed"

    Any ideas on how to solve this problem?

    1 reply
    Peyman Yousefi
    @peyman.yousefi3_gitlab
    Hi all, What does "public resource" do in the solutions segment?
    4 replies
    proyectonode
    @proyectonode
    Hi, im new at this.. can anyone help me.. how its send comand by node red ?
    1 reply
    Edward Maina
    @MainaEdd_twitter
    Hi Iam new here ...am trying to log in my first time always getting an error message: "Keycloack we are sorry page not found" what could be the issue?
    2 replies
    Ivan Razorenov
    @ivan.razorenov_gitlab
    Hello, new user here, exploring Kaa Cloud.
    Kibana in "Analytics" and "Alerts" tab does not load with "Missing Tenant" error for me - is this expected?
    There is also another question I had: it there any way to use data, collected in Kaa Cloud, outside of the platform? As far as I understand (and please correct me if I'm wrong), it is not possible to deploy custom microservices in the PaaS version, but maybe there is some possibility to export the data?
    2 replies
    Ali070
    @Ali070
    Kaa gives me an error message: "Unexpected error when authenticating with identity provider" what is the reason ?
    3 replies
    kingxcold
    @kingxcold
    Hi, i am facing a problem the cloud page is not working
    kingxcold
    @kingxcold
    kaaa.JPG
    1 reply
    kingxcold
    @kingxcold
    how can I send a normal HTTPS request to the cloud from my esp8266, some posts say that I need the SHA 1 certificate to be able to send the request?
    2 replies
    Kristiaan Verbeke
    @kverbeke
    Hi, I'm trying to control the date/time range of multiple time series widget graphs on a dashboard through one "Dashboard control" widget. The idea is that the user can zoom in/out on multiple graphs by adjusting the single dashboard control. The setup is twofold, I believe:
    • First, put the time range that is selected in the dashboard controls in a variable: In the widget, this is done in 'Controls', 'Write value by path'. It is suggested by the help text on that field: "You can assign variable in widget with ${dashboard.value}. For example ${dashboard.range.from}, ${dashboard.range.to}"
    • Secondly, specify on the time series that the selected range need to be applied to that time series: when taking the time series widget in edit, this is found under 'Data source', 'Time range' (select 'Specific') and then clicking on 'ABC', so it become '${x}'. In the dropdownbox of the entry field, I find the variables defined in step one (but always preceeded by 'dashboard.', which indicates I'm on the right track.
      I tried hunderds of combinations for both steps, none of them are working. Can someone please point me in the right direction?
    2 replies
    Peyman Yousefi
    @peyman.yousefi3_gitlab
    Hi all, is there a way to prevent the PAT token from being changed?
    5 replies
    GATSA-SA
    @GATSA-SA
    Good day KAA people. Quick question: Which server can i use to ping connectivity?
    4 replies
    mxrandhawa
    @mxrandhawa
    Dear All! Can someone please post a curl request to get telemetry data from the kaaiot cloud? I want to fetch the data that was pushed to the cloud by my iot. Thanks for your help!
    14 replies
    Peyman Yousefi
    @peyman.yousefi3_gitlab
    Hi all, in the kaa-rest-api client, I saw more than 2000 active sessions. Why is it so high and is it bad or something?
    anamamjad27
    @anamamjad27
    Hi, can anyone please guide me how can I perform message translation in KAA? For example, if I want to convert MQTT into HTTP message, is it possible in KAA? if yes, then what is the possible way?
    Erwin Vermassen
    @evermassen_gitlab
    Hi, bit of a strange problem here. I am test driving Kaa and until now it ticks quit a lot of boxes but, for some reason I cannot access the platform anymore. When I open the login page I get a form where I need to check the Root Account and next the system asks me for my tenantId or user name. After adding either the tenantId or user name, click Next and the same TenantId form is shown again. It used to work fine this morning but at a certain moment I got an Nginx error. Something like a Server Error. Anything wrong with the system?
    Timorba
    @Timorba
    I need help adding timestamp , if you can help me just add comment on arduino forum : https://forum.arduino.cc/t/adding-timestamp-to-kaaiot/910702
    Funmilola Fagbola
    @funmilola:matrix.org
    [m]
    Hi everyone, i am a newbie to KAAIoT, can anyone kindly assist with how to activate an inactive token?
    2 replies
    GATSA-SA
    @GATSA-SA
    Good Day Kaa. I've recently seen the error "Something went wrong, please contact your system administrator" on all of my solution and dashboard's widgets. I first noticed it on the 20/11/21, any idea on the cause of this?
    1 reply