These are chat archives for LaravelRUS/chat

2nd
Dec 2017
KOrVin
@lokilok1993
Dec 02 2017 12:21 UTC
Привет ребят, скиньте пожалуйста исчерпывающий гайд как деплоить приложение на laravel через гит ( Мой первый опыт самостоятельного деплоя на шаред хастинг через гит )
Хостинг*
des1roer
@des1roer
Dec 02 2017 12:59 UTC
привет
а вот хелперы https://laravel.com/docs/5.5/helpers#introduction лары можно через композер отдельно подключить?
strekozlik
@strekozlik
Dec 02 2017 13:03 UTC
Я хелперы подключил через сервис провайдер. Создал сервис провайдер HelpersServiceProvider
Так они хотя бы на виду
des1roer
@des1roer
Dec 02 2017 13:04 UTC
что это за пакет?
strekozlik
@strekozlik
Dec 02 2017 13:04 UTC
Это не пакет
Ща
В общем хелперы, которые в Ларе есть подключать не надо, они уже есть. Я имел ввиду, что можно создавать свои хелперы и подключать их ни только через composer
namespace App\Providers\Helper;

use Illuminate\Support\ServiceProvider;

class RequireViewHelpersServiceProvider extends ServiceProvider
{
    /**
     * Register the application services.
     *
     * @return void
     */
    public function register()
    {
        require_once __DIR__ . '/../../Classes/Support/ViewHelpers/urlHelper.php';
        require_once __DIR__ . '/../../Classes/Support/ViewHelpers/routeHelper.php';
        require_once __DIR__ . '/../../Classes/Support/ViewHelpers/menuHelper.php';
        require_once __DIR__ . '/../../Classes/Support/ViewHelpers/assetHelper.php';
    }
des1roer
@des1roer
Dec 02 2017 13:09 UTC
да нет же. пусть будет никий проект с пср и композером. не обязательно лара. какой пакет нужно поставть чтобы работал dd array_add и прочее?
strekozlik
@strekozlik
Dec 02 2017 13:10 UTC
Так никакой не надо, они уже есть
Просто набери в любом месте array_add()
У меня даже ide подсказывает, правда это наверное из-за того, что я поставил пакет ide-helper
des1roer
@des1roer
Dec 02 2017 13:13 UTC
image.png
нет. это composer require illuminate/support
и в yii2 можно юзать
image.png
strekozlik
@strekozlik
Dec 02 2017 13:15 UTC
Так ты отдельно от Лары хочешь установить?
des1roer
@des1roer
Dec 02 2017 13:15 UTC
image.png
я про это и написал
strekozlik
@strekozlik
Dec 02 2017 13:16 UTC
Тогда не помогу, отдельно их не юзал
JhaoDa
@jhaoda
Dec 02 2017 14:09 UTC
@des1roer ну очевидно же, что хэлперы это не отдельный пакет
@des1roer не менее очевидно, что надо посмотреть, в каком они пакете и его ставить
JhaoDa
@jhaoda
Dec 02 2017 16:25 UTC
@des1roer да ты шо...
ZatsepinSerg
@ZatsepinSerg
Dec 02 2017 20:34 UTC
Добрый вечер !Подскажите пожалуйста с моей проблемой . Стала задача установить jQuery и Bootstrap3 через менеджер npm . Всё установил , распаковал. Но вот вопрос ) Как подключить их к необходимой мне странице? появилась папка node_modules, результаты поиска в гугле мне не дали ответа как это правильно делать.
решение было было предложено такое <link rel="stylesheet" type="text/css" href="{{ asset('assets/css/test.css') }}" /> . Но вот в чём ещё проблема , папки css в assets нет .
ZatsepinSerg
@ZatsepinSerg
Dec 02 2017 20:40 UTC
в package.json изменения видны
"devDependencies": {
"axios": "^0.16.2",
"bootstrap-sass": "^3.3.7",
"cross-env": "^5.0.1",
"jquery": "^3.2.1",
"laravel-mix": "^1.0",
"lodash": "^4.17.4",
"vue": "^2.1.10"
},
"dependencies": {
"bootstrap": "^3.3.7"
}
}
добавился bootstrap и jquery
JhaoDa
@jhaoda
Dec 02 2017 21:02 UTC
@ZatsepinSerg пробовал ли ты читать документацию?
ZatsepinSerg
@ZatsepinSerg
Dec 02 2017 21:45 UTC
Естественно)Смог разобраться с тем что бы подключить стили , ок. Но вот попытка установить дополнительный пакет закончилась тем что опять же , он есть в package.json . А использовать не получается (
ZatsepinSerg
@ZatsepinSerg
Dec 02 2017 21:53 UTC
после того как получилось с стилями решил установить npm install jquery-treegrid
прописало что такой пакет добавило , но файлов некаких небыло
кроме изменения package.json
JhaoDa
@jhaoda
Dec 02 2017 21:55 UTC
@ZatsepinSerg плохо читал
ZatsepinSerg
@ZatsepinSerg
Dec 02 2017 21:58 UTC
можете пожалуйста ткнуть какую именно статью перечитать? Буду очень благодарен
Илья.
@IlyaVorozhbit
Dec 02 2017 22:53 UTC

Доброй ночи, программисты!

Подскажите, пожалуйста. Поставил socialite (давно, проект давно писал, тогда работало...), поставил драйвер вконтакте, и при авторизации получаю Call to undefined method SocialiteProviders\VKontakte\Provider::getAccessTokenResponse()

Не знаю, как бороться, уже думал старое всё, обновил, смотрю в другом проекте, там версия старее (и провайдера и социалайта, все работает).

Не знаю, где проблема кроется...

Юзаю апи: http://socialiteproviders.github.io/providers/vkontakte/

Т.е. Socialite::driver('vkontakte')->user();
На этом месте падает

Илья.
@IlyaVorozhbit
Dec 02 2017 23:01 UTC
Вот сейчас посмотрел код провайдера ВКонтакте, он просит метод getAccessTokenResponse, которого, собственно, нет
Andrey
@daaner
Dec 02 2017 23:05 UTC
@ZatsepinSerg полезно будет сперва узнать что такое GULP и SASS. ну и папка assets как бы не видна из браузера. такие весчи тыкай в public.
Mikhail Donskoy
@mdnsk
Dec 02 2017 23:14 UTC
@Daaner Тогда уже не про gulp, а про webpack нужно узнавать.
Илья.
@IlyaVorozhbit
Dec 02 2017 23:17 UTC
Спасибо, решил проблему
Andrey
@daaner
Dec 02 2017 23:32 UTC
@mdnsk ну ты выдумаешь) так сразу нельзя