Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 11 2018 10:21

    asahd on v2.5.2

    (compare)

  • Sep 11 2018 10:21

    asahd on v2.5.2

    (compare)

  • Sep 11 2018 10:19

    asahd on master

    Restore nginx.conf.example (compare)

  • Sep 11 2018 10:05

    asahd on v2.5.2

    (compare)

  • Sep 11 2018 10:04

    asahd on feature-symantic

    (compare)

  • Sep 11 2018 10:04

    asahd on master

    Added full document toggle to s… Added post and patch metadata. Updated Metadata to update stat… and 6 more (compare)

  • Sep 11 2018 10:04
    asahd closed #1232
  • Sep 11 2018 09:05
    asahd labeled #1232
  • Sep 11 2018 09:05
    asahd unlabeled #1232
  • Sep 11 2018 08:42
    asahd synchronize #1232
  • Sep 11 2018 08:42

    asahd on feature-symantic

    Fixes statement creations being… (compare)

  • Sep 10 2018 15:07

    happy-machine on Statement_component

    fixed default naming in Stateme… (compare)

  • Sep 10 2018 12:45
    asahd synchronize #1232
  • Sep 10 2018 12:45

    asahd on feature-symantic

    Changes Forwarding UI, updates … (compare)

  • Sep 10 2018 11:45
    ht2 synchronize #1232
  • Sep 10 2018 11:45

    ht2 on feature-symantic

    Start of shareable dashboards u… Removed filter required paramet… Added validation for shareable … and 49 more (compare)

  • Sep 04 2018 16:29
    cutz opened #1246
  • Sep 04 2018 14:20
    samjaved closed #1245
  • Aug 30 2018 22:20
    ryansmith94 assigned #1242
  • Aug 30 2018 16:43

    happy-machine on Statement_component

    working as Map (compare)

njimkolp
@njimkolp

Hello,

We have Learning Locker v6.4.0 "{"X-Experience-API-Version":"1.0.3","version":["1.0.3"]}". It does not seem to work well with the newest version of Articulate Storyline. Is Learning Locker able to work with bootstrapper.min.js? If so, what version?

torashid
@torashid
Hi Guys, I am trying to set up LearningLocker latest release v7.1.1. I have Node10 installed but while running npm build all getting an error and see most of the packages are deprecated. I need help, can you guys guide me how to setup this?
torashid
@torashid
image -error.png
image (8).png
torashid
@torashid
What would need Node Version to install the latest release 7.1.1 of LearnigLocker https://github.com/LearningLocker/learninglocker/releases
Florian Tolk
@FlorianTolk
Are you sure you are using node 10? It is a fairly old version of nodejs, and has recently been deprecated.
I am in the process of trying to get it to run in a docker container with 12 and am running into the same problem. node-gyp has a number of odd requirements, like make and python being installed.
Robert Kraemer
@numismae
Hi, referring to "Statement Forwarding", is there anything like a "State Forwarding" feature? Or how can states be forwarded to another LRS?
Florian Tolk
@FlorianTolk
When standing up using yarn, does the UI and API talk directly to the database, or does it go through a worker?
I am trying to generate an architecture diagram
Jesus M Bianco T
@jbiancot_twitter
Hi, I need help !!! please help !!! We have a LL 3.19.0 on Debian 9, when updating to Debian 10, it install NodeJS v10 and LL breaks, what we can do to migrate from Debian 9 to 10, and run the same version of LL?

npm -v
6.4.1
node -v
v8.16.0
nodejs -v
v8.16.0
yarn -v
1.5.1
pm2 -v
3.5.1

lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 9.13 (stretch)
Release: 9.13
Codename: stretch

uname -a
Linux lrs 4.9.0-15-amd64 #1 SMP Debian 4.9.258-1 (2021-03-08) x86_64 GNU/Linux

Jesus M Bianco T
@jbiancot_twitter
There is other online community, e-mail, etc.. to get support for the Learning Locker software?
gamahachaa
@gamahachaa
It seems that nobody from the learning pool will ever appear and provide support again here. They seem to have changed their strategy. Last appearance from a @ryansmith94 was 2 years ago. I can understand though that support on opensource project cannot be forever free, considering the amount that was provided in the first years. But I agree it is a little disappointing to post an issue and have unanswered.
Florian Tolk
@FlorianTolk
I am trying to containerize and scan LearningLocker, however most of the unit tests are failing for the learningLocker base repo (all but one are passing for the service)
Is there documentation on why tests like "BatchDeleteController intialise should initialise a deletion with the correct filer"?
Florian Tolk
@FlorianTolk

I have also been struggling with this error on startup:
uncaughtException: listen EADDRINUSE: address already in use undefined

But I have defined every variable in the sample env file, so am unsure where this error is coming from

David Pesce
@davidpesce
I think it’s safe to say that the oss version of learning locker is dead. Take a look at YetAnalytics open source LRS as an alternative
Florian Tolk
@FlorianTolk
Will do. While I asses I do think I am closer to finding a solution.
Does anyone know what arguments to add to the .env file to pass in service bus settings?
uncaughtException: Cannot find correct Service Bus settings in configuration or environment
Seeing thsi error as I work through all of teh various error messages I am getting
cPanelRyan
@cPanelRyan
Having trouble after setting up learninglocker, logins showing "There was an error communicating with the login server." - anyone familiar with troubleshooting this?
cPanelRyan
@cPanelRyan
ACtually, it seems like it might be grpc install related
> node-pre-gyp install --fallback-to-build --library=static_library

node-pre-gyp ERR! Tried to download(undefined): https://storage.googleapis.com/grpc-precompiled-binaries/node/grpc/v1.9.1/node-v64-linux-x64-glibc.tar.gz
cPanelRyan
@cPanelRyan
do I need to establish a google dev api key somewhere?
Marlon Martínez Salazar
@marlonmartinezsalazar
Hi Learning Locker team and people! I recently upgraded my LL installation from version 4.10.0 to the most recent version. Everything was good at upgrading but I cannot see the updated version on the login screen. The login screen keep displaying version 4.10.0. Is this an issue? Thank you!
Debkumar-Maiti
@Debkumar-Maiti
Hi Learning Locker Team, Learning Locker is installed in RHEL 8.5 Azure VM. Sometimes (Intermittent, once in a month) learning locker gets stopped abruptly. We manually start the learning locker process. What could be the root cause. @ryansmith94 @cPanelRyan
Alex
@alex2408
Hi Learning Locker Team. I have installed LL (community) on AWS. I am trying to send a statement to the LRS using postman (used the tutorial from youtube). Unfortunately I receive a 502 bad gateway in return. Any idea?
Pedro Sousa
@pmsousa
Hi, guys. We have a problem with Redis on Azure because the number of connected clients just goes up and up, until it reaches the limits of connections. It looks like Learning Locker is opening connections but never closing them. Any ideas?
Pascal Peters
@PascalPet
Hey, in some learning lockers the cursor parameter causes a 500-error: "A server error occurred".
Can i change something in the settings? In other LL the cursor parameter is working as intended. (tried out multiple with postman)
ADLMeganBohland
@ADLMeganBohland
Hi all! I am working with Learning Locker APIs, if I use "GET https://lrs.castle.adlnet.gov/data/xAPI/statements" I can get ALL the statements, but how can I narrow down by user? Say I want to search by user "Megan Bohland", something like "GET https://lrs.castle.adlnet.gov/data/xAPI/statements?actor=MeganBohland" or other forms are giving me an error ""Expected valid JSON in query.agent". I tried URI encoding it, but same thing, sure I'm just missing the syntax. Anyone have an example I can go off?
vishu1013
@vishu1013
Hi @ADLMeganBohland you can use the "person" : {
_id: "111aaa1111a111111aa11111",
name: "Joe Bloggs"
}, in the get statement repsonse and pass person._id as query parameter in the get call
Hi LearningLockerTeam, I had restored the mongodb to and mongo atlas and updated the endpoint in .env for webapp and XApi, but for some reason not able to login on UI(passport basic auth is failing), I can see user in the new mongodb user collection, any help on this would be much appreciated, thank you
ADLMeganBohland
@ADLMeganBohland
Thank you @vishu1013, I appreciate it!
Andrey G.
@Andrey2G
Hi! I've started reading Locker Learning documentation and found on this page https://docs.learninglocker.net/guides-structuring/ broken links to articles on zendesk. Could you please help me to find them?
Vaibhav Mahajan
@MYVAIBHA
I am using learning locker version 7.1.1 and I am running learninglocker on docker. When I login using admin user sometimes users default organisation is not showing. The organisation API returns blank array in response and when I refresh the page 5-6 times then the organisation is visible. Why is that happening can anyone answer?
Vaibhav Mahajan
@MYVAIBHA
Screenshot 2022-08-11 at 12.48.49 PM.png
The above screen is showing after login. and after 5-6 refresh it is showing the orgnisation
Vaibhav Mahajan
@MYVAIBHA
The above error is coming because the APIs are returning 304 response sometimes. So is there any way to invalidate learninglocker session after user closes the browser tab.