Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Dec 02 15:48
    KKauK commented #4369
  • Dec 02 12:48
    punker76 commented #4366
  • Dec 02 12:48
    punker76 closed #4368
  • Dec 02 12:48
    punker76 locked #4368
  • Dec 02 12:47
    punker76 commented #4369
  • Dec 02 12:46
    punker76 commented #4369
  • Dec 02 12:46
    punker76 closed #4369
  • Dec 02 12:46
    punker76 commented #4369
  • Dec 02 12:40
    KKauK labeled #4369
  • Dec 02 12:40
    KKauK opened #4369
  • Dec 02 10:19
    lorenzocostalunga commented #4361
  • Nov 24 21:35
    osekj opened #4368
  • Nov 22 21:23
    punker76 closed #4361
  • Nov 22 21:23
    punker76 commented #4361
  • Nov 22 21:21
    punker76 commented #4366
  • Nov 22 21:18
    Build #1888 passed
  • Nov 22 21:06
    punker76 commented #4364
  • Nov 22 21:06

    punker76 on develop

    fix: #4363 MultiSelectionComboB… fix: #4363 we need to handle th… Merge pull request #4364 from I… (compare)

  • Nov 22 21:06
    punker76 closed #4363
  • Nov 22 21:06
    punker76 closed #4364
Tim
@timunie
I think there is also a ticket at MahApps or ControlzEx
Tim
@timunie
TripleNico
@TripleNico
@timunie Thanks for your swift reply. Hmm it seems like the problem is indeed related. Wil try to debug some more to see if i can pinpoint where it goes wrong. Because the issue doesn't appear always.
Twitter Tweets
@mrjakepavek_gitlab
can someone help me try to fix these textboxes?
image.png
<StackPanel Orientation="Horizontal">
                    <TextBox Name="txtUsername" FontFamily="Helvetica"
                            FontWeight="Light"
                            FontSize="20"
                            HorizontalAlignment="Center"
                            Foreground="White"
                            Background="Transparent"
                            BorderThickness="0"
                            Width="235"
                             VerticalAlignment="Bottom"
                            HorizontalContentAlignment="Left"
                            Opacity="100"
                            Height="20"
                            Margin="110,0,0,0"
                            Text="{Binding SelectedUser}"/>
                    <iconPacks:PackIconMaterial Kind="Account"
                                               VerticalAlignment="Center"
                                               HorizontalAlignment="Center"
                                               Foreground="White"/>
                </StackPanel>
Tim
@timunie
Hi @mrjakepavek_gitlab
Hope you are doing well ☺️
Have you double check the Margin? Maybe it's related to your issue
Or the width is wrong
Twitter Tweets
@mrjakepavek_gitlab
Thank you I hope you are as well. It works fine on some monitors and other dimensions it decided to offset
Tim
@timunie
That's why I try to avoid fixed sizes.
Twitter Tweets
@mrjakepavek_gitlab
image.png
Tim
@timunie
I think it comes from the margin in combination with center
Twitter Tweets
@mrjakepavek_gitlab
I think it's my stackpanel codes lol
Tim
@timunie
Yep possible
Twitter Tweets
@mrjakepavek_gitlab
I think I just have to many
<Grid>

        <Grid>
            <Grid.RowDefinitions>
                <RowDefinition/>
                <RowDefinition/>
                <RowDefinition/>

            </Grid.RowDefinitions>

            <Grid.ColumnDefinitions>
                <ColumnDefinition/>
                <ColumnDefinition/>
                <ColumnDefinition/>

            </Grid.ColumnDefinitions>


            <Border  Grid.RowSpan="3" Grid.ColumnSpan="3">
                <Border.Background>
                    <LinearGradientBrush>
                        <GradientStop Color="#7be9f6" Offset="0.1"/>
                        <GradientStop Color="Blue" Offset="1"/>
                    </LinearGradientBrush>
                </Border.Background>
            </Border>


            <StackPanel Grid.ColumnSpan="3" Grid.Row="1">
                <iconPacks:PackIconMaterial Kind="HomeCircle" HorizontalAlignment="Center" VerticalAlignment="Top" Foreground="White" Width="70" Height="70" />
                <TextBlock Text="Associate Login"
                          Margin="0,20,0,0"
                          VerticalAlignment="Top"
                          FontWeight="Light"
                          FontFamily="helvetica"
                          FontSize="22"
                          Foreground="White"

                          HorizontalAlignment="Center"/>
            </StackPanel>



            <StackPanel Grid.Column="1" Grid.Row="1" Grid.RowSpan="2" Margin="0,150,0,0">
                <StackPanel Orientation="Horizontal">
                    <TextBox Name="txtUsername" FontFamily="Helvetica"
                            FontWeight="Light"
                            FontSize="20"
                            HorizontalAlignment="Center"
                            Foreground="White"
                            Background="Transparent"
                            BorderThickness="0"
                            Width="235"
                            VerticalAlignment="Bottom"
                            HorizontalContentAlignment="Left"
                            Opacity="100"
                            Height="25"
                            Margin="110,0,0,0"
                            Text="{Binding SelectedUser}"/>
                    <iconPacks:PackIconMaterial Kind="Account"
                                               VerticalAlignment="Center"
                                               HorizontalAlignment="Center"
                                               Foreground="White"/>
                </StackPanel>
                <Border Width="250"
                       Height="2"
                       Background="White"
                       Opacity="0.5"/>



                <StackPanel Grid.ColumnSpan="3" Orientation="Horizontal" Margin="0,20,0,0">
                    <PasswordBox Name="txtPassword" FontFamily="Helvetica"
                            FontWeight="Light"
                            FontSize="20"
                            HorizontalAlignment="Center"
                            Foreground="White"
                            Background="Transparent"
                            BorderThickness="0"
                            Width="235"
                            HorizontalContentAlignment="Left"
                            Opacity="0.5"
                            Height="25"
                            Margin="110,0,0,0"/>
                    <iconPacks:PackIconMaterial Kind="TextboxPassword"
                                               VerticalAlignment="Center"
                                               HorizontalAlignment="Center"
                                               Foreground="White"/>
                </StackPanel>
                <Border Width="250"
                       Height="2"
                       Background="White"
                       Opacity="0.5"/>


                <StackPanel Orientation="Horizontal" HorizontalAlignment="Center" Margin="0,50,0,0">
                    <Button Name="btnLogin" Click="btnLogin_Click" Height="40" Width="200" C
Tim
@timunie
Maybe 😂. It's bedtime for me now.
Maybe set the inner grid to be centered instead of margin
It is stretch by default
Good night
TripleNico
@TripleNico

Hi @TripleNico I think there is an issue with WPF and transparent Windows if I remember correctly

Did some testing and a simple workarround is to hide the MainWindow also upon load. For now i have what i want :-)

TripleNico
@TripleNico
Different question: Is it possible to apply the Validation style to a usercontrol? In other words i have created a UserControl with four textboxes for entering IP adresses. Now when it's empty i raise a validationerror. The UserControl gets the red border but no Popup with the error message, also not when i click on it.
Torchok19081986
@Torchok19081986
Try ObservableValidator from mvvm toolkit
TripleNico
@TripleNico
Thanks, will have a look! Though isn't there something simpler without adding another package?
Torchok19081986
@Torchok19081986
have a look to validation method
may is possible to achieve same with custom way. Second link to validator. Validationname Method
Tim
@timunie
@Torchok19081986 that is something differnt. The package is great, but it is not related to the appereance
@TripleNico you will have to set it via the attached property Validaten.ErrorTemplate="{StaticResource MahApps.Templates.ValidationError}"
Torchok19081986
@Torchok19081986
ok, thanks Tim. I thought with Validator , i can achive same like IDataErrorInfo Interface.
bolt-b
@bolt-b
Hello everyone,
I can't understand an issue. Whether it depends on this framework or this is native WPF issue or so. Perhaps professionals will give me an advice.
Tim
@timunie
@bolt-b then post your question 😊
This chat is not in real time
bolt-b
@bolt-b
<Path

                            Width="46"
                            Height="88"
                           Data="F1 M 384.165,185.705L 302.608,32.3512L 131.861,0.499878L 0.5,114.136L 7.44214,287.69L 147.46,390.471L 315.117,345.084L 384.165,185.705 Z "
                            Stretch="Fill"
                            Stroke="#FF000000"
                            StrokeLineJoin="Round">
                            <Path.Style>
                                <Style TargetType="{x:Type Path}">
                                    <Style.Triggers>
                                        <DataTrigger Binding="{Binding firstColour}" Value="false">
                                            <Setter Property="Path.Fill" Value="Red" />
                                        </DataTrigger>
                                        <DataTrigger Binding="{Binding secondColour}" Value="true">
                                            <Setter Property="Path.Fill" Value="Blue" />
                                        </DataTrigger>
                                    </Style.Triggers>
                                </Style>
                            </Path.Style>

                        </Path>
I can't understand why the trigger works properly when true, and doesn't work when false. The polygone remains "Blue". Thanks
Tim
@timunie
Hi @bolt-b
try to add a default setter
                            <Path.Style>
                                <Style TargetType="{x:Type Path}">
                                    <Setter Property="Path.Fill" Value="[YourFallbackValue]" />
                                    <Style.Triggers>
                                        <DataTrigger Binding="{Binding firstColour}" Value="false">
                                            <Setter Property="Path.Fill" Value="Red" />
                                        </DataTrigger>
                                        <DataTrigger Binding="{Binding secondColour}" Value="true">
                                            <Setter Property="Path.Fill" Value="Blue" />
                                        </DataTrigger>
                                    </Style.Triggers>
                                </Style>
                            </Path.Style>
bolt-b
@bolt-b
@timunie, thanks, this works. However, it looks not logically. Or? I can simply delete "false" part of trigger. Use default setter and "true" part.
Tim
@timunie

First of all this is normal WPF, not MahApps related.

And for me it makes sense: How else should the style know, which color is the normal

But I am not a programmer, so maybe my engineers understanding is wrong ^^
bolt-b
@bolt-b
Yes I agree this is not related to your framework. The style is said explicitly "when false" fill with "Red", though.
Tim
@timunie
No it does not
firstColour vs secondColour
bolt-b
@bolt-b
I can't find any info about this misbehaving. Anyway thank you a lot.
Tim
@timunie
:+1:
TripleNico
@TripleNico
Morning everyone! Today i got a simple question, is there a poperty i can set to hide the last vertical gridline of a datagrid? It seems that the example app does this but if i try the same the vertical gridline of the last column is always shown.
6 replies