Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Jan 26 23:21
    Build #1785 passed
  • Jan 26 23:14
    Build #1784 passed
  • Jan 26 23:09
    punker76 synchronize #4259
  • Jan 26 23:08
    punker76 labeled #4259
  • Jan 26 23:08
    punker76 milestoned #4245
  • Jan 26 23:08
    punker76 edited #4259
  • Jan 26 23:06

    punker76 on develop

    refactor(demo): use only one Bi… refactor(helper): prevent dupli… refactor(demo): improve DataGri… (compare)

  • Jan 26 17:37
    Build #1783 passed
  • Jan 26 17:30
    punker76 commented #4258
  • Jan 26 17:30

    punker76 on develop

    Handle DataGridColumn visibilit… Merge pull request #4258 from f… (compare)

  • Jan 26 17:30
    punker76 closed #4258
  • Jan 26 15:59
    punker76 milestoned #4258
  • Jan 26 15:59
    punker76 labeled #4258
  • Jan 26 13:44
    Build #1782 passed
  • Jan 26 13:36
    fredericoregateiro synchronize #4259
  • Jan 26 13:18
    Build #1781 passed
  • Jan 26 13:11
    fredericoregateiro opened #4259
  • Jan 26 13:00
    Build #1780 passed
  • Jan 26 12:52
    fredericoregateiro opened #4258
  • Jan 26 12:16
    fredericoregateiro closed #4256
bolt-b
@bolt-b
is there a difference in code?
Tim
@timunie
not in XAML
Ok Mode=TwoWay
bolt-b
@bolt-b
where?
Tim
@timunie
Maybe the property
I have not your Property
image.png
image.png
bolt-b
@bolt-b
...and it works by true coming from binding only?
Tim
@timunie
yep
And I think there is an issue in your MVVM
So please share your code of the Property
bolt-b
@bolt-b
nothing special... standard property made by code snippet.
I have got hundreds identical ones, all working.
 public bool BooleanValue
        {
            get { return _booleanValue; }
            set { Set(ref _booleanValue, value); }
        }
        private bool _booleanValue;
Tim
@timunie
very strange, but not MahApps related as it works in the demo
bolt-b
@bolt-b
@timunie thank you, seems I found a culprit. it was App specific issue. Not WPF and Mahapps.
Tim
@timunie
I sent you a private link
It's a tool which helped me in the past
bolt-b
@bolt-b
Oh, I see.
JendolaRajda
@JendolaRajda
Hello there! I've been using MahApps for some time now, but only now am I really getting into utilizing the ThemeManager within my apps and have a little question or a possible feature request: Are there any brushes within each of the themes that could give me the Accent colour when using a Light theme, but a dark grey colour when using a Dark theme? Or perhaps vice versa - a brush that would produce accented colour for Dark theme and a shade of dark grey for the Light theme? There's a lot of brushes that switch between dark grey and white depending on the theme, but I haven't found any that would switch between the accent and grey.
Tim
@timunie
Hi @JendolaRajda
You can roll your own ThemeManager and adjust it the way you need to.
Have a look at
Override the LibraryThemeProvider
Happy theming
Tim
TripleNico
@TripleNico
Hi all! Is there a helper function in Mahapps to start a MetroWindow on it's own thread instead of the MainWindow thread?
rabster007
@rabster007
Hi! Does anyone have any experience with TextBoxHelper.IsWaitingForData? Is there a way to change the color of the effect? When my theme is set to dark, the effect isn't visible.
Tim
@timunie
Hi @TripleNico This is normal WPF and not MahApps related.
Anyway you can find more information about this here: https://is.gd/uEQ4Yw
Happy coding, Tim
Tim
@timunie
Hi @rabster007
I think you can override this effect by overriding this DynamicResource in your App.xaml or in any Resources section
Just try to copy&paste the lines given in the link and modify to your needs. I have not tested it yet, so if it doesn't work please come back.
Happy coding, Tim
rabster007
@rabster007
Thanks Tim, I actually did end up doing that shortly after asking my question. I can get it to work as long as I set a specific color but I still haven't been able to set it based on the theme (I'd like to set it to the current accent). If you have any additional suggestions, I appreciate the guidance. Thanks :)
rabster007
@rabster007
Cancel that.. I was able to figure it out after sleeping on it :)
Tim
@timunie
@rabster007 you are welcome.
Sebastian Matus
@sebamatusr
Hi
does anyone encountered a weird behavior using dialog windows along with child windows?
I open a progress dialog when I open a childwindow to wait for an api call
but looks bad
image.png
its like the modal is behind the childwindow and I can click it, move it, etc
Tim
@timunie
Hi @sebamatusr can you share the sample code or create a sample App?
Tim
@timunie
Hi @sebamatusr I tried to reproduce this in the demo and I was able to reproduce your issue.
wait
image.png
Tim
@timunie
it works on another childwindow. Just try the second button:
image.png