These are chat archives for Makuna/NeoPixelBus

14th
Feb 2018
Guillem Cabo
@GuillemCabo
Feb 14 2018 19:38

Setup:
PlatformIO 3.5.1

Platform Teensy

Updating teensy @ 3.0.1 [Up-to-date]
Updating toolchain-atmelavr @ 1.40902.0 [Up-to-date]
Updating framework-arduinoteensy @ 1.141.0 [Up-to-date]
Updating tool-teensy @ 1.141.0 [Up-to-date]
Updating framework-mbed @ 4.50703.1 [Up-to-date]
Updating toolchain-gccarmnoneeabi @ 1.50401.0 [Up-to-date]

Run the next commands:
mkdir ws2812
cd ws2812
platformio init -b teensylc
platformio lib install NeoPixelBus
//version:NeoPixelBus @ 2.2.9
cd src/
wget https://raw.githubusercontent.com/Makuna/NeoPixelBus/master/examples/DotStarTest/DotStarTest.ino
cd ../
sudo platformio run --target upload

Michael Miller
@Makuna
Feb 14 2018 23:09
I don't specifically support platform IO and the current support was supplied by someone else. Have you tried it with the Arduino IDE first?
Michael Miller
@Makuna
Feb 14 2018 23:25
I just got all the latest support for Teensy LC and your problem does reproduce. They must have changed something in the board support, I will look into it. In the past, they haven't followed good Arduino board support practices making it a pain to support them.