These are chat archives for Makuna/NeoPixelBus

2nd
Feb 2019
Tinkerspy
@tinkerspy
Feb 02 17:22
I tried to compile on a Teensy 3.5 but I got a compile error. When I changed the conditional compile to include the 3.5 in the 3.0/3.1 test it compiled it seemed to work fine. MK64FX512 and MK66FX1M0 define the Teensy 3.5 and 3.6 respectively. Good chance the 3.6 will work as well. The 3.2 is identical to the 3.1 and it works fine as is.
Oops, markdown changed the double underscores to bold markings. More info here: https://forum.pjrc.com/threads/36912-Teensy-3-5-3-6-identification
Michael Miller
@Makuna
Feb 02 19:00

So the line 109 in NeoArmMethod becomes

// Teensy 3.0 or 3.1 or 3.5 or 3.6
#if defined(__MK20DX128__) || defined(__MK20DX256__) || defined(__MK64FX512__) || defined(__MK66FX1M0__)

I don't have any of the arms to test, I can only make sure it compiles.

Michael Miller
@Makuna
Feb 02 19:39
AND BTW, I may never own a teensy. The Arduino install on Windows never works right for me. And their insistence that real time virus protection be turned off to make it work; well, that's a deal breaker right there. NO SOFTWARE SHOULD REQUIRE THIS unless its a virus itself.
Tinkerspy
@tinkerspy
Feb 02 19:39
That should be it. I have verified it works on 3.2 and 3.5, you may want to add 3.2 to the comment. I don't have a 3.6 but if I ever get one I'll let you know.
Teensyduino only works on Windows?
Michael Miller
@Makuna
Feb 02 19:41
Do you use Windows for working with Teensy?
Tinkerspy
@tinkerspy
Feb 02 19:41
I do
Linux on my servers (I'm not a complete newb)
Michael Miller
@Makuna
Feb 02 20:17
Do you run into the same issues with installing the Arduino Dev Board support?
Tinkerspy
@tinkerspy
Feb 02 21:12
No, not really. For teensy support I just run the PJRC installer and that works fine.