Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Nov 21 19:10
    mfeifer labeled #32
  • Nov 21 19:10
    mfeifer unlabeled #32
  • Nov 21 19:10
    mfeifer labeled #32
  • Nov 08 22:05

    Fryguy on master

    Optionally symlink spec/managei… Merge pull request #84 from agr… (compare)

  • Nov 08 22:05
    Fryguy closed #84
  • Nov 08 22:05
    Fryguy labeled #84
  • Nov 08 22:05
    Fryguy milestoned #84
  • Nov 08 22:05
    Fryguy assigned #84
  • Nov 08 13:51
    miq-bot commented #84
  • Nov 08 13:50
    agrare synchronize #84
  • Nov 08 13:39
    agrare edited #84
  • Nov 08 13:37
  • Nov 08 13:28
    agrare opened #84
  • Nov 06 17:47
    simaishi assigned #83
  • Nov 06 17:47
    simaishi milestoned #83
  • Nov 06 17:47
    simaishi labeled #83
  • Nov 06 17:47

    simaishi on ivanchuk

    Test ruby 2.5.5, see: https://g… Merge pull request #83 from d-m… (compare)

  • Nov 06 17:47
    simaishi closed #83
  • Nov 06 16:54
    miq-bot commented #83
  • Nov 06 16:43
    miq-bot edited #83
Jason Frey
@Fryguy
you just set a validation in the model
PATCH/PUT doesn't write to the DB directly...it still has to go through model validations and whatnot
ThomasBuchinger
@ThomasBuchinger
you are correct, automate_domains is backed. I'll try to get from being able to read rails code, to writing new rails code on the weekend
Martin Hradil
@himdel

I'd rather see a specific "enable domain" action, instead of a generic "set attribute" in this case.

After all, we're talking about enabling a domain, not about settting domain.enabled=true

(even if that's all that would end up happening)
((at least, to me enabling a domain sounds more like a black box method call than a simple attribute set))
Jason Frey
@Fryguy
I dunno...agree to disagree :)
Martin Hradil
@himdel
yeah, either works :)
ThomasBuchinger
@ThomasBuchinger
so 3 votes for "indifferent"?
Halász Dávid
@skateman
I'm struggling with retrieving a virtual attribute of an expanded subcollection, specifically for tagging, is it even possible?
GET /api/categories?expand=resources,tags&attributes=id,description
into that I'm trying to get in the categorization virtual attribute for eachtag
ThomasBuchinger
@ThomasBuchinger
@skateman Are you looking for this?
 GET /api/tags?expand=resources&attributes=id,name,categorization
{"href":"https://cf.example.com/api/tags/6062","id":"6062","name":"/managed/visibility/all","categorization":{"name":"all","description":"All Groups","category":{"name":"visibility","description":"Visibility"},"display_name":"Visibility: All Groups"}}
Halász Dávid
@skateman
@ThomasBuchinger nope, this would be too easy
I want it through the categories
Eugene Zapolsky
@izapolsk
Hi everybody. remote appliance templates don't have ems_id set in global region appliance. could you please advice what property should I use to get some particular provider's template ?
Eugene Zapolsky
@izapolsk
@all ^^
Jason Frey
@Fryguy
@agrare ?
I can't understand how that wouldn't be replicated
Adam Grare
@agrare
Are they archived? Do they have an ems Id in the remote regions
Gregg Tanzillo
@gtanzillo
@izapolsk The replicated templates should be identical between the lower region and the global
Eugene Zapolsky
@izapolsk
@agrare, sure thing, they have.
@gtanzillo, I'll submit BZ then. thank you
Gregg Tanzillo
@gtanzillo
Sounds good @izapolsk
Fabien Dupont
@fdupont-redhat
Hi. I have a question about ServiceTemplate order. There's test in specs/requests/service_templates_spec.rb, on line 618, that verifies that the order action is not available for unorderable template. Could anyone explain what are the criteria that remove this action from the actions list ?
Adam Grare
@agrare
hey guys, looks like master has been failing for a week on travis is anyone looking at this?
ManageIQ/manageiq-api#662 should fix it thanks @lpichler
Fabien Dupont
@fdupont-redhat
@abellotti do you want any other change on ManageIQ/manageiq-api#656 ?
Alberto Bellotti
@abellotti
lemme see ....
maybe add a spec that exercises the case where that failing order reason "Service ordering via API is not allowed", other than that LGTM!!
Fabien Dupont
@fdupont-redhat
@abellotti I updated an existing test that was a bit weird: https://github.com/ManageIQ/manageiq-api/blob/707c884ed35865cfc4143826fbc13bb7d363bf0f/spec/requests/service_templates_spec.rb#L638-L649. It tested ordering an unorderable service template, so it didn't even check Settings.product.allow_api_service_ordering. Tell me if that's a good move.
Alberto Bellotti
@abellotti
sorry Fabien, I've been tied up, let me take a look now.
Fabien Dupont
@fdupont-redhat
No problem. Thanks.
Adam Grare
@agrare
Hey @thearifismail @djberg96 looks like the -api specs are failing due to the lan transformation validation PR
can one of you take a look?
thearifismail
@thearifismail
Yes, that's what I am seeing now
in my appliance. let me take a look at it.
Adam Grare
@agrare
:+1: thanks!
thearifismail
@thearifismail
@agrare I can't reproduce the problem locally after syncing my repo with upstream master. That said, there IS something wrong because I was encountering similar problem when using the WebUI. I need to step away but Dan is looking at it
Daniel Berger
@djberg96
i was able to reproduce it locally
Adam Grare
@agrare
On an appliance? I thought it was just a spec failure
Daniel Berger
@djberg96
i think he means a local dev instance
just looks like the lan factories need to actually be attached to a switch/host/ems
Daniel Berger
@djberg96
i think these factories are messed up in general
Daniel Berger
@djberg96
looks like the host types are flip-flopped
Adam Grare
@agrare
oh yeah, source_ems is vmware, source_host is redhat
thearifismail
@thearifismail
I am getting at it
Fabien Dupont
@fdupont-redhat
@abellotti I've been distracted too. PR updated.
Fabien Dupont
@fdupont-redhat
@abellotti thanks :+1:
Martin Hradil
@himdel
Would anyone object to changing API logging so that the requests ends up in rails s output?