Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Oct 20 20:40
    miq-bot commented #690
  • Oct 20 17:40
    Fryguy commented #759
  • Oct 20 17:40
    Fryguy labeled #759
  • Oct 20 17:40
    Fryguy unlabeled #759
  • Oct 20 17:40
    Fryguy unlabeled #759
  • Oct 20 17:40
    Fryguy commented #759
  • Oct 20 17:39

    Fryguy on morphy

    Merge pull request #759 from ag… (compare)

  • Oct 20 17:38
    Fryguy commented #759
  • Oct 20 17:38
    Fryguy labeled #759
  • Oct 20 17:38
    Fryguy commented #759
  • Oct 19 21:56

    Fryguy on master

    Remove config/secrets.yml file Merge pull request #761 from ag… (compare)

  • Oct 19 21:56
    Fryguy closed #761
  • Oct 19 21:30
    agrare labeled #761
  • Oct 19 21:30
    agrare labeled #761
  • Oct 19 21:16
    miq-bot commented #761
  • Oct 19 21:16
    miq-bot commented #761
  • Oct 19 21:12
    agrare synchronize #761
  • Oct 19 21:12
    agrare synchronize #761
  • Oct 19 21:11
    miq-bot commented #761
  • Oct 19 21:05
    agrare review_requested #761
Fabien Dupont
@fdupont-redhat
As far as I've been able to dig, it's only use in HostEsx class, in thumbprint_sha1 method.
Adam Grare
@agrare
it looks like for the vcenter version of that class (VcenterThumbPrint) we do exactly that
not sure why the host is different
Fabien Dupont
@fdupont-redhat
Me neither. There must have been a reason. I'm tempted to propose PRs to change that, but I wouldn't want to break anything. Do we have QE functional tests with older versions of vCenter ?
Adam Grare
@agrare
looks like @jerryk55 added that in ManageIQ/manageiq-gems-pending@c4289b1
hopefully he has a good memory
Jerry Keselman
@jerryk55
Well I know it was related to SmartState Analysis
Let me dig
Well. Comments are your friend.
Adam Grare
@agrare
thanks!
Jerry Keselman
@jerryk55
The comment at the above link says it all.
Adam Grare
@agrare
above which link?
Jerry Keselman
@jerryk55
The one you pasted for the PR
Adam Grare
@agrare
the commit message?
Jerry Keselman
@jerryk55
Depending upon whether scan_via_host is enabled or not, a different thumbprint is required.
yes
Adam Grare
@agrare
well it says that it gets it differently but not why
Jerry Keselman
@jerryk55
Because I couldn't get the thumbprint from the vCenter the same way I could get it from the ESX host.
Adam Grare
@agrare
I checked a 6.0 host and the ssl_cert from the server is the same as what you get from that /host/ssl_cert
Fabien Dupont
@fdupont-redhat
It says that it needs a different thumprint, not that the method to get it has to be different...
Jerry Keselman
@jerryk55
The test servers I was working with at that time (4 years) required a different method.
Adam Grare
@agrare
hm okay
Jerry Keselman
@jerryk55
Could it have been the way they were configured? Absolutely.
Fabien Dupont
@fdupont-redhat
Then, functional tests with different version of vCenter is the only way to find out if it would break something, right ?
Adam Grare
@agrare
6.0 is the oldest we have
Also maybe the oldest we support, if this was only needed on older versions maybe we can simplify it
Andrey Menezes
@AndreyMenezes
.0
Fabien Dupont
@fdupont-redhat
@agrare I'll look into it. This will require changes in other repos.
samson7point1
@samson7point1
Are NSX networks not supported in CFME 5.10?
CloudForms doesn't seem to be able to see them at all.
Adam Grare
@agrare
hey @samson7point1 that's not something which is currently supported
samson7point1
@samson7point1
@agrare Is this on the roadmap at all, maybe as a network provider in the future?
Adam Grare
@agrare
@samson7point1 I'd love to support it as a network provider, just time and resources
samson7point1
@samson7point1
@agrare I hear you there
samson7point1
@samson7point1
@agrare I'm still trying to skin this cat and I noticed that the pyvmomi has some support for "opaque networks" - in this case the customer is using NSX-v which is completely external to vCenter. Is it possible for MIQ to support opaque networks (outside the context of NSX specifically).
?
Adam Grare
@agrare
hey we actually had a community user push a PR trying to collect these opaque networks
I think it stalled when trying to link them up to hosts
let me check
samson7point1
@samson7point1
awesome, thanks!
really need an environment to test it in
samson7point1
@samson7point1
Well... I'm not sure how much longer I'll have access to it, but I'm at a customer site with this circumstance right now.
Adam Grare
@agrare
Okay I'll DM you in a little bit, lets see if we can resurect that PR and get some specs recorded to test against
samson7point1
@samson7point1
That would be killer, thanks
To be clear this is actually CloudForms 4.6
samson7point1
@samson7point1
@agrare I don't know if this is related or something else entirely, but when we tested assigning opaque networks to VMs during provisioning, we didn't catch that the NICs were coming up "Disconnected". They were attached to the correct network but not activated. I'm working with the consultants onsite to try to isolate the cause, but I suspect it's at least possible it has something to do with those opaque networks.
Adam Grare
@agrare
can you be more specific about coming up disconnected
samson7point1
@samson7point1
in vCenter the NIC will appear on the VM, but will have a status of "Disconnected".