Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
Akash Bagde
@click2cloud-akash
@agrare anyways but thanks for your quick response :)
Akash Bagde
@click2cloud-akash
@djberg96 as per the documentation I have installed 'ansible-playbook' in RHV manager. Is I need to add 'ansible-playbook' in host machine which I'm trying to add as a conversion host.
@Fryguy Here I'm using container/docker environment.
Satoe Imaishi
@simaishi
@click2cloud-akash ansible was added to container image post ivanchuk-6. It's included only in latest-ivanchuk build right now (will be included in ivanchuk-7)
Akash Bagde
@click2cloud-akash
Thanks @simaishi , I will check with 'latest-ivanchuk' build.
Aniket Pawar
@click2cloud-aniketp
Hi @simaishi , We have added conversion host (using API). It is not working properly with UI. (Tried with cloud-user SSH key)
Now, we are trying to migrate Vmware virtual machine to RHV platform. But, while migration we are facing the error, can you please help us to understand the error cause.
Note: Here we are using jansa-1-alpha1.20200515020205_3266b8e version
image.png
Satoe Imaishi
@simaishi
@click2cloud-aniketp sorry, I'm not familiar with how migration works... but I suggest to try jansa-1-beta1 instead, as things have changed a lot between alpha1 and beta1
Aniket Pawar
@click2cloud-aniketp
Okay @simaishi , Thanks for the quick response.
I will check with jansa-beta1
Fabien Dupont
@fdupont-redhat
@click2cloud-aniketp I think that Ivanchuk has some issues in latest master, as we were introducing new stuff that relied on podman and containers, but was abandonned. What do you call latest-ivanchuk? In http://releases.manageiq.org, I can only see builds from master or actual releases like manageiq-ovirt-ivanchuk-6.qc2.
Jason Frey
@Fryguy
we aren't building ivanchuk nightlies
Satoe Imaishi
@simaishi
we're still building ivanchuk nightly and the images should be available at releases.manageiq.org
^ for appliances. We just don't do nightly for podified images
Jason Frey
@Fryguy
oh nice! I thought we stopped nightlies cause of jansa
Satoe Imaishi
@simaishi
we'll stop once jansa goes GA
Aniket Pawar
@click2cloud-aniketp
@fdupont-redhat , we had pull docker image from docker hub: https://hub.docker.com/r/manageiq/manageiq/tags
But, now we are using jansa-1-alpha1 version
Fabien Dupont
@fdupont-redhat
@click2cloud-aniketp the error you show is about podman, which surprises me, as we reverted the PRs and the jansa branch doesn't use podman to start a conversion
Aniket Pawar
@click2cloud-aniketp
@fdupont-redhat , I am using 6 weeks old image. This is the reason why updated code is not present.
Fabien Dupont
@fdupont-redhat
Oh, indeed this was changed on May 28th. That might explain. Then, I'd recommend using a more recent appliance.
Aniket Pawar
@click2cloud-aniketp
Okay @fdupont-redhat , shall I go for jansa1-beta1 version or latest-jansa?
Can you please tell me which version should I use here?
Fabien Dupont
@fdupont-redhat
Aniket Pawar
@click2cloud-aniketp
@fdupont-redhat Thanks for the input, Now we are using latest-jansa that is nothing but jansa1-beta1.
But, here we are stuck in adding conversion host (Getting 1-failure). Please have a look and share your input.
error.jpg
Fabien Dupont
@fdupont-redhat
Are you using API or UI to add the conversion host?
Aniket Pawar
@click2cloud-aniketp
@fdupont-redhat , We have tried both API and UI. But, getting same error log.
Fabien Dupont
@fdupont-redhat
Can you share your API call please? Normally, you must specify the transport method.
Aniket Pawar
@click2cloud-aniketp
Sure. Please find the below image of API call for adding the conversion host.
image.png
Aniket Pawar
@click2cloud-aniketp
@fdupont-redhat , I have gone through bug ticket for the same type of issue (https://bugzilla.redhat.com/show_bug.cgi?id=1806485)
And, you already solved this issue (ManageIQ/manageiq#19864)
As per our observation, the updated code is not present in the container environment latest-jansa. And, I think this may be a cause for this error.
Jason Frey
@Fryguy
@fdupont-redhat didn't you already revert all that code?
Satoe Imaishi
@simaishi
and revert is ManageIQ/manageiq#20168 for master/jansa
Fabien Dupont
@fdupont-redhat
Indeed. So, it shouldn't be that. The API call looks good.
Aniket Pawar
@click2cloud-aniketp
@fdupont-redhat , we are facing the same error while configuring conversion host using latest docker image. Can you please help us how we can solve this issue?
Fabien Dupont
@fdupont-redhat
We never tested with docker images, only with appliance. Can't you use the appliance? @simaishi what's the difference between appliance and images build process?
Satoe Imaishi
@simaishi
@fdupont-redhat build process is very different, but source code and dependent packages should be same as we now install using RPMs. There are some extra/less packages in each, but I don't think any of those matter for v2v
Aniket Pawar
@click2cloud-aniketp
@fdupont-redhat , @simaishi We have setup appliance based ManageIQ environment. Here we are using ManageIQ Version: jansa-1-beta1.20200602190924_8227a77
To configure the conversion host we have tried with VDDK and SSH approach but, we are getting the same error (Same as docker environment). Find the below log image and please suggest if we are missing anything.
image.png
Mike Turley
@mturley
Trying to get my dev environment back up and running for some debugging, and I'm having some trouble. Anyone know why this might be happening?
mikebookpro:manageiq-ui-classic mturley$ bin/webpack-dev-server
Webpack dev_server configuration not found in /Users/mturley/git/manageiq/plugins/manageiq-ui-classic/config/webpacker.yml.
Please run bundle exec rails webpacker:install to install webpacker

mikebookpro:manageiq-ui-classic mturley$ bundle exec rails webpacker:install
** override_gem("manageiq-v2v", :path=>"/Users/mturley/git/manageiq/plugins/manageiq-v2v") at /Users/mturley/git/manageiq/bundler.d/Gemfile.dev.rb:2
** override_gem("manageiq-v2v", :path=>"/Users/mturley/git/manageiq/plugins/manageiq-v2v") at /Users/mturley/git/manageiq/bundler.d/Gemfile.dev.rb:2
rails aborted!
Don't know how to build task 'webpacker:install' (See the list of available tasks with `rails --tasks`)
Did you mean?  webpacker:verify_install
bin/rails:14:in `require'
bin/rails:14:in `<main>'
(See full trace by running task with --trace)
@Fryguy ^
that file manageiq-ui-classic/config/webpacker.yml does exist. I pulled master of everything and ran a bin/update
Jason Frey
@Fryguy
not sure... maybe @himdel knows?
@mturley did you try bin/update?
Martin Hradil
@himdel
You should never run webpacker:install, it will probably rewrite random parts of our config
but, once you undo that (edit: it failed, so no need to undo), I think all you need is up to date manageiq-ui-classic and bin/update, yes
(Also, nobody maintains webpack-dev-server, I do not know if it works. Try bin/webpack --watch instead.)
ManageIQ/manageiq-ui-classic#7238 is probably the last PR to touch webpack-dev-server config
Martin Hradil
@himdel
it's probably that bin/webpack-dev-server still expects to have that config and fails,
so you'd have to move the ASSET_HOST logic to the javascript parts too, or try running yarn run webpack-dev-server --config config/webpack/development.js directly
or stick to bin/webpack which does get regularly tested :)
Mike Turley
@mturley
Thanks, I did end up just running env NODE_ENV=development ./node_modules/.bin/webpack-dev-server --config config/webpack/development.js and it worked fine. Wasn't aware of the --watch arg for bin/webpack, good to know.
Martin Hradil
@himdel
great, so maybe we can just remove the asset host bit and make it work :) yeah, watch is usually fine :) (just have to restart it after yarn)
Mike Turley
@mturley
Does anyone have time to review a small PR for v2v? I've been away from the project for long enough, my usual contacts aren't available. ManageIQ/manageiq-v2v#1142