Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Nov 26 21:59
    RickStrahl commented #850
  • Nov 26 21:58
    RickStrahl commented #850
  • Nov 26 21:49
    RickStrahl commented #852
  • Nov 26 21:48
    RickStrahl commented #852
  • Nov 26 21:45
    RickStrahl commented #852
  • Nov 26 20:56
    RickStrahl commented #880
  • Nov 25 14:43
    realB12 commented #884
  • Nov 24 05:18

    RickStrahl on 2.2

    (compare)

  • Nov 23 22:02
    CADbloke commented #852
  • Nov 23 21:05
    RickStrahl commented #880
  • Nov 23 19:46

    RickStrahl on main

    Update Changelog.md (compare)

  • Nov 18 20:28
    RickStrahl closed #885
  • Nov 18 12:59
    posinautinc commented #885
  • Nov 18 06:25

    RickStrahl on main

    Update README.md (compare)

  • Nov 17 23:49

    RickStrahl on main

    Update Changelog.md (compare)

  • Nov 17 23:09
    RickStrahl commented #885
  • Nov 17 22:29
    RickStrahl commented #885
  • Nov 17 21:55
    RickStrahl commented #885
  • Nov 17 01:23
    posinautinc commented #885
  • Nov 17 01:20
    posinautinc commented #885
Rick Strahl
@RickStrahl
I'm not sure if I want to go down the path of building a new 'editor' that treats folders like projects for the main editor. That adds a lot of complexity. Maybe in the future. But again an Addin can easily handle that with keeping a base folder and it's own set of configuration settings for each 'project'.
There have been a bunch of requests for adding folder display support. I think it's something that I might do a little later for a 2.0 version, but for now I want the main editor to focus on core editing related stuff.
Mordechai Zuber
@M-Zuber
Makes sense
As far as the wyam add in, I spoke to a number of other wyam users, and the consensus was that a more generic command line launcher makes more sense for an initial effore, so I will open an issue for that
Mordechai Zuber
@M-Zuber
Another thing - where is the best place to understand how the existing infrastuctre for publishing to a blog works?
Rick Strahl
@RickStrahl
What do you want to know? How it works, or how to do it?
The implementation is in an addin - it's not a part of the core Markdown Monster editor.
For how it works there's info in the docs: https://markdownmonster.west-wind.com/docs/_4nb0ser9f.htm
Although that probably needs an update - still works the same but the screen shots are a little out of date :-)
Paulo Morgado
@paulomorgado
Hi all! What are the available themes? I need a light them.
doh! there's a selection at the bottom. no need to manually edit the settings.
Larry Lai
@lai3d
Risk is awesome
Rick Strahl
@RickStrahl
Ok...
Mehul Harry
@mehulharry_twitter
Hey @RickStrahl what info can I provide for that issue?
Rick Strahl
@RickStrahl
What version are you using?
Mehul Harry
@mehulharry_twitter
1.6.2
Rick Strahl
@RickStrahl
Ok...
I think the issue if there are no images open initially the option is disabled and the bindings are not refreshing.
So we can try this:
Do you have UseSingleWindow: true in config?
Mehul Harry
@mehulharry_twitter
yes
Rick Strahl
@RickStrahl
Ok - if you shut down with a document open that document should open back up when you restart yes?
Mehul Harry
@mehulharry_twitter
yes
Rick Strahl
@RickStrahl
Still not seeing the option enabled then?
Mehul Harry
@mehulharry_twitter
unfortunately no.
Rick Strahl
@RickStrahl
Hmmmm....
Mehul Harry
@mehulharry_twitter
"WebBrowserPreviewExecutable": "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe",
Rick Strahl
@RickStrahl
And that's valid?
Mehul Harry
@mehulharry_twitter
checking
yes
how can I launch it in Edge instead?
I was thinking that changing that setting, it might re-enable that menu option?
Rick Strahl
@RickStrahl
Leaving it blank uses a different path, but I don't think that's the actual problem - the problem is the menu binding is not refreshing as it should. Normally, opening a window EXPLICITLY forces the binding to be refreshed (due to this funky behavior which I notice on my end is work).
You can try leaving the executable blank.
Mehul Harry
@mehulharry_twitter
it's blank now but still disabled
Rick Strahl
@RickStrahl
You do have to restart for that to have an effect.
Hang on I'm going to check the conditions there with the refresh.
Mehul Harry
@mehulharry_twitter
k
Rick Strahl
@RickStrahl
Ouh...
I think I see the problem :-)
You have your preview browser not visible?
If not make that visible and the activate another window and back.
Mehul Harry
@mehulharry_twitter
Chrome? it's open, visible, and active
Or the built in one inside MM?
Rick Strahl
@RickStrahl
No - the preview in MM.
Mehul Harry
@mehulharry_twitter
even with that enabled, which it is now, it's still disabled menu option
Rick Strahl
@RickStrahl
Can you restart with it on?
There's definitely a bug there, you may be seeing something slightly different than what I see here.
Rick Strahl
@RickStrahl
So the bug is that it didn't work with the Preview off because it's looking to just display the last rendered HTML output file. I fixed that so that the file always gets re-rendered.
Thanks for pointing me into that direction.