Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Jan 24 23:10

    RickStrahl on main

    Update Changelog.md (compare)

  • Jan 24 22:03
    RickStrahl closed #904
  • Jan 24 22:02
    RickStrahl commented #904
  • Jan 24 22:02
    RickStrahl commented #904
  • Jan 24 21:58
    RickStrahl commented #904
  • Jan 24 21:57
    RickStrahl assigned #904
  • Jan 24 20:52
    RickStrahl closed #905
  • Jan 24 20:52
    RickStrahl commented #905
  • Jan 24 07:46
    jbridgy commented #905
  • Jan 24 05:37
    RickStrahl commented #905
  • Jan 24 05:01
    RickStrahl closed #902
  • Jan 24 05:00
    RickStrahl labeled #904
  • Jan 24 05:00
    RickStrahl commented #905
  • Jan 24 04:59
    RickStrahl labeled #905
  • Jan 24 04:58
    RickStrahl assigned #905
  • Jan 24 00:11
    jbridgy opened #905
  • Jan 23 23:43
    jbridgy opened #904
  • Jan 23 19:47
    RickStrahl commented #901
  • Jan 23 19:46
    RickStrahl closed #901
  • Jan 21 08:29
    jbridgy commented #901
Rick Strahl
@RickStrahl
The implementation is in an addin - it's not a part of the core Markdown Monster editor.
For how it works there's info in the docs: https://markdownmonster.west-wind.com/docs/_4nb0ser9f.htm
Although that probably needs an update - still works the same but the screen shots are a little out of date :-)
Paulo Morgado
@paulomorgado
Hi all! What are the available themes? I need a light them.
doh! there's a selection at the bottom. no need to manually edit the settings.
Larry Lai
@lai3d
Risk is awesome
Rick Strahl
@RickStrahl
Ok...
Mehul Harry
@mehulharry_twitter
Hey @RickStrahl what info can I provide for that issue?
Rick Strahl
@RickStrahl
What version are you using?
Mehul Harry
@mehulharry_twitter
1.6.2
Rick Strahl
@RickStrahl
Ok...
I think the issue if there are no images open initially the option is disabled and the bindings are not refreshing.
So we can try this:
Do you have UseSingleWindow: true in config?
Mehul Harry
@mehulharry_twitter
yes
Rick Strahl
@RickStrahl
Ok - if you shut down with a document open that document should open back up when you restart yes?
Mehul Harry
@mehulharry_twitter
yes
Rick Strahl
@RickStrahl
Still not seeing the option enabled then?
Mehul Harry
@mehulharry_twitter
unfortunately no.
Rick Strahl
@RickStrahl
Hmmmm....
Mehul Harry
@mehulharry_twitter
"WebBrowserPreviewExecutable": "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe",
Rick Strahl
@RickStrahl
And that's valid?
Mehul Harry
@mehulharry_twitter
checking
yes
how can I launch it in Edge instead?
I was thinking that changing that setting, it might re-enable that menu option?
Rick Strahl
@RickStrahl
Leaving it blank uses a different path, but I don't think that's the actual problem - the problem is the menu binding is not refreshing as it should. Normally, opening a window EXPLICITLY forces the binding to be refreshed (due to this funky behavior which I notice on my end is work).
You can try leaving the executable blank.
Mehul Harry
@mehulharry_twitter
it's blank now but still disabled
Rick Strahl
@RickStrahl
You do have to restart for that to have an effect.
Hang on I'm going to check the conditions there with the refresh.
Mehul Harry
@mehulharry_twitter
k
Rick Strahl
@RickStrahl
Ouh...
I think I see the problem :-)
You have your preview browser not visible?
If not make that visible and the activate another window and back.
Mehul Harry
@mehulharry_twitter
Chrome? it's open, visible, and active
Or the built in one inside MM?
Rick Strahl
@RickStrahl
No - the preview in MM.
Mehul Harry
@mehulharry_twitter
even with that enabled, which it is now, it's still disabled menu option
Rick Strahl
@RickStrahl
Can you restart with it on?
There's definitely a bug there, you may be seeing something slightly different than what I see here.
Rick Strahl
@RickStrahl
So the bug is that it didn't work with the Preview off because it's looking to just display the last rendered HTML output file. I fixed that so that the file always gets re-rendered.
Thanks for pointing me into that direction.
But... that still doesn't explain why you're options are disabled.
Mehul Harry
@mehulharry_twitter
I'm using the portable version
Rick Strahl
@RickStrahl
Enabled status is controlled by thisIsEnabled="{Binding IsEditorActive}" and so somehow I suspect that flag is not set properly, but I'm not sure how.
I don't think that should make a difference.
Rick Strahl
@RickStrahl
I'm looking at this and I don't see how this could not be working unfortunately. There's some 'magic' around this because the bindings have to be explicitly refreshed, but I tried with a bunch of different scenarios here and it doesn't fail with disabled menu options for me.
I did add a fix for the execution bit so it now will work when the preview is not active. Doesn't address the disabled state however.