Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Dec 01 01:37
    kaesinol closed #887
  • Dec 01 01:37
    kaesinol commented #887
  • Dec 01 01:21
    RickStrahl commented #887
  • Dec 01 01:08
    kaesinol opened #887
  • Nov 30 21:35
    RickStrahl commented #886
  • Nov 30 21:34
    RickStrahl commented #886
  • Nov 30 12:09
    realB12 commented #850
  • Nov 30 12:09
    realB12 closed #850
  • Nov 30 07:53
    realB12 opened #886
  • Nov 30 07:50
    realB12 commented #880
  • Nov 30 07:48
    realB12 commented #880
  • Nov 30 07:46
    realB12 commented #880
  • Nov 30 07:44
    realB12 commented #880
  • Nov 26 21:59
    RickStrahl commented #850
  • Nov 26 21:58
    RickStrahl commented #850
  • Nov 26 21:49
    RickStrahl commented #852
  • Nov 26 21:48
    RickStrahl commented #852
  • Nov 26 21:45
    RickStrahl commented #852
  • Nov 26 20:56
    RickStrahl commented #880
  • Nov 25 14:43
    realB12 commented #884
Rick Strahl
@RickStrahl
What version are you using?
Mehul Harry
@mehulharry_twitter
1.6.2
Rick Strahl
@RickStrahl
Ok...
I think the issue if there are no images open initially the option is disabled and the bindings are not refreshing.
So we can try this:
Do you have UseSingleWindow: true in config?
Mehul Harry
@mehulharry_twitter
yes
Rick Strahl
@RickStrahl
Ok - if you shut down with a document open that document should open back up when you restart yes?
Mehul Harry
@mehulharry_twitter
yes
Rick Strahl
@RickStrahl
Still not seeing the option enabled then?
Mehul Harry
@mehulharry_twitter
unfortunately no.
Rick Strahl
@RickStrahl
Hmmmm....
Mehul Harry
@mehulharry_twitter
"WebBrowserPreviewExecutable": "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe",
Rick Strahl
@RickStrahl
And that's valid?
Mehul Harry
@mehulharry_twitter
checking
yes
how can I launch it in Edge instead?
I was thinking that changing that setting, it might re-enable that menu option?
Rick Strahl
@RickStrahl
Leaving it blank uses a different path, but I don't think that's the actual problem - the problem is the menu binding is not refreshing as it should. Normally, opening a window EXPLICITLY forces the binding to be refreshed (due to this funky behavior which I notice on my end is work).
You can try leaving the executable blank.
Mehul Harry
@mehulharry_twitter
it's blank now but still disabled
Rick Strahl
@RickStrahl
You do have to restart for that to have an effect.
Hang on I'm going to check the conditions there with the refresh.
Mehul Harry
@mehulharry_twitter
k
Rick Strahl
@RickStrahl
Ouh...
I think I see the problem :-)
You have your preview browser not visible?
If not make that visible and the activate another window and back.
Mehul Harry
@mehulharry_twitter
Chrome? it's open, visible, and active
Or the built in one inside MM?
Rick Strahl
@RickStrahl
No - the preview in MM.
Mehul Harry
@mehulharry_twitter
even with that enabled, which it is now, it's still disabled menu option
Rick Strahl
@RickStrahl
Can you restart with it on?
There's definitely a bug there, you may be seeing something slightly different than what I see here.
Rick Strahl
@RickStrahl
So the bug is that it didn't work with the Preview off because it's looking to just display the last rendered HTML output file. I fixed that so that the file always gets re-rendered.
Thanks for pointing me into that direction.
But... that still doesn't explain why you're options are disabled.
Mehul Harry
@mehulharry_twitter
I'm using the portable version
Rick Strahl
@RickStrahl
Enabled status is controlled by thisIsEnabled="{Binding IsEditorActive}" and so somehow I suspect that flag is not set properly, but I'm not sure how.
I don't think that should make a difference.
Rick Strahl
@RickStrahl
I'm looking at this and I don't see how this could not be working unfortunately. There's some 'magic' around this because the bindings have to be explicitly refreshed, but I tried with a bunch of different scenarios here and it doesn't fail with disabled menu options for me.
I did add a fix for the execution bit so it now will work when the preview is not active. Doesn't address the disabled state however.
I guess for the moment all I can say is wait for the next update and see if that's any better. Sorry.
You can try the full version instead of the portable one (which now runs non-admin installs anyway so there's really no great reason to run the portable install)
But I don't think that that is actually the problem.
Mehul Harry
@mehulharry_twitter
Ok, I'll test the next update. thanks for looking into it
hmm, I downladed the regular install but it still brings up my version that I run from dropbox
nm, it's running from appdata and still loading docs like the portable version. Either way, good news, it's enabled that option now.
Mehul Harry
@mehulharry_twitter
Thanks again!
Rick Strahl
@RickStrahl
If you use the manual install you'll need to run markdownmonster -uninstall to remove the registry bindings to .md files, paths etc. The uninstaller normally handles this.