by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Arthur Ma
    @ArthurMa1978
    IoTCoast2Coast is awesome! thanks @SQLDataSide
    Renhe Li
    @lirenhe
    @lowndesc , you could follow https://github.com/microsoft/vscode-iot-workbench#contributing to contribute new example for IoT Devkit. You could also check the existing contributed example: https://github.com/jimbobbennett/InternetConnectedFan/
    Nik - Shahriar Nikkhah
    @SQLDataSide
    @lowndesc you can start by sharing in this page if you like
    @ArthurMa1978 Thank you
    Xavier Mignot
    @xaviermignot
    Hello, I have followed the MSBuild announcements and would like to play with the IoT plug and play feature.
    I know that the MXCHIP can be easily integrated in IoT Central, but I would like to test the code-generating feature presented at Build this month.
    Can I do this with the MXCHIP ?
    According to the Azure Iot Solutions catalog it is not "IoT Plug and Play certified" (link here) but there is a new ESP32 board pictured among the certified devices. Maybe I should get one of these new boards...
    Arthur Ma
    @ArthurMa1978
    @xaviermignot PnP is announced at //BUILD, but currently it's still private preview and only can share with under-NDA customers
    MXChip is definite the preferred device, and it's the only MCU device we used for service and tooling development now
    Xavier Mignot
    @xaviermignot
    ok thanks @ArthurMa1978, I'll wait for the public preview then :)
    Charlie
    @misterfoo
    Quick question from a new guy: I'm working with an MXChip and a very slightly modified version of the firmware from IoT Central, and finding that the board is randomly rebooting itself (presumably crashing?) every 30-60 seconds. Edits to the code were to change the duration of the telemetry uploads and to add a few Serial.print statements with no formatting (i.e. no opportunity for format bugs). I can see the output from the Serial monitor but so far I can't figure out what's causing the reboots. Can anyone point me to troubleshooting resources or techniques? Is there any way to get a crash dump or get the debugger to break in when the crash happens?
    Arthur Ma
    @ArthurMa1978
    @misterfoo does the default firmware work well?
    Jani Turunen
    @Janisku7
    I got latest: N/A to my mx ship
    Dan Shoubridge
    @danshoubs
    I would like to make a direct method call to the device (DeviceMethodCallback)
    how can I display the payload that is received on the device? I can see a payload variable, but not sure how to use it. (I know zero c++, which doesn't help)
    I tried Screen.print(1, *payload, true);
    Xavier Mignot
    @xaviermignot
    @danshoubs have you tried Screen.print(1, payload, true); ? (without the *)
    Dan Shoubridge
    @danshoubs
    @xaviermignot yes, tried a few combinations, without the *, I get:
     initializing argument 2 of 'virtual int OLEDDisplay::print(unsigned int, const char*, bool)'
         virtual int print(unsigned int line, const char *s, bool wrap = false);
                     ^`
    ideally, I want to convert it from json to an struct and output specific values, but just displaying whatever raw text I send to it would be a good start.
    Xavier Mignot
    @xaviermignot
    @danshoubs if it's just for debugging purpose I'll suggest to use Serial.print and from VS Code see what is sent to the Serial Monitor.
    Xavier Mignot
    @xaviermignot
    Or if you want to stick with the screen, I have looked into the samples for some code who display variables on the screen, I have found this in the translator sample:
    char temp[33];
    int end = min(length, sizeof(temp) - 1);
    memcpy(temp, text, end);
    temp[end] = '\0';
    Screen.print(2, temp, true);
    And that in the Shake for a tweet sample:
    Screen.print(1, &msgBody[msgStart], true);
    Where msgBody is a char array and msgStart is an int
    Dan Shoubridge
    @danshoubs
    @xaviermignot that was a compile error, rather than a log whilst it was running, but I am logging in the way you suggest to help me, e.g. LogInfo("Message recieved from IoTHub");
    I managed to get the following working now, but thanks anyway:
    ...
    JSON_Value *root_value=NULL;
        root_value = json_parse_string((const char*)payload);
        JSON_Object *root_object;
        if(json_value_get_type(root_value) == JSONObject)
        {
            root_object = json_value_get_object(root_value);
            const char *message = json_object_get_string(root_object, "message");
    ...
    Sam Listopad
    @samlii
    Hmm does anyone know about the free MXChip DevKit, I got an email about one but only see links to purchase from Seeed
    rbeyea
    @rbeyea
    @samlii same here. got an email that says "Sign up for a free IoT MxChip DevKit and start simplifying your processes." but I see no where to sign up. Just the link to purchase a kit.
    Liya Du
    @liydu
    @samlii , @rbeyea , can we know the details about that email? As our team has not sent such email recently, we want to learn more about the situation here. Thanks.
    ashtez
    @ashtez
    Hello everybody, how are you doing ?
    Do you know why this sketch https://github.com/microsoft/vscode-iot-workbench/blob/master/docs/iot-devkit/devkit-mqtt-client.md gives me gibberish instead of a properly formated string ? For exemple : "üs 5m m m m m m m J"
    ashtez
    @ashtez
    ok, problem resolved, the default code is garbage, use this one : https://github.com/eclipse/paho.mqtt.embedded-c/blob/master/MQTTClient/samples/arduino/Hello/Hello.ino
    &ladeak
    @ladeak87_twitter
    When I connect the devkit to a
    When I connect the devkit to a battery bank, the programming led starts blinking. What does that mean?
    Renhe Li
    @lirenhe
    @ladeak87_twitter , The programming led blinks when uploading firmware into devkit. Did this happen when you connect it to your computer?
    @ashtez , I checked the devkit-mqtt-client and did not see any strange string. Could you share the full output? The Baud Rate should be set to 115200.
    &ladeak
    @ladeak87_twitter
    It blinks much slower say 1/sec
    Nik - Shahriar Nikkhah
    @SQLDataSide
    anyone have worked on Azure Speaker Recognition?, i need help for a demo
    Renhe Li
    @lirenhe
    @ladeak87_twitter could you try to upgrade our firmware first? https://microsoft.github.io/azure-iot-developer-kit/docs/firmware-upgrading/ If that doesn't help, this could be a hardware issue and please contact the seller.
    Nik - Shahriar Nikkhah
    @SQLDataSide
    Anyone knows how to work with Azure Speaker Services? I need some Demos and i cant get the one provided my MS working.
    raghuureddy
    @raghuureddy
    Hello, I have followed the iot getting started and after following all the steps, getting the below errors, please suggest..
    2019-06-13 20:15:43 INFO: >>>Connection status: disconnected
    2019-06-13 20:15:43 ERROR: socketio_mbed_os5.c (ln 176): Socketio_Failure: underlying IO error -3004.
    2019-06-13 20:15:43 INFO: >>>Connection status: disconnected
    2019-06-13 20:15:48 INFO: >>>Re-connect.
    2019-06-13 20:15:48 INFO: Iothub Version: 1.2.14
    2019-06-13 20:15:43 INFO: >>>Connection status: disconnected 2019-06-13 20:15:43 ERROR: socketio_mbed_os5.c (ln 176): Socketio_Failure: underlying IO error -3004. 2019-06-13 20:15:43 INFO: >>>Connection status: disconnected 2019-06-13 20:15:48 INFO: >>>Re-connect. 2019-06-13 20:15:48 INFO: Iothub Version: 1.2.14
    sandy
    @sandeepkumar-sgnr
    Hello, is it possible to use ESP32 Web-socket server library into IOT-Dev-Kit ? if not , then anyone having idea how can we create web-socket server library for IOT Dev Kit ?
    mkbouvet
    @mkbouvet
    How can I get PlatformIO to cooperate with IoT projects? When I try to debug the "DevKitTranslator" example project it breaks completely
    Renhe Li
    @lirenhe
    @raghuureddy , from the error message, it seems the network is not stable that caused connection failure. Could you try another network?
    Renhe Li
    @lirenhe
    @sandeepkumar-sgnr , on IoT Devkit, we only have web socket client. https://microsoft.github.io/azure-iot-developer-kit/docs/apis/websocket-client/ . I am not sure whether existing server lib would work.
    @mkbouvet , you could directly use the debug feature provided by Vscode Arduino Extension. As I know, debug code on IoT Devkit is supported.
    sandy
    @sandeepkumar-sgnr
    @lirenhe Thanks for the reply, i have tried the existing server lib but it was not working.
    Allan Pead
    @apead
    Hi
    anyone able to create an iot central application lately?
    Renhe Li
    @lirenhe
    @apead , could you provide more detail about the problem you face?
    Allan Pead
    @apead
    @lirenhe I sorted it out : combination of website not working properly and subscription without the iotcentral provider registered
    Matha Goram
    @baqwas
    Hello, I had to rebuild my Ubuntu platform and reinstall VS Code. Arduino Board Manager no longer offers AZ3166 as a selection but when I plug in the board the status bar detects it and the STMicroelectronics driver is installed. Is there a manual method that can be applied to let Board Manager offer AZ3166 as a selection. UNO and MKR1000 work fine with "Hello Blink" tests. What have I not installed? The AZ3166 connects to IoT Hub presently when plugged in but I would like to conduct local Arduino tests. Thanks.