Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Nik - Shahriar Nikkhah
    @SQLDataSide
    I am having problems wit connecting MXCHip to DPS , getting the error on the MXCHIP.....DPS FAILED on the screen
    Anyone have set MXCHIP with DPS?
    JerryYang
    @JerryYangKai
    @RakeLund Hi, RackLund. I think this problem may caused by wi-fi's weak signal. Devkit has disconnected from wi-fi then printed this log.
    JerryYang
    @JerryYangKai
    @SQLDataSide Hi, Shahriar Nikkhah. You can follow this tutorials https://docs.microsoft.com/en-us/samples/azure-samples/mxchip-iot-devkit-dps/sample/. I suggest do not leave registrationId as blank in STEP 'Update the Global Device Endpoint and ID Scope in device code' . And in STEP 'Generate X.509 certificate', follow '1.Specified the registrationId' and input same registrationId.
    JerryYang
    @JerryYangKai
    @SQLDataSide And I strongly suggest using version 1.6.5 to test this sample.
    Usman UrRehman Ahmed
    @usman_ur_rehman_twitter
    Can someone help me understand if MX3166 has same level of security built into it as MT3620 or does it belong to Azure Sphere and Iot Edge
    Vijay
    @VQuery
    Hi Folks
    Shall i ask query regarding Azure Function App here ?
    Nik - Shahriar Nikkhah
    @SQLDataSide
    thanks for the help i got the ball rolling
    got it fixed
    Nik - Shahriar Nikkhah
    @SQLDataSide
    hi i am looking for a code that i can use in a MXCHIP DEV KIT, it needs to

    1- Must use WIFI
    2- Must use Azure Function call
    3- The Azure function will insert data into a blob or SQL
    4- when setting up the WIFI parameter i want to be able to pass the Functions parameter as well (.bin file)
    5- mxchip will pass something simple like temp.
    6- i want my
    .bin file be in a way so that i do not need VS or VSCode to be installed on my machine

    Can someone help ????????, Thanks

    Nik - Shahriar Nikkhah
    @SQLDataSide
    @jakubsvobodacz wilde guess, i had something similer and i found out that i was not using the MXChip cable from the box i changes the cable and it worked.
    and about the link it is working perfectly, i am sure that it is just a simple basic step that youmight be missing
    brodbor
    @brodbor
    I just finished my pet project - inventory replenishment system with Proximity Sensor, ML, and Sitecore. I can share code if anyone is interested: https://youtu.be/19yxF6Uo9z4 . Let me know.
    Mostafa Rafiur Wasib
    @mrw-soumik
    Hey
    Can I know how I can use the MXchip accelerometer for tilt degree detection?
    Maciej Skuratowski
    @mskuratowski

    Hi guys, I'm trying to deploy Azure MXChip IoT DevKit Translator (https://docs.microsoft.com/en-us/samples/azure-samples/mxchip-iot-devkit-translator/sample/) but when I try to Azure IoT Device Workbench: Configure Device Settings... > Config Device Connection String. Select Select IoT Hub Device Connection String I get Writing to COM port (GetOverlappedResult): operation aborted

    Do you know how can I investigate it and fix it? To be honest, I don't know where even I can check the logs

    Maciej Skuratowski
    @mskuratowski
    Nevermind ;). Restart VS code helped ;)
    laurentg91
    @laurentg91_twitter
    Hello, for an unknown reason, the code i was using for 2 years for my MXChip, seems to not be valid anymore:
    Stupid error like cannot open source file "windows.h" (dependency of "FATFileSystem.h")C/C++(1696)
    appears. Any idea on how to fix it ? [ if was working a few weeks ago, and i changed nothing , can it be a package update that messed it up ?
    JerryYang
    @JerryYangKai
    @laurentg91_twitter Hi, can you give some more information about your problem? For example, the error log when you uploading?
    Stephen M Morris
    @StephenMMorris-PB
    Hi. Brand new to this community. I'm trying to connect a Ultimate GPS Breakout v3 to the MXChip board. I noticed that the MXChip has a 3v out and the GPS has a VIN rated at 5v. I'm a newbie with hardware, so I'm not sure I can connect these two boards. Anyone use this GPS board with MXChip? Can you give me the pin connections between the two?
    SumonBormon-007
    @SumonBormon-007
    Hello
    DevScienceScope
    @DevScienceScope
    @ArthurMa1978 in April 2018 you solved a problem for me with building.bin files that cen be put directley onto the dev kits. GenerarteBinFile. I know have working code that incorporates OTA. When i try and generate the bin file now it cant install the update. Am i missing somehting simple that i need to include to get this to work with OTA
    Usman UrRehman Ahmed
    @usman_ur_rehman_twitter
    Using "iotc-devkit-1.9.11-preview.bin" firmware, I can't seem to find a capability model that lists all the sensor properties or allows executes commands in Iot Central. I've tried to expand the capability set provided at official site, https://catalog.azureiotsolutions.com/details?title=MXChip-IoT-DevKit but no other telemetry other than Pressure, Humidity or Pressure gets loaded or any command executes.
    Usman UrRehman Ahmed
    @usman_ur_rehman_twitter
    So apparently the latest build of firmware is pushing telemetry of Gyroscope, magnetometer and accelerometer as nested object "magnetometer":
    {"x":-154,"y":-91,"z":-32} whereas the Dev Kit capability model doesn't support telemetry exposed as nested JSON. If it does, an example would be helpful.
    Usman UrRehman Ahmed
    @usman_ur_rehman_twitter
    Just today, without changing anything locally, the commands have started working back on the Iot Central site as well as the Shared Signature tokens are also yielding positive response via Rest API. (y)
    JerryYang
    @JerryYangKai
    @usman_ur_rehman_twitter The Iot Central doesnot support these type of nested object like {"x":-154,"y":-91,"z":-32} . I have raised an issue to them and it will be supported in the future. Until then I will update the capability model.
    sanjaydatasciencedojo
    @sanjaydatasciencedojo
    @JerryYangKai How do I connect devkit-firmware-1.6.5.bin with IOThub? I want to send all the sensor data to IoThub but IoT GetStarted is very limited.
    JerryYang
    @JerryYangKai
    @sanjaydatasciencedojo IoT GetStarted just showed how to connect devkit with hub. I think you can extend it. API's link https://microsoft.github.io/azure-iot-developer-kit/docs/apis/hts221/.
    @sanjaydatasciencedojo Some tips. Editing readMessage() and adding some new functions like readTemperature() in utility.cpp to add new sensor.
    sanjaydatasciencedojo
    @sanjaydatasciencedojo
    @JerryYangKai Thank you for your help.
    How is binary generated for devkit-firmware-1.6.5.bin?
    JerryYang
    @JerryYangKai
    @sanjaydatasciencedojo You can refer to this repo https://github.com/VSChina/devkit-mbedos5-getstarted.
    sanjaydatasciencedojo
    @sanjaydatasciencedojo
    @JerryYangKai Thank you
    Usman UrRehman Ahmed
    @usman_ur_rehman_twitter
    @JerryYangKai Thank You. The Commands at IoT Central are very intermittent in behavior. Is it like you've an internal access to their folks or can you suggest me where to report so?
    @brodbor This seems promising for demo purposes. I'll make sure to pay proper attribution. Link to source code is gravely appreciated and consider making it available at the Projects catalog.
    JerryYang
    @JerryYangKai
    @usman_ur_rehman_twitter You can add your suggestions here https://feedback.azure.com/forums/911455-azure-iot-central.
    Parth Kaloliya
    @Parth2412
    Hi Everyone, anyone familiar with blockchain workbench?
    gmwill92
    @gmwill92
    Hello,
    I'm following the tutorial Connect a devkit device to Azure IoT Central, https://docs.microsoft.com/en-us/azure/iot-central/core/howto-connect-devkit
    The devkit isn't sending any data, the screen says IoT DevKit, PnP Enabled Running 192.168.1.81
    JerryYang
    @JerryYangKai
    @gmwill92 Hi, you can follow this link https://docs.microsoft.com/en-us/samples/azure-samples/mxchip-iot-devkit-pnp/sample/ to connect to Azure IoT Central. Make sure add an IoT Central application created from the Preview application template. If you have any questions, show your output log in serrial monitor and maybe I can help you.
    Rick Peters
    @rickpeters

    Hi, hopefully a simple question. I just tried the IOT DevKit for the first time, following the getting started example using VSCode. Everything went smooth up until running the code on the IOT device. The display is stuck on Running... -> IoT Hub
    I checked that the device is configured in Azure and it is. If I try to monitor using serial communication (the powerplug in vscode) I get the following error message:

    [Starting] Opening the serial port - /dev/cu.usbmodem143203
    [Error]Error: Error Resource temporarily unavailable Cannot lock port

    Also when I monitor communication to endpoints on Azure there is no traffic. I would expect that the blue led for Azure connection should light on the IOT device but it doesn't
    I should mention that I try to follow the tutorial on a macbook. All software is at current version (VSCode, IOT extension, Arduino extension and Arduino IDE

    Ivan Jobs
    @IvanJobs
    @rickpeters Hi Rick, I encountered the same problem with the getting started example like you a few days ago. The screen of the devkit board showed Running...-> IoT Hub, but didn't go to the next expecting screen of message counts. For me, I just ignored this and continued with the guide using arduino IDE to upload example project code onto the devkit board, and luckily enough I saw the expecting green of message counts. So you can try it . For the specific problem you mentioned, I guess maybe the newest firmware just don't work as we expect.
    jyotendra sharma
    @jyotendra
    Hello guys, I want to understand once one build some solution around Azure DevKit - how they port it in production from hardware perspective. I mean an embedded device should contain only specific things and all the sensors on DevKit might not be all needed in every application. How do you go about making an hardware port then ?
    Ivan Jobs
    @IvanJobs
    @jyotendra As I know, the porting part should be implemented by yourself. You can treat porting as a common problem, and porting is all about adaptation. You need to implement the APIs developed with Azure DevKit with the lower APIs provided by your hardware. If your production hardware is some standard in industry compatible, that would save a lot of time. For the "sensors not be all needed" part, I think this is a problem you should make your own decisions.
    Maciej Skuratowski
    @mskuratowski
    Hi Guys, I'd like to use a camera and MXChip. Is it possible to somehow add a physical camera to a device and then use it?
    jyotendra sharma
    @jyotendra
    Thanks @IvanJobs that was helpful. That matches my thought process and after reading your comment I have decided to use top-down approach, beginning from choosing hardware that could be ported easily and then going with developer kit. ST Electronic's boards seems compatible with arduino, like iot-dev-kit - I think will give it a try first.
    Ivan Jobs
    @IvanJobs
    @jyotendra You're welcome and totally agree with u.
    Nicolas cumu
    @NicolasCumu_twitter
    Hello. I've a question about the AZ3166, what is the reference of the microphone ? I want to find the sensor datasheet, thanks