Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Aug 03 07:56
    nollied opened #925
  • Aug 02 16:08

    microsoft-github-policy-service[bot] on GitHubPolicyService

    (compare)

  • Aug 02 16:08

    microsoft-github-policy-service[bot] on GitHubPolicyService

    Microsoft mandatory file (compare)

  • Aug 01 18:41
    akshaykr removed as member
  • Jul 16 21:48
    itzdrli closed #915
  • Jul 13 09:47
    StackoverflowEnjoyer closed #920
  • Jul 11 10:49
    jeasinema commented #844
  • Jul 07 05:07
    allarassemjonathan commented #922
  • Jul 07 04:59
    allarassemjonathan commented #911
  • Jul 07 04:55
    allarassemjonathan commented #911
  • Jul 07 04:51
    allarassemjonathan commented #911
  • Jun 18 13:52
    psuci opened #924
  • May 16 13:02
    melorian94 commented #275
  • May 16 12:40
    melorian94 commented #275
  • May 07 01:39
    MirzaSikander removed as member
  • May 06 14:27
    nmandhana commented #600
  • Apr 24 04:16
    mhauskn removed as member
  • Mar 20 11:03
    addis2123 commented #920
  • Mar 20 10:59
    addis2123 commented #921
  • Mar 20 10:57
    addis2123 commented #922
Lennart
@biggzlar

Was trying to run launchClient.bat on Windows 10 and encountered this error. Any way to fix it?

Where:
Build file 'C:...\Desktop\malmo-master\Minecraft\build.gradle' line: 13

What went wrong:
An exception occurred applying plugin request [id: 'net.minecraftforge.gradle.forge', version: '2.0.1']
Failed to apply plugin [id 'net.minecraftforge.gradle.forge']
Unable to obtain url ([http://files.minecraftforge.net/maven/net/minecraftforge/forge/json]) with etag!

Jewel James
@jeweljames

@AndKram Thanks for answering.
Im observing this on ubuntu . im already running the minecraft instances from two folders.
im using the following params

                                    "client_pool": client_pool,
                                    "agent_names" : [
                                        "MarLo-Agent-0",
                                        "MarLo-Agent-1"],
                                     "step_sleep":0.01,
                                     "kill_clients_after_num_rounds":100,
                                     "kill_clients_retry":10
                                 }

this is reproducible as it happens around the same episode number each time. will attach the log.

Jewel James
@jeweljames
@AndKram - you can find the logs here - https://gist.github.com/jeweljames/788a8517ea76b02fa8a40970ee934398
i have attached the logs from the agents , the two minecraft instances(latest_m1.log and latest_m2.log) and two jstack logs.
ProQianXiao
@ProQianXiao
@AndKram @spMohanty Hello, are there any solutions that decides which mission is running?
Andre Kramer
@AndKram
@ProQianXiao My post from Nov 6th should provide a way to check which of the three games is being played. (Hope I understood the question correctly).
ProQianXiao
@ProQianXiao
@AndKram I tried that , but I met some errors:
Andre Kramer
@AndKram
@jeweljames Both Minecrafts seem to running a mission while one agent host (called from Python) is waiting on second to turn up and the second agent host is saying that all ports are in use. Which would indicate that previous missions are not finishing. Are you calling reset() before the step() function returns "done"? I've opened issue #784 on github malmo for this but have not seen this failure.
ProQianXiao
@ProQianXiao
QQ截图20181217163939.png
I added the codes at the begining of the 'run_agent' function, is that right ?
QQ截图20181217164050.png
Jewel James
@jeweljames
@AndKram im sometimes calling reset() before the step function returns "done". but only after calling close() on that env first.
is that a problem?
Andre Kramer
@AndKram
@jeweljames Better to not call close and re-use the env with reset(). It looks like there is a port leak when closing and the mission is still running? Let's take this to #784.
@ProQianXiao etree is not defined. I think we had this also in MarLo.: from lxml import etree.
ProQianXiao
@ProQianXiao
@AndKram Thanks and that helps. I also want to know whether we can use this method to dertermine the running misson when evaluation.
andrekramer
@andrekramer
@ProQianXiao (Andre on non-work account:) I think so but have not tried by submitting a test.
ProQianXiao
@ProQianXiao
@andrekramer Thank you, and I will have a try.
iZuno-K
@iZuno-K

@andrekramer @AndKram I got errors at auto-evaluation phase:
“Unable to orchestrate evaluation. Core services failed to start…”
and after 1 or 2 episodes:
“Unable to orchestrate submission, please contact Administrators.”
The submitted programs have succeeded the test_submission_locally.sh without errors.
(Issue url:
https://gitlab.crowdai.org/karino_isi/marlo2018/issues/8
https://gitlab.crowdai.org/karino_isi/marlo2018/issues/5
)

Could you check the cause and teach me how to fix it ?
My CrowdAI account is karino_isi.

Lennart
@biggzlar
One more question: suppose I have several different models - is there a way to access the gametype during evaluation?
SP Mohanty
@spMohanty
@iZuno-K : We are investigating the error. and Will get back to you guys soon.
SP Mohanty
@spMohanty
I just tried to make a new submission with the starter kit, and it went through completely fine.
So theres a chance that this might be because of some issue in the actual submitted code.
iZuno-K
@iZuno-K

@spMohanty Thank you for your investigating.

I’ve succeeded the local test based on crowdAI’s instruction (https://github.com/crowdAI/marlo-multi-agent-starter-kit). I tested 1 game with 2 agents and 3 different games with 6 agents. Both tests succeed without errors.

How can I check my submitted code have any issue?

SP Mohanty
@spMohanty
@iZuno-K : Do you test it for multiple episodes locally ?
iZuno-K
@iZuno-K
@spMohanty I tested multiple episodes today. My code cause an error RuntimeError: Attempted to use a closed Session. The reason is I use tf.Session().close() at the end of the run_episode().
Then I modified run.py by moving the tf.Session().close() line to the end of the main function. After that I tested 15 episodes local test and succeeded.
I submitted the modified code but receive Unable to orchestrate evaluation. Core services failed to start....
ProQianXiao
@ProQianXiao
@spMohanty @AndKram I submitted my code but I got the following error ,
1.png
it seems that episode-1 and episode-2 are successful, but I do not know why the later episodes failed.
2.png
ProQianXiao
@ProQianXiao
@spMohanty @AndKram How to solve the problem "Unable to orchestrate evaluation. Core services failed to start...."? Is it a evaluation environment error or code error?
iZuno-K
@iZuno-K
@ProQianXiao @spMohanty @AndKram I solved the problem by removing apt.txt from my repository.
I removed these dependencies and then the evaluator works.
libopenmpi-dev, openmpi-bin (for mpi4py)
libgtk2.0-dev, libglib2.0 (for opencv)
ProQianXiao
@ProQianXiao
@iZuno-K Thanks for your reply, did it work for you ? I checked my environment.yml, in fact there are no these dependencies.
2018-12-31 16-40-09屏幕截图.png
This is mine
iZuno-K
@iZuno-K
@ProQianXiao @spMohanty @AndKram Sorry, that is not the cause... I tried a new submission now with the same dependency with only modified trained parameters. But it failed...
ProQianXiao
@ProQianXiao
2018-12-31 16-46-10屏幕截图.png
I always met this error, did you have same error?
iZuno-K
@iZuno-K
image.png
Yes. I met the error at the 17/18 submissions.
ProQianXiao
@ProQianXiao
That really makes me crazy!!! I have tested locally and everything is fine, I do not know why it failed in the server
iZuno-K
@iZuno-K
Me too. I'm in the same situation.
EC2EZ4RD
@EC2EZ4RD
I met the same problem.
Tejas Jogi
@tdjogi010
Having the same problem ... Unable to orchestrate submission, please contact Administrators.
ProQianXiao
@ProQianXiao
@spMohanty @AndKram It seems that many people have the same error, maybe it is caused by the evaluation environment? Are there any solutions about that?
Lennart
@biggzlar
Hi there, I was just pushing my latest tag and discovered that the challenge ended at 12:00 UTC - however in the text it states, that the challenge ends on 23:59 PST. What's up with that??
andrekramer
@andrekramer
https://xkcd.com/2092/ Happy New Year everyone!
EC2EZ4RD
@EC2EZ4RD
Hi, did anyone receive some email or get some information about how is the competition going?
d33ms
@matthew-egbert
Is there anyway to accelerate the passage of time in Malmo? Or to have the time of day change triggered by an agent touching something (or similar)?
SP Mohanty
@spMohanty
@EC2EZ4RD : We are running the post challenge evaluations, and will get back to you soon. We will pit all the submitted models against each other, and then will have the results soon. Hopefully by the end of this week. Thanks for your patience.
ProQianXiao
@ProQianXiao
@spMohanty Many people meet the error 'Unable to orchestrate submission, please contact Administrators.' when submitting, is this caused by the code or the evaluation server? If it is caused by the evaluation server, could you give us another chance to submit? Thanks very much.