Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    v-prsasa
    @v-prsasa
    @martinsipka yes sure, we will let you know once it's fixed.
    TylerOdenthal
    @TylerOdenthal

    Hey I'm using the Dev Kit to train a Wildlife Camera model.

    I'm wondering if the Dev Kit is water resistant or proof? It is currently sitting on my balcony looking at birds.

    v-iskha
    @v-iskha
    @TylerOdenthal - No, device is not weather proof. Please ensure it is mounted or stored in a dry, cool place. Please refer below link for reference- https://visionaidevkitsupport.azurewebsites.net/?q=is%20the%20camera%20waterproof%3F
    TylerOdenthal
    @TylerOdenthal

    image.png

    I randomly get this distortion on my video stream about every 5 second. Is this something we know how to fix?

    My Bitrate is set to 1.5Mb and stream quality is set to 1080P. I will increase my bitrate in the meantime.

    v-prsasa
    @v-prsasa
    @TylerOdenthal Hi, It looks like there must be defect in camera hardware or network connection. I would suggest you to change the camera and check once.
    TylerOdenthal
    @TylerOdenthal
    I bought a wifi extender, we will see if that fixes it. Hopefully it isn't a hardware defect, that would be unfortunate.
    v-iskha
    @v-iskha
    @TylerOdenthal - Did the WIFI extender fixed the distortion problem for you?
    TylerOdenthal
    @TylerOdenthal
    @v-iskha Sorry for the late reply, I have been working on other aspects of my project. Unfortunately no, none of the settings or WiFi hardware that I have tried solve my distortion problem. I am tempted to buy another Dev Kit, but skeptical.
    I am exploring using the Vision AI Dev Kit for Wildlife applications in partnership with Cornell Lab of Ornithology, but with this distortion. I don't know if I can use the Vision AI Dev Kit or particularly this Vision AI Dev Kit.
    v-iskha
    @v-iskha
    @TylerOdenthal - I suggest you to raise a support ticket with einfochips.com using link - https://www.einfochips.com/partnerships-and-alliances/digital-partnerships/microsoft/microsoft-ai-vision-kit/
    Also I would like to inform you that we have a new camera in "Dev Kit" coming out which is currently in private preview. We expect devkit to go available in sale somewhere 1st quarter of next year. It should be the same price.
    Gerhard Ebinger
    @gerhard67

    I have version v0.2680_Perf installed and like to do a firmware update. But it fails.

    adb devices brings

    adb server is out of date. killing...
    * daemon started successfully *
    List of devices attached
    f6bbef6c device

    1) the update script return "Device is not attached(X)"

    2) the manual version from https://azure.github.io/Vision-AI-DevKit-Pages/docs/Recover_device/ at the point “fastboot flash abl abl.elf” “< waiting for device >” forever.

    3) the adb reboot edl and Qualcomm_Flash_Image_Loader_v2.0.3.5. Even I see the devices on Qualcomm HS-USB Android DIAG 901D (COM2), I get after push download
    • ERROR: function: port_connect:99 Failed to open com port handle
    • ERROR: function: main:314 Could not connect to \.\COM2
    • Download Fail:Sahara Fail:QSaharaServer Fail:Process fail

    v-prsasa
    @v-prsasa
    @gerhard67 Could you try using another dev kit?
    Gerhard Ebinger
    @gerhard67
    @v-prsasa - sorry, no, my company rented me only this one 😏. It runs and I can also access it via adb and via ssh in the config mode (starting adb shell /etc/wlanstart softap). But I can't update the devices
    v-prsasa
    @v-prsasa
    @gerhard67 have you checked the battery of the camera. It should be more than 50% , then only you can update the device. if the battery backup is less it wont work.
    Gerhard Ebinger
    @gerhard67
    @v-prsasa yes I have checked this. You anyway get the msg, that you can do update if the battery is to low. adb shell cat /sys/class/power_supply/battery/capacity delivers 100%
    levi
    wang jeff
    @wangjeff
    image.png

    May I ask a question?
    my device will go not attached when executing the update script
    C:\xx\IoT\v0.5370_Perf>FastbootUpgrade_v6_5.bat
    "Check adb device..."
    "Check battery capacity..."
    "Check fastboot files..."
    "Rebooting to fastboot mode"

    C:\xx\IoT\v0.5370_Perf>adb reboot bootloader
    Press any key to continue . . .
    "Check fastboot devices..."
    "Device is not attached(X)"
    "Fastboot upgrade fail(X)"
    Press any key to continue . . .

    wang jeff
    @wangjeff
    I verify the battery capacity is 100%
    TylerOdenthal
    @TylerOdenthal

    Can we confirm that the v2 cameras are coming out sometime Q1 2021?

    I have been a long time user of the Microsoft ecosystem and Microsoft products, but I have to say I wouldn't recommend this device to anyone in it's current state.

    It may be that I just got a bad camera (which I have order 2 more for $1.1k, an absurd price), but aside from the price, there are some problems:

    • After a couple reboots and model changes, the camera now refuses to update my Custom Vision AI model from the ModelZipUrl.
    • Changing the Video Capture resolution from anything other than 1080P causes the cameras RTSP to crash.
    • There is huge distortion randomly in the RTSP which has been suggested is a hardware malfunction.
    • Documentation on the device is slim to none, good luck to anyone figuring out what any of the properties in the "AIVisionDevKitGetStartedModule" do without diving into GitHub.
    • Activating Audio Capture on the Device should be much easier. Why aren't Audio Config Variables included in the "AIVisionDevKitGetStartedModule" just like the RTSP and Custom Vision Variables?
    • There is quite a stream delay on feeds that are running for longer than 10 minutes. This delay seems to get worse over time.

    Unless some improvements are made, I can't continue to buy these cameras at this price. Exploring making my own solutions or just investing in CORAL dev boards from Google.

    v-iskha
    @v-iskha
    @TylerOdenthal - As of now, yes the new camera is expected in Q1 2021. We will update if there is any change in plan or once we have the new camera available.
    TylerOdenthal
    @TylerOdenthal
    image.png

    New camera out of the box, still getting distortion of the camera on my live stream. I have high quality internet, even bought a wifi extender.

    I mean come on... I guess I'm the idiot that spends a good $1.2k just to try and fix my problem, but this is ridiculous Microsoft.

    Do I really have to shoot some emails to someone like Lili Chang and complain about how crappy a product this Vision AI dev kit is? How can we fix this?

    martinsipka
    @martinsipka
    @TylerOdenthal I had similar experience with the camera and now I am asking for a refund. This simply is an unfinished product and it does not even have a proper technical support. There is no way you can develop a working solution with Microsoft Vision AI kit. I would expect at least a sorry from the team for all the hours wasted on the development of our solutions until we discovered that the VAIDK kit is just an expensive webcam.. and a broken one. I personally switched to CORAL and had the solution ready in two days without any issues. I really wonder why is Microsoft still selling and advertising the thing. It will just do damage to the brand.
    v-prsasa
    @v-prsasa
    image.png
    @TylerOdenthal Hey Tyler, Hello Martin, I understand your concern. So just to cross check whether the issue is with camera or network connection , I tried in my camera and it looks fine for me. I have observed the distortion when we try to move the camera from one place to other but if you keep the camera still at one position there is no distortion. You can see the screenshot of the image which I have captured from VAIDK.
    TylerOdenthal
    @TylerOdenthal
    Does anyone have a link to the v0.5330 firmware? I would like to try that firmware.
    v-prsasa
    @v-prsasa
    Hi @TylerOdenthal As of now we have only this link -https://store.altek.com.tw/qualcomm/downloads/Azure-IoT-Starter-Kit#tab-1 which has the latest firmware, once there is an upgrade of latest firmware they remove the older one with release note.
    TylerOdenthal
    @TylerOdenthal
    Is there a way to use adb to turn on the VAIDK audio capture?
    v-prsasa
    @v-prsasa
    @TylerOdenthal There is no way to use adb to turn on the VAIDK audio. You can go through this link for reference- https://azure.github.io/Vision-AI-DevKit-Pages/docs/community_project03/
    idataJuan
    @idataJuan
    hi
    someone has tried update the version of iot device client sdk in the starter module?
    v-prsasa
    @v-prsasa
    Hi @idataJuan Please go through this link- https://github.com/microsoft/vision-ai-developer-kit/tree/master/camera-sdk. It has the details of camera SDK which may help you.
    idataJuan
    @idataJuan
    but i talk about iot azure sdk
    the version 1 is deprecated
    so61pi
    @so61pi
    I have a few questions about the access users can have on the DevKit, hope someone can help
    • Do we have root access to the filesystem?
    • Can I install additional package to the system (like sudo apt install package on Ubuntu)
    • Do we support deploying native applications (i.e. compiling C/C++ programs and push them to the DevKit)
    • Does the DevKit have secure boot enabled?
    Rohit Thakur
    @1297rohit
    HI all,
    can anyone tell me how to stream video from IOT edge camera and save the stream on local ??
    v-prsasa
    @v-prsasa
    Hi @1297rohit You can follow this link- https://azure.github.io/Vision-AI-DevKit-Pages/docs/RTSP_stream/ for reference. Once you stream it from your vlc media player you can load it to your local machine as well
    Rohit Thakur
    @1297rohit
    can we run a pytorch model on the IOT edge camera ?
    v-prsasa
    @v-prsasa
    According to this document - https://azure.github.io/Vision-AI-DevKit-Pages/docs/frameworks/ I don't think so you can run a pytorch model on the IOT edge camera
    Rohit Thakur
    @1297rohit
    can we stream video from IOT edge camera to the local if we are not on the same network of the camera without the use of VPN.
    v-prsasa
    @v-prsasa
    @1297rohit You have to be in same network and VPN should be connected.
    Rohit Thakur
    @1297rohit
    can we run a model to count objects of a particular type on IOT edge camera
    Rohit Thakur
    @1297rohit
    I am unable to connect the IOT edge camera, i have pay as you go subscription but it is not showing under subscription on the vision camera setup page, giving error code 400
    v-prsasa
    @v-prsasa
    @1297rohit Can you try to do factory reset and check again?
    Rohit Thakur
    @1297rohit
    Unable to select Vision AI Dev Kit under the Object Detection module in Custom Vision. Any idea ??
    DmitryT
    @dmitriyteteruk

    Looks like something was changed in CustomVision API and from now on you cannot choose Export for VAIDK using General Compact domain for Object Detection. I have tried General Compact S1 and it works for Export for VAIDK, BUT it does not work then on VAIDK - module is running, but nothing detected, just an video from camera on web-stream. I have raised an two issues on GitHub https://github.com/microsoft/vision-ai-developer-kit/issues?q=is%3Aopen+is%3Aissue

    Unable to select Vision AI Dev Kit under the Object Detection module in Custom Vision. Any idea ??

    Rohit Thakur
    @1297rohit
    The custom trained General Compact S1 model which was trained on custom vision is not working on VAIDK. gives no output on the rstp stream and nothing in logs as well
    Rohit Thakur
    @1297rohit
    When we update the model url then this value "RtspDataUrl": null is updated and after that "VideoAnalyticsEnabled": false After this the model is not able to predict anything. Does anyone has any idea regarding this. Why does this happen after updating the model with custom vision model instead of the default mobilenet-SSD model.
    Kris Turner
    @kristopherjturner
    Good morning... I have had my dev kit for a few months. Had it at a customer demonstration this week. It kept turning off after running for a while. THought maybe battery? It wasn't plugged into anything and the only module running was the Vision Test module. Anyway, long story short, the device doesn't turn on anymore. At least from what I can tell. I have tried to reset it. Nothing. What is the warranty if any on these devices?