Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Jonathan Colmenares
    @Jonathing
    @Mustafa5775 ForgeGradle is something used for developing mods, so you can't put it on a server.
    @spamvictus new forge maven is https://maven.minecraftforge.net so change your build.gradle file accordingly
    falazar
    @falazar
    @spamvictus it is the gradle channel mapping adding it on.. did you find a solution for it?
    Having some problem.. and two others above.
    @NathanFallet Having same problem, I see where it is coming from, in gradle, did you find a solution?
    PheonixVX
    @PheonixVX
    Is there a Java 16-compatible Forge Gradle?
    K4su
    @K4su
    Hi. I'm trying to use ForgeGradle for Minecraft 1.12. Can I use ForgeGradle 4 and how? When running gradle setupDecompWorkspace it tells me I'm using a deprecated version of ForgeGradle. I've downloaded the MDK as written on the Wiki (Github)
    Su5eD
    @su5ed:matrix.org
    [m]
    You can use FG4 the same way newer versions use it, but it causes several issues on 1.12. For example assets, dependency ATs and coremods not loading.
    TBH just stick with FG2
    xxminersx
    @xxminersx
    Hey! Im currently trying to login in my dev client, but im trying to use a new account which is a microsoft account. is this possible or do i need to wait untill there is a patch for microsoft accounts?
    Su5eD
    @su5ed:matrix.org
    [m]
    Forge currently only supports Yggdrasil auth, so no
    Also not sure when that will come, as there aren't any guidelines for Microsoft auth
    @FinnT730 I see you!
    Curle
    @TheCurle
    thonk
    1 reply
    Torono909
    @Torono909

    Hi. I'm trying to use forge Gradle for minecraft 1.12.2 when running gradlew setupDecompWorkspace it tells me this error
    ERROR:
    To honour the JVM settings for this build a new JVM will be forked. Please consider using the daemon: https://docs.gradle.org/4.9/userguide/gradle_daemon.html.

    FAILURE: Build failed with an exception.

    • What went wrong:
      Unable to start the daemon process.
      This problem might be caused by incorrect configuration of the daemon.
      For example, an unrecognized jvm option is used.
      Please refer to the user guide chapter on the daemon at https://docs.gradle.org/4.9/userguide/gradle_daemon.html
      Please read the following process output to find out more:

    FAILURE: Build failed with an exception.

    • What went wrong:
      java.lang.ExceptionInInitializerError (no error message)

    • Try:
      Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

    • Get more help at https://help.gradle.org

    • Try:
      Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

    • Get more help at https://help.gradle.org

    Su5eD
    @su5ed:matrix.org
    [m]
    That's not enough info. You can try running with --stacktrace, although I recommend you to update to FG5
    Also, use a paste site for logs
    superJK92iscool
    @superJK92iscool
    I am trying to build a mod but I keep getting this https://pastebin.com/TfgVhNP2
    superJK92iscool
    @superJK92iscool
    I made a edit to the paste on pastebin
    if you need the build.gradle file I can paste the text from the file to pastebin
    https://pastebin.com/D1BsVwF6 is the link to the text in the build.gradle file
    superJK92iscool
    @superJK92iscool
    Please let me know as soon as you can because I want to use the mod I am building (form its source code)
    superJK92iscool
    @superJK92iscool
    Turns out I accidentally put a c in the code but now I get this https://pastebin.com/zWV3e3rz
    superJK92iscool
    @superJK92iscool
    I need to know how to fix this
    Su5eD
    @su5ed:matrix.org
    [m]
    Are you using a fork of FG?
    expansionism
    @expansionism
    anyone know why this is happening? https://pastebin.com/6v18nzWD
    Su5eD
    @su5ed:matrix.org
    [m]
    Any details? Is that the full error? How does your buildscript look like?
    foxandsgf
    @foxandsgf
    when i use gradle 2.9 or 2.8,idea warned https://pastebin.com/st2w8jP4.
    1 reply
    when i use gradle 3.0 or later,idea warned https://pastebin.com/pDK2LzEq.
    1 reply
    how can i do?
    JVM:jdk1.8.0_202
    ForgeGradle 2.1.2-g6aa76ec
    Forge:forge-1.8.9-11.15.1.2318-1.8.9
    build could be finished,but always with a warnning.
    Su5eD
    @su5ed:matrix.org
    [m]
    Why 1.8.9?
    Why not use a modern mc version?
    foxandsgf
    @foxandsgf
    to play hypixel network
    so use 1.8.9
    Su5eD
    @su5ed:matrix.org
    [m]
    Hypixel works on never versions, too
    foxandsgf
    @foxandsgf
    but many mod only support 1.8.9,so many player play hypixel on 1.8.9 client...
    its so popular that 1.8.9 mod
    Su5eD
    @su5ed:matrix.org
    [m]
    And what? Modern versions easily outnumber them
    foxandsgf
    @foxandsgf
    thats impossible in hypixel network...maybe new combat mechanism after 1.9
    i know 1.8.9 is a version that released 5 years ago
    Su5eD
    @su5ed:matrix.org
    [m]
    Well then you know you can't expect it to be supported
    Or work without issues
    foxandsgf
    @foxandsgf
    need i to use a older version idea??
    or gradle?
    Su5eD
    @su5ed:matrix.org
    [m]
    No, you need a newer version of minecraft
    foxandsgf
    @foxandsgf
    why some1 can make 1.8.9 mod???
    playing hypixel netword 'd to use 1.8.9 ;w;
    Su5eD
    @su5ed:matrix.org
    [m]
    What
    1 reply
    Su5eD
    @su5ed:matrix.org
    [m]
    Oh no you found me
    finnt7300
    @finnt7300:matrix.org
    [m]
    and yes, I have 2 0 here....
    don't ask me why xd
    Skeppyy
    @KeppyssDev
    hello?
    how to install optifne to forgegradle??
    1 reply