Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jan 09 12:51
  • Jan 09 12:51
  • Jan 09 00:13
  • Jan 09 00:12
  • Jan 04 04:42
    bundabrg commented #210
  • Dec 31 2019 02:01
    bundabrg labeled #212
  • Dec 31 2019 02:01
    bundabrg assigned #212
  • Dec 31 2019 02:01
    bundabrg opened #212
  • Dec 30 2019 09:23
    bundabrg commented #211
  • Dec 06 2019 15:55
    OskarZyg commented #211
  • Dec 06 2019 10:23
    jastice commented #209
  • Dec 06 2019 00:54
    bundabrg closed #208
  • Dec 06 2019 00:52
    bundabrg commented #209
  • Dec 06 2019 00:48
    bundabrg commented #211
  • Dec 05 2019 22:50
    OskarZyg commented #211
  • Dec 05 2019 22:42
    OskarZyg opened #211
  • Dec 05 2019 22:37
    OskarZyg commented #177
  • Nov 21 2019 17:51
    iomatix opened #210
  • Nov 16 2019 15:51
    jastice commented #209
briwn_amcw
@adm_amcw_twitter
No idea how to do it on a fresh local setup, the server is about as new as it get, just created it spigot 1.10.2 other than standard plugins gringotts was the first econmy of any sort, other than Vault plugin I suppose
Justin Kaeser
@jastice
no other plugins?
briwn_amcw
@adm_amcw_twitter
worldgaurd, worldedit, dynmap, vault ,PEX, essentials X
Justin Kaeser
@jastice
you can just create a server locally with just the minimum plugins. like vault, gringotts, worldguard
briwn_amcw
@adm_amcw_twitter
I have added more now for economy since first installing Gringotts everything else is functioning fine just can't make a region vault. It's not a game breaker I will work around it
Justin Kaeser
@jastice
and see if the error still happens
maybe PEX or something is interfering with the permission
briwn_amcw
@adm_amcw_twitter
Maybe but I don't know what I could change there to make a difference. I am creating everything as OP with full permissions
Justin Kaeser
@jastice
you'll have to localize the error. try without those plugins
briwn_amcw
@adm_amcw_twitter
Can't. Under a lot of pressure to get the new world going. I am way to far now. It doesn't create any errors. Nothing in console, log it just doesn't make the vault. I probably has more to do with the latest spigot build?
Justin Kaeser
@jastice
it's possible. if you can't think you can find the factor making it break, I can't help you though, sorry.
buy you know you can just set up a server on your local computer and play around with that, right?
briwn_amcw
@adm_amcw_twitter
I think the plugins need updating for 1.10.2 I have another with a similar problem. No errors it just doesn't perform a function in the yml
Yeah but I don't have time for that now
Justin Kaeser
@jastice
ok then
briwn_amcw
@adm_amcw_twitter
Appreciate the response
Legendnems@WoW
@Legendnems_twitter
hi guys, anyone could take a look at an Gringotts error i get by default?
[23:01:55] [Server thread/INFO]: [Gringotts] Enabling Gringotts v2.9
[23:01:55] [Server thread/INFO]: Can not test connection as heartbeatsql is not set
[23:01:55] [Server thread/INFO]: Closing Connection[Gringotts.1] psReuse[0] psCreate[1] psSize[0]
[23:01:55] [Server thread/INFO]: [Gringotts] Initializing database tables.
[23:01:55] [Server thread/INFO]: runScript
[23:01:55] [Server thread/INFO]: executing 1 of 2 create table gringotts_account ( id integer primary key,...
[23:01:55] [Server thread/INFO]: executing 2 of 2 create table gringotts_accountchest ( id integer primary...
[23:01:55] [Server thread/INFO]: ... end of script
[23:01:55] [Server thread/INFO]: [Gringotts] Player database not migrated to UUIDs yet. Attempting migration
[23:01:55] [Server thread/INFO]: [Gringotts] Created backup of Gringotts database as Gringotts.db.bak
[23:01:55] [Server thread/INFO]: [Gringotts] Players to UUIDs database migration complete.
[23:01:55] [Server thread/INFO]: [Gringotts] Found Bukkit version: 1.10.2-R0.1-SNAPSHOT. All features enabled.
[23:01:55] [Server thread/ERROR]: Error occurred while enabling Gringotts v2.9 (Is it up to date?)
java.lang.NoClassDefFoundError: net/milkbowl/vault/item/Items
at org.gestern.gringotts.Configuration.unitName(Configuration.java:270) ~[?:?]
at org.gestern.gringotts.Configuration.parseCurrency(Configuration.java:182) ~[?:?]
at org.gestern.gringotts.Configuration.readConfig(Configuration.java:115) ~[?:?]
at org.gestern.gringotts.Gringotts.reloadConfig(Gringotts.java:189) ~[?:?]
at org.gestern.gringotts.Gringotts.onEnable(Gringotts.java:70) ~[?:?]
at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:292) ~[spigot-1.10.2.jar:git-Spigot-850da7e-e20928f]
at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:337) [spigot-1.10.2.jar:git-Spigot-850da7e-e20928f]
at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot-1.10.2.jar:git-Spigot-850da7e-e20928f]
at org.bukkit.craftbukkit.v1_10_R1.CraftServer.enablePlugin(CraftServer.java:373) [spigot-1.10.2.jar:git-Spigot-850da7e-e20928f]
at org.bukkit.craftbukkit.v1_10_R1.CraftServer.enablePlugins(CraftServer.java:323) [spigot-1.10.2.jar:git-Spigot-850da7e-e20928f]
at net.minecraft.server.v1_10_R1.DedicatedServer.init(DedicatedServer.java:204) [spigot-1.10.2.jar:git-Spigot-850da7e-e20928f]
at net.minecraft.server.v1_10_R1.MinecraftServer.run(MinecraftServer.java:535) [spigot-1.10.2.jar:git-Spigot-850da7e-e20928f]
at java.lang.Thread.run(Unknown Source) [?:1.8.0_40]
Caused by: java.lang.ClassNotFoundException: net.milkbowl.vault.item.Items
at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.8.0_40]
at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[spigot-1.10.2.jar:git-Spigot-850da7e-e20928f]
at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot-1.10.2.jar:git-Spigot-850da7e-e20928f]
at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_40]
at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_40]
... 13 more
[23:01:55] [Server thread/INFO]: Beginning UUID conversion, this may take A LONG time
i just installed this addon and it gives above error. If i for example type: /money i get the result: "/money /moneypay <amount> <player> " instead of the balance etc. Also i cant create a vault with the [Vault] sign.
do you need to "Vault" plugin to use Gringotts? Becouse i dont have that addon
Legendnems@WoW
@Legendnems_twitter
I guess nobody is online, but i will check the history on my question later.
Justin Kaeser
@jastice
@Legendnems_twitter do you have the Vault plugin installed?
Justin Kaeser
@jastice
ah, Vault might be necessary for that operation. I should fix it so that it handles absence more gracefully, but in practice almost everybody uses it anyway
Legendnems@WoW
@Legendnems_twitter
@jastice Thanks, that solved the issue, working like a charm now <3 keep up the good work!
Justin Kaeser
@jastice
:)
briwn_amcw
@adm_amcw_twitter
I am having an emeralds added to my vault for no reason, may be on a timed basis but haven't figured that out just all the sudden when I check money there is an extra emerald?
briwn_amcw
@adm_amcw_twitter
Also I am using the MC Jobs plugin and I think it is related to that after giving it some thought. The emeralds are being added as 1 to the vault when my inventory passes a full emerald value performing a job.
Justin Kaeser
@jastice
that sounds about right
briwn_amcw
@adm_amcw_twitter
So my only option then is to disable the vaults? Unless you have any other suggestions.
Justin Kaeser
@jastice
if you don't want stuff ending up in the vault, yes. It's working as intended
briwn_amcw
@adm_amcw_twitter
Well the problem is I am getting double paid. Into to my inventory and also into the vault as I earn money from a job. I will test some more to be sure but quite positive there is a double pay happening.
Justin Kaeser
@jastice
are the values you get from /money not as expected?
3ssej
@3ssej__twitter
thanks for replying, I just saw that...
I can't update to 2.9 as my server provider isn't updated to java 8 yet... I really need this plugin though. (I have contacted my server host about this, probably going to switch hosts)
Justin Kaeser
@jastice
yeah, they should... but 2.9 won't change anything about this particular thing
3ssej
@3ssej__twitter
someone actually told me that it was within the area of the currency units
I'm not sure what though
3ssej
@3ssej__twitter
do the item names have to be capitalized? Do they need to be the item IDs?
Justin Kaeser
@jastice
@3ssej__twitter confused you there for a moment, what were you referring to?
3ssej
@3ssej__twitter
?
in the config file, where you specify the different levels of currency
briwn_amcw
@adm_amcw_twitter
the values are correct. But after more testing what is happening is the money from MC jobs is being moved into the vault when it hits a full emerald. The inventory shows the decimal values like 8.5 but when a whole emerald is reached like 9 then the vault is increased by 1 while the inventory will still keep the decimal value paid. I guess it is moving the whole emerald from inventory into the vault rather than leaving it in my inventory. Not a big deal now there is no double pay but then the player needs to withdraw from the vault when they want the money it will just confuse some.
Justin Kaeser
@jastice
@adm_amcw_twitter Ah right. Yeah, that's just how it's supposed to work. If you have both vaults and inventory one or the other will have to be used at some point
@3ssej__twitter the item names should be the ones used in the game as IDs
3ssej
@3ssej__twitter
alright I'll try changing them a bit
Justin Kaeser
@jastice
yeah. by eliminating them one by one you should be able to find out the problem.
unfortunately the parser doesn't give better error messages..
briwn_amcw
@adm_amcw_twitter
The only commands that work are money and money pay? Withdraw and deposit don't. And the earlier problem I believe is because it's treating the vault I created from a chest as an enderchest vault? I have that turned off in the config.
Justin Kaeser
@jastice
why do you think it's treating it like an enderchest?
and is there any error doing withdraws?