Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Sep 20 18:46
    AntoxaSa closed #184
  • Sep 19 19:15
    AntoxaSa opened #184
  • Sep 18 17:48
    tinkerborg commented #13
  • Sep 17 09:18
    fastbike commented #39
  • Sep 17 08:02
    matthandel commented #39
  • Sep 15 21:57
    tomasgatial commented #13
  • Sep 15 17:26
    tomasgatial commented #13
  • Sep 12 15:01
    SwiCago commented #13
  • Sep 12 15:00
    SwiCago commented #13
  • Sep 12 15:00
    SwiCago commented #13
  • Sep 12 15:00
    SwiCago commented #13
  • Sep 12 14:59
    SwiCago commented #183
  • Sep 12 14:59
    SwiCago closed #183
  • Sep 07 17:48
    AntoxaSa commented #183
  • Sep 02 22:32
    xcusso commented #13
  • Sep 02 20:55
    frspp commented #13
  • Sep 02 01:10
    jb123567 commented #183
  • Sep 01 11:23
    AntoxaSa commented #183
  • Sep 01 11:22
    AntoxaSa commented #183
  • Sep 01 07:12
    fastbike commented #183
jarnomm
@jarnomm
Hi, trying to get older msz-fd35va model to work with Wemos D1 mini. Apparently there is something wrong with my setup as i cannot power on AC after connecting Wemos using premade Cellpro pigtail cable. I know this model is not on the support list but as it seems to have proper connector in control board and its also compatible with melcloud unit i thought it would work. Any ideas what could be wrong,
I've followed Chris Davis' Blog closely but apparrenly there is something with my connections or this particular model is really not compatible? D1 itself is ok, works and can communicate with mqtt while disconnected from AC.
d4rkmen
@d4rkmen
hi, i believe its about 3v3 vs 5v TTL
i have same AC model and also no luck with d1 mini
same time nodemcu works fine
Euton2020
@Euton2020
« case 0x06: { // status
heatpumpStatus receivedStatus;
receivedStatus.operating = data[4];
receivedStatus.compressorFrequency = data[3];
          // callback for status change -- not triggered for compressor frequency at the moment
          if(statusChangedCallback && currentStatus.operating != receivedStatus.operating) {
            currentStatus.operating = receivedStatus.operating;
            currentStatus.compressorFrequency = receivedStatus.compressorFrequency;
            statusChangedCallback(currentStatus);
          } else {
            currentStatus.operating = receivedStatus.operating;
            currentStatus.compressorFrequency = receivedStatus.compressorFrequency;
          }

          return RCVD_PKT_STATUS;
        }
hello, i am having trouble understanding how decoded info is published in MQTT. could you explain to me?
Euton2020
@Euton2020
I will try to modify the .ino at the level of [root info] by what is missing I think just a line for that publish
Turbobussi
@Turbobussi
@SwiCago i did managed upload software to esp-01 board. When i booted i entered wifi & passoword. But it never joined wifi network. Also when push save & reboot that won't work also. When put same program to wemos mini it join find to wifi network. Any suggestions?
SwiCago
@SwiCago
@Turbobussi what ino file you using? The examples in this library all have wifi info hardcoded in .h file of sample. If you are using a firmware that asks you enter the info after boot, then it is not from my repo. Ask the owner of the repo you downloaded from what to do
mattkerrison
@mattkerrison

So something I didn't realise is that incorrectly wiring the esp can fry the board.

I did a less than stellar soldering job, plugged it in via the CN105 port, switched mains power on and when I came back smelt a faint smoke smell. entire unit dead, luckily was still in warranty, MSZ-AP35VGD definitely seems to be supported so I can only assume it was my shitty soldering, just a word of warning to others, you can damage your unit if not done properly.

Ordered some JST headers and will do it a little neater on my second unit and hopefully won't break anything 😂

SwiCago
@SwiCago
@mattkerrison lesson learned. That is why you triple check everything.
Amayii
@amayii0
@mattkerrison, would you mind sharing pics of wiring? By any "chance" is that related to using 12v instead of 5v line?
mattkerrison
@mattkerrison
@amayii0 Sure, sorry missed messages here, pretty sure I still have the abomination I created, will post a pic tonight if I can dig it up

@SwiCago Absolutely, also 2am is a time for sleep and not for hacking things together!
I was honestly surprised the whole board was killed, I (naively) assumed there would be a fuse or some kind of protection.

I've got some more D1's on the way (I could not for the life of me get the ESP-01's to flash, I think it's to do with having to jump a pin whilst plugged into the serial-to-usb adapter) so I'll give it another crack on the other aircon unit (same model) when they arrive.

mattkerrison
@mattkerrison
As rubbish as it was (I was going to tidy before installing it) it doesn't look like the solder joints were bridging, so just to clarify I had the right wiring?
1.PNG
2.PNG
3.PNG
d4rkmen
@d4rkmen
it looks incorrect
mattkerrison
@mattkerrison
CN105_ESP8266.png
@d4rkmen I wish I had seen those images in the first place. I misinterpreted this diagram ^, And read it as red wire is 12v (ie cut it off) not that the CN105 connector is red 😂
You may've saved my second aircon unit haha
d4rkmen
@d4rkmen
@mattkerrison 😮😮😮
Amayii
@amayii0
IMG_20190126_103254.jpg
here is a (blurry:() image of my Wemos D1 before putting it into unit (I have 4 like this one)
Amayii
@amayii0
IMG_20190126_103300.jpg
mattkerrison
@mattkerrison

In a renewed effort I decided to have another crack at the project with ESP-01s as I'm still waiting for more D1 Mini's to arrive.
I was able to flash them with the mitsubishi2MQTT project. I connected to the new AP, gave it the credentials and then they seem to intermittently join the wifi, I can load the webpage but it lags and timeouts, then drops off the network. They're currently just connected to 5v usb power through the adapter board, I assume it should function without the pins plugged into the aircon?

I bought these with the adapter board
tried both 1M (64k SPIFFS) & 1M (512k SPIFFS) with no difference, tried 3 different ESPs. I'm assuming unlike the HeatPump project mitsubishi2MQTT is better suited to a D1 mini, or is there another obvious thing I've missed?

mattkerrison
@mattkerrison

update board manager in Arduino IDE to the latest version (2.6.3 in my case) and insert 1 simple line in the code: #define PUYA_SUPPORT 1
Then all works perfectly...as far as I can tell

I did see this above, I may try it tonight and see if it fixes it for me

Amayii
@amayii0
even if i successfully use Wemos D1 Mini, most will recommend https://www.nodemcu.com/
Andrea De Dominicis
@dedins
Hi guys, anyone knows where I can find the CN105 port on PEAD-M71JA (Horizontal Ducted Unit)?
I have an Ecodan system, already connected a MAC­-567-IF­E to the ecodan unit, but I'm able to control only water from that. I guess I will need to attach to the PEAD unit in order to control AC
Docteur-No
@Docteur-No
@dedins If you have a MAC­-567-IF­E it is already plugged on the CN105 socket of your PEAD-M71JA and it is able to tune all parameters of your installation. I used this solution the problem for me was MELCLOUD as I don't like the cloud for this kind of automation
Docteur-No
@Docteur-No
@dedins I have a PEAD-140-JAQ which is bigger than yours but perhaps the circuit board is the same. CN105 is a the top right of the board, it is red and CN105 is written at right on the side of the PCB
becmar39
@becmar39
Somebody knows how to get it working with Tasmota? Do I need to activate something in Tasmota?
Matthew Kelch
@kelchm
What is everyone doing for remote temperature sensing these days? Particularly for ducted units having a propper temperature sensor in the room is pretty critical IMO.
Andrea De Dominicis
@dedins

@dedins I have a PEAD-140-JAQ which is bigger than yours but perhaps the circuit board is the same. CN105 is a the top right of the board, it is red and CN105 is written at right on the side of the PCB

thanks, actually the problem I have is that I didn't even find the board :D

the unit is hidden in the ceiling and I can't find it
Docteur-No
@Docteur-No
@dedins :D Find where the air is sucked the PEAD is probably very close
Andrea De Dominicis
@dedins
ok thanks! do you know if It should be a central one? or the PEAD is usually installed in each room?
Docteur-No
@Docteur-No
@dedins Yes PEAD is central a duct network with air outlet vents in each room
Amayii
@amayii0
Maybe time to get a cheap 5m Wi-Fi Endoscope. For absolute dirt cheap, that's around 15-20€ at
SwiCago
@SwiCago
@kelchm I use dht22 with an esp1 for remote temperature, for my ducted units. I hide the sensor esp combo in a faux candle.
Euton2020
@Euton2020
good evening, I just saw on github a person proposing a program for the Mitsubishi Ecodan air/water with the Cn105 connector, based on the research done here. the protocol is the same as for the heatpumps but with different addresses. Wouldn't it be interesting to test these addresses?
Euton2020
@Euton2020
good evening @SwiCago, I propose to do tests in 0x1A to see if it responds to an MSZ-AP50VG heatpump.
How can I send this type of packet to the heatpump?
Euton2020
@Euton2020
good evening I have just modified the automatic loop by adding 0xa1 and 0xa2 no answer
becmar39
@becmar39
Hi all, got my AC Working. Only {"roomTemperature":20,"operating":false}" is always at status "false". Temp is working fine. Any idea?
Iam using Arduino example: mitsubishi_heatpump_mqtt_esp8266_esp32